LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-29-2007, 10:07 PM   #1
Brooder
LQ Newbie
 
Registered: Nov 2007
Posts: 3

Rep: Reputation: 0
sdb1 isn't mounting right


I installed Linux Ubuntu a few months ago and managed to mount both my C and D drives NTFS partitions after a lot of research and messing around. I uninstalled linux at some point and now I just reinstalled it and I am trying to mount my drives, but even though my C drive got mounted automaticly with no problem i cant get my D: drive to work.

The C and D drives are sda1 and sdb1 respectively from what the hardware information screen tells me.

My C drive is perfectly mounted in /media/sda1. There is also a folder /media/sdb1, but it is empty when I open it, which is just plain wrong as it should have 180GB of files in there.

I tried to mount it manually with the command:

"sudo mount -t ntfs-3g /dev/sdb1 /mnt/d"

but I get the error:

"$LogFile indicates unclean shutdown (0, 0)
Failed to mount '/dev/sdb1': Operation not supported
Mount is denied because NTFS is marked to be in use. Choose one action:

Choice 1: If you have Windows then disconnect the external devices by
clicking on the 'Safely Remove Hardware' icon in the Windows
taskbar then shutdown Windows cleanly.

Choice 2: If you don't have Windows then you can use the 'force' option for
your own responsibility. For example type on the command line:

mount -t ntfs-3g /dev/sdb1 /mnt/d -o force

Or add the option to the relevant row in the /etc/fstab file:

/dev/sdb1 /mnt/d ntfs-3g defaults,force 0 0"

Could anyone spare some time to help me figure out how to get my D drive "sdb1" mounted properly? it should be possible since it worked in teh past.
 
Old 11-29-2007, 11:28 PM   #2
Slokunshialgo
Member
 
Registered: Jan 2006
Distribution: Ubuntu 9.04, Fedora 10
Posts: 76

Rep: Reputation: 17
I've had similar errors before, and there was one simple thing to solve it... Since you installed Ubuntu, have you started Windows? The most common cause is that Windows crashed, something went wrong when Windows unmounted it, or you turned the power off without shutting it down. The easiest solution is to normally start Windows, then shut it down, letting it cleanly go into reboot, or power off. This will take the mark of it being in use off, and should allow you to mount it.

However, if this does not work, there is one alternative I know of. However, I neither endorse this, nor suggest it, but it's an option...

mount -f ntfs-3g /deb/sdb1 /mnt/d

The -f forces it to mount, even if there are errors.
 
Old 11-29-2007, 11:34 PM   #3
Brooder
LQ Newbie
 
Registered: Nov 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Ok, thanks for the reply. I'll give it a try and get back with the result.
 
Old 11-29-2007, 11:38 PM   #4
Brooder
LQ Newbie
 
Registered: Nov 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks for the help, it worked and is mounted fine now.
I was really stomped on this one since no matter what I tried the thing just wouldn't mount.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
why I can't find /dev/sdb1 in fdisk -l breeze027 Linux - Server 1 08-02-2007 05:44 AM
Can't mount sdb1 Fixed_it Linux - Newbie 38 04-15-2007 04:27 PM
where are files after mount sdb1? LetMeTryToo Linux - Newbie 3 11-08-2006 04:52 AM
External USB HDD"Mounting local filesystems: /dev/sdb1 is not a valid block device" manudath Linux - Hardware 3 12-13-2004 10:59 PM
sdb but no sdb1? Moebius Linux - Hardware 3 02-15-2004 07:16 AM


All times are GMT -5. The time now is 05:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration