LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 02-01-2012, 12:14 PM   #1
Macburp
LQ Newbie
 
Registered: Jan 2012
Posts: 8

Rep: Reputation: Disabled
SD Card - 'Permission denied' for anything installed from source


My setup - Asus eeepc 701 with 4GB SSD and Kinston Class 10 16GB SD Card, running Linux Mint 9 (Katya).

Due to lack of disk space I've moved /home to the SD card. I previously had /home on a 4GB card, which worked well once set up.

The SD card is mounted in fstab as follows -

Code:
UUID=[uuid, too long to quote here] /home ext2 defaults,user,noatime,errors=continue 0 0
The first program I installed from source was Dropbox, which I have installed several times before. The command that runs dropbox is

Code:
~/.dropbox-dist/dropboxd
to which the pc said -

Code:
~/.dropbox-dist/dropboxd: Permission denied
I tried running the program as root, didn't work. Checking permissions for dropboxd showed the following -

Code:
-rwxr-xr-x 1 macburp macburp      258 2012-01-18 18:53 dropboxd
thi seems to indicate that the files is executable, so why is permission denied?

I've had this issue with other programs too, which indicates that I have an issue with the SD card rather than dropbox.

What can I try next to resolve this?

tia
 
Old 02-01-2012, 12:49 PM   #2
suicidaleggroll
Senior Member
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 2,409

Rep: Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883
Add exec to the mount options in fstab

Code:
defaults,user,noatime,exec,errors=continue
 
Old 02-01-2012, 01:28 PM   #3
SecretCode
Member
 
Registered: Apr 2011
Location: UK
Distribution: Kubuntu 11.10
Posts: 562

Rep: Reputation: 101Reputation: 101
Are you running with sudo?
I agree that you should have permissions to run ~/.dropbox-dist/dropboxd itself, but the error may be coming from within the code.

I don't see why those mount options should give this problem, but can you try it with defaults,errors=continue and even with rw,exec,suid,sync,errors=remount-ro (you probably don't want sync for long term use on an SD card, though)

---------- Post added 2012-02-01 at 21:29 ----------

Quote:
Originally Posted by suicidaleggroll View Post
Add exec to the mount options in fstab

Code:
defaults,user,noatime,exec,errors=continue
According to my reading of man mount, defaults implies exec. But it seems like it has to be something to do with the mount options.
 
Old 02-01-2012, 02:37 PM   #4
suicidaleggroll
Senior Member
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 2,409

Rep: Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883
Quote:
Originally Posted by SecretCode View Post
According to my reading of man mount, defaults implies exec. But it seems like it has to be something to do with the mount options.
When you mount with the "user" option, noexec is the default

Code:
              user   Allow an ordinary user to mount the  file  system.   The
                     name  of the mounting user is written to mtab so that he
                     can unmount the file system again.  This option  implies
                     the options noexec, nosuid, and nodev (unless overridden
                     by  subsequent  options,   as   in   the   option   line
                     user,exec,dev,suid).
 
Old 02-01-2012, 02:48 PM   #5
SecretCode
Member
 
Registered: Apr 2011
Location: UK
Distribution: Kubuntu 11.10
Posts: 562

Rep: Reputation: 101Reputation: 101
Aha. We have a suspect.
 
Old 02-01-2012, 05:00 PM   #6
Macburp
LQ Newbie
 
Registered: Jan 2012
Posts: 8

Original Poster
Rep: Reputation: Disabled
Added 'exec' to fstab as suggested, and rebooted. I then tested by running the Flaah-aid plug-in in firefox, which opens a terminal and writes to /home - previously this plug-in would hang at an open terminal window.

Well, flash-aid ran fine, so I think this one is solved. Thanks to all for advice and assistance.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Permission denied Fedora 16 - just installed jorran Fedora 1 01-12-2012 03:57 PM
Installed slackware-try to access FAT32 file partition-permission denied-? linus72 Slackware 10 03-23-2009 08:23 AM
can't execute c++ binaries, "permission denied"... even though permission is 777 SerfurJ Programming 14 02-20-2009 04:50 AM
Permission Denied.. Julinho Linux - Newbie 3 06-18-2007 07:40 PM
'permission denied" inspite of right permission flags on network drive anirudhvij Linux - Enterprise 8 05-22-2007 05:57 AM


All times are GMT -5. The time now is 05:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration