LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-07-2004, 08:30 AM   #1
Joe Soap
Member
 
Registered: Sep 2001
Location: Switzerland
Distribution: Debian, Sidux
Posts: 225

Rep: Reputation: 30
Question Scsi emulation - audio cd won't play anymore


I have an IDE DVD-writer and a SCSI cd-rom on my Debian (2.4.22) system. To use xcdroast, I enabled SCSI emulaton and edited my fstab to look as follows
---------------------------------------------------------------------
# /etc/fstab: Tabelle einzubindender Dateisysteme.
#
# <Dateisystem> <Mountpunkt> <Typ> <Optionen> <dump> <pass>
/dev/hda1 / reiserfs defaults 0 0
/dev/sda1 none swap sw 0 0
proc /proc proc defaults 0 0
/dev/fd0 /floppy auto user,noauto 0 0
# /dev/cdrom /cdrom iso9660 ro,user,noauto 0 0
/dev/hda5 /home reiserfs defaults 0 0
/dev/hda6 /usr reiserfs defaults 0 0
/dev/hda7 /var reiserfs defaults 0 0
/dev/sda2 /xtra reiserfs defaults 0 0
/dev/hda8 /dl reiserfs defaults 0 0
/dev/scd0 /scsi iso9660 ro,user,noauto 0 0
/dev/scd1 /dvd iso9660 ro,user,noauto 0 0
----------------------------------------------------------------------------------

My original DVD line (/dev/cdrom) was commented out and I inserted /dev/scd0 (the scsi cd-rom) and /dev/scd1 (the DVD writer).

Xcdroast is happy, but XMMS (amongst others) is not. I know that I have to change whatever points to /cdrom to point to /dvd, but I have no idea how.

For what it's worth, cdrecord -scanbus gives the following output:
------------------------------------------------------------------------------------
Cdrecord-Clone 2.01a19 (i686-pc-linux-gnu) Copyright (C) 1995-2003 Jörg Schilling
Linux sg driver version: 3.1.25
Using libscg version 'schily-0.7'
scsibus0:
0,0,0 0) 'SEAGATE ' 'ST39103LW ' '0001' Disk
0,1,0 1) *
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) 'NEC ' 'CD-ROM DRIVE:466' '1.06' Removable CD-ROM
0,6,0 6) *
0,7,0 7) *
scsibus1:
cdrecord.mmap: Warning: controller returns wrong size for CD capabilities page.
1,0,0 100) 'ATAPI ' 'DVD DUAL 4XMax ' '2.17' Removable CD-ROM
1,1,0 101) *
1,2,0 102) *
1,3,0 103) *
1,4,0 104) *
1,5,0 105) *
1,6,0 106) *
1,7,0 107) *
-----------------------------------------------------------------------------------------------------

Any help, ideas and pointers will be welcome.

Joe
 
Old 02-07-2004, 09:12 AM   #2
dopefish
Member
 
Registered: Nov 2003
Location: Northcliffe, WA
Distribution: Slackware 12.0
Posts: 481

Rep: Reputation: 30
you could redirect the link /dev/cdrom to whichever drive your using for audio cd's
ln -s /dev/scd1 /dev/cdrom
 
Old 02-07-2004, 11:03 AM   #3
Joe Soap
Member
 
Registered: Sep 2001
Location: Switzerland
Distribution: Debian, Sidux
Posts: 225

Original Poster
Rep: Reputation: 30
Thanks, I tried it, but it didn't solve the problem.

When I do ls -l /dev/cdro* the output looks like this:
------------------------------------------------------------------------
lrwxrwxrwx 1 root root 4 Feb 7 15:57 /dev/cdrom -> /dvd
lrwxrwxrwx 1 root root 9 Feb 5 20:43 /dev/cdrom0 -> /dev/scd0
lrwxrwxrwx 1 root root 9 Feb 5 20:43 /dev/cdrom1 -> /dev/scd1
------------------------------------------------------------------------

Any further ideas?
 
Old 02-07-2004, 11:28 AM   #4
dopefish
Member
 
Registered: Nov 2003
Location: Northcliffe, WA
Distribution: Slackware 12.0
Posts: 481

Rep: Reputation: 30
You can also change the input for the XMMS cd input plugin
Right click on XMMS Options->Preferences
go to the Audio I/O Plugins tab and click CD Audio Player plugin then click configure
 
Old 02-07-2004, 12:28 PM   #5
urka58
Member
 
Registered: Nov 2003
Distribution: slackware 14
Posts: 540

Rep: Reputation: 32
Once you extabilished what name has the device after enabling ide-scsi emulation
make sure you have permissions to access that drive as user.
Try using this device first as root and if working properly look for whatever group owns such device and add yourself as normal user to such group.
On Slackware usually disk group owns cdroms, dvdroms etc.
May be debian has different setup
Hope this helps
Ciao
 
Old 02-09-2004, 04:25 AM   #6
Joe Soap
Member
 
Registered: Sep 2001
Location: Switzerland
Distribution: Debian, Sidux
Posts: 225

Original Poster
Rep: Reputation: 30
Thanks for the advice. I'm at work at the moment, so won't have an opportunity to try it until tonight, but will post the result as soon as I've tried it.
 
Old 02-09-2004, 02:14 PM   #7
Joe Soap
Member
 
Registered: Sep 2001
Location: Switzerland
Distribution: Debian, Sidux
Posts: 225

Original Poster
Rep: Reputation: 30
Problem solved.

I checked the permissions and they seemed to be ok. Then I did as dopefish suggested and changed XMMS' input and, just for good measure, I added a 2nd drive and right now XMMS is happily playing from both drives.

Thanks very much for your help.
 
Old 02-09-2004, 03:40 PM   #8
Joe Soap
Member
 
Registered: Sep 2001
Location: Switzerland
Distribution: Debian, Sidux
Posts: 225

Original Poster
Rep: Reputation: 30
Well, problem not COMPLETELY solved...

As I said in my previous post, XMMS now plays happily from either cd-drive. However, it seems that some other apps are still a tad confused.

ripperx, using cdparanoia, complains that it cannot find /cdrom. Question is, how do I get /cdrom to point to /dvd - where my scsi-emulated ide-dvd is mounted/available/whatever? I've tried to symlink it, but after
--------------------
ln -s /dvd /cdrom
--------------------
ls -al /cdrom shows me this:
-------------------
total 3
drwxr-xr-x 2 root root 120 Feb 9 20:52 .
drwxr-xr-x 27 root root 680 Feb 9 17:46 ..
lrwxrwxrwx 1 root root 7 Feb 9 17:46 cdrom0 -> /cdrom0
lrwxrwxrwx 1 root root 4 Feb 9 20:52 dvd -> /dvd
lrwxrwxrwx 1 root root 9 Feb 7 16:57 scd1 -> /dev/scd1
--------------------

Any ideas, suggestions, hints?
 
Old 02-10-2004, 01:03 AM   #9
dopefish
Member
 
Registered: Nov 2003
Location: Northcliffe, WA
Distribution: Slackware 12.0
Posts: 481

Rep: Reputation: 30
Try making a link to your actual dvd device like
ln -s /dev/scd1 /cdrom
also try creating the link to /dev/cdrom
ln -s /dev/scd1 /dev/cdrom
 
Old 02-10-2004, 11:27 AM   #10
Joe Soap
Member
 
Registered: Sep 2001
Location: Switzerland
Distribution: Debian, Sidux
Posts: 225

Original Poster
Rep: Reputation: 30
Man this is weird. It still doesn't work.

This is the output of ls -al /dev/cdrom:
-----------------------------------------------------
lrwxrwxrwx 1 root root 4 Feb 7 15:57 /dev/cdrom -> /dvd
-----------------------------------------------------

and ls -al /cdrom shows this:
-----------------------------------------------------
total 3
drwxr-xr-x 2 root root 120 Feb 10 17:07 .
drwxr-xr-x 27 root root 680 Feb 9 17:46 ..
lrwxrwxrwx 1 root root 7 Feb 9 17:46 cdrom0 -> /cdrom0
lrwxrwxrwx 1 root root 4 Feb 9 20:52 dvd -> /dvd
lrwxrwxrwx 1 root root 9 Feb 10 17:07 scd1 -> /dev/scd1
-----------------------------------------------------

ls -al /dvd shows this:
-----------------------------------------------------
total 4
drwxrwxrwx 2 root root 168 Feb 10 17:07 .
drwxr-xr-x 27 root root 680 Feb 9 17:46 ..
lrwxrwxrwx 1 root root 6 Feb 7 15:57 cdrom -> /cdrom
lrwxrwxrwx 1 root root 11 Feb 9 17:46 cdrom0 -> /dev/cdrom0
lrwxrwxrwx 1 root root 11 Feb 7 15:58 cdrom1 -> /dev/cdrom1
lrwxrwxrwx 1 root root 9 Feb 10 17:07 scd1 -> /dev/scd1
lrwxrwxrwx 1 root root 5 Feb 7 15:57 scsi -> /scsi
-----------------------------------------------------
ls -al /dev/scd1 shows this:
-----------------------------------------------------
brw-rw---- 1 root cdrom 11, 1 Nov 9 16:01 /dev/scd1
-----------------------------------------------------

I'm really at a loss here. The way I see it, I need /cdrom and /dev/cdrom to point to /dev/scd1 or (maybe) /dvd. Should I maybe delete the various symlinks (how does one do that?) and create them from scratch?

As always, help is gratefully accepted.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No audio CD sound due to SCSI emulation ? zahoo Linux - Hardware 1 10-02-2005 02:08 PM
Enabled scsi emulation, now can't play music cd's DuncanM Slackware 2 02-09-2004 01:29 AM
have combo CD-RW/DVD, problem with SCSI emulation, can not play DVD stunix Linux - Hardware 3 10-12-2003 09:23 AM
Playing audio cd while configured under SCSI emulation Hartford Linux - Distributions 2 09-08-2002 03:32 PM
Unable to play audio CDs in a scsi emulated CDRW David Incoll Linux - Newbie 6 04-14-2002 08:46 AM


All times are GMT -5. The time now is 06:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration