LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-06-2003, 07:19 AM   #1
Odd_Bloke
Member
 
Registered: Aug 2003
Location: P'boro, UK
Distribution: Fedora Core 1 (Yarrow)
Posts: 87

Rep: Reputation: 15
SCSI Emulation


I have an ATAPI CD-burner and my burning program (X-CD Roast) warns me that SCSI emulation would be better. How can I enable/install this?

Cheers,
Dan
 
Old 09-06-2003, 08:39 AM   #2
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
try ::
modprobe ide-scsi
as root..
 
Old 09-06-2003, 06:02 PM   #3
Odd_Bloke
Member
 
Registered: Aug 2003
Location: P'boro, UK
Distribution: Fedora Core 1 (Yarrow)
Posts: 87

Original Poster
Rep: Reputation: 15
It couldn't find this command...

Dan
 
Old 09-06-2003, 06:04 PM   #4
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
a) you have to be root
b) if you are root, and if /sbin is not in your path, then you have to type :: /sbin/modprobe ide-scsi
 
Old 09-06-2003, 07:30 PM   #5
Odd_Bloke
Member
 
Registered: Aug 2003
Location: P'boro, UK
Distribution: Fedora Core 1 (Yarrow)
Posts: 87

Original Poster
Rep: Reputation: 15
OK, that is working now, but it doesn't return anything. Does this mean it is not installed? If so, how do I install it?

Cheers,
Dan
 
Old 09-06-2003, 07:37 PM   #6
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
as root do

lsmod


and see if it's there then try your burner again

.
 
Old 09-06-2003, 07:40 PM   #7
Odd_Bloke
Member
 
Registered: Aug 2003
Location: P'boro, UK
Distribution: Fedora Core 1 (Yarrow)
Posts: 87

Original Poster
Rep: Reputation: 15
I get returned the lines (amongst others)::
ide-scsi 11984 0
scsi_mod 106200 1 [ide-scsi]
ide-cd 35196 0 (autoclean)
cdrom 33472 0 (autoclean) [ide-cd]

Yet my burning software still complains that I am not using SCSI emulation. What am I doing wrong?

Dan

EDIT: Added extra, possibly relevant lines.

Last edited by Odd_Bloke; 09-06-2003 at 07:41 PM.
 
Old 09-07-2003, 01:15 AM   #8
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
you need to pass the parameter to the kernel. If you use grub edit your grub.conf, add hdX=ide-scsi to the line where it specifies the kernel then do a reboot.
for example:

kernel /boot/vmlinuz ro root=/dev/hdc3 hdh=ide-scsi

where /dev/hdh is my burner

if u use lilo I think you u add "append=hdX=ide-scsi", i don't use lilo so not exactly sure.

Last edited by Demonbane; 09-07-2003 at 01:16 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
scsi emulation tux66 Slackware 4 05-25-2005 05:26 AM
SCSI emulation bcf2 Mandriva 2 12-22-2004 04:06 PM
scsi emulation or not ? cozye Slackware 5 12-01-2003 03:23 PM
Scsi Emulation!! FearPasion710 Linux - General 3 09-20-2003 05:14 AM
scsi emulation, how? one Slackware 1 09-02-2003 02:58 PM


All times are GMT -5. The time now is 05:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration