LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-12-2005, 02:55 AM   #1
Wedley
LQ Newbie
 
Registered: Nov 2002
Location: Australia
Distribution: Mandrake 10.0 (free version)
Posts: 8

Rep: Reputation: 0
Scrolling Up in Firefox makes it go Back


Before I say anything I should point out that I only just installed Mandrake 10.0 yesterday and I don't really know what I'm doing. Before that it was Windowsmania.

Okay, so I got Firefox installed, java is working, and the net in general has been just peachy. Mozilla and Konqueror both came with Mandrake but I much prefer Firefox, and besides... it took be bloody forever to get java working on it, so I want to keep it.

HOWEVER, it does have a problem which Mandrake and Konqueror do not, which is that every time I scroll up on my mouse's scroll wheel, Firefox will go Back to the last page I was on. If I do it again it'll take one step forward, so scrolling up means switching rapidly between the page I'm on and the page I was at last.

Not being able to scroll up in this way is quite frustrating, as you can imagine. I love scrolling up. At least a quarter of the scrolling I do is up. It's very important to me. As is Firefox. Can anyone help me with this? I've searched around but haven't been able to find anything that deals exactly with this problem.

It's just the standard Microsoft Optical Mouse that came with my computer. It works absolutely perfectly in every other application - only Firefox has this bizarre problem. Before you ask, I have the very latest version of Firefox, and aside from this tedious error it works perfectly. So yes... could somebody please explain what to do, keeping in mind that until just yesterday I was a frequent Windows XP user?
 
Old 04-12-2005, 05:38 AM   #2
h3o
LQ Newbie
 
Registered: Jan 2005
Location: Johannesburg, South Africa
Distribution: Debian
Posts: 22

Rep: Reputation: 15
hmmm thats pretty weird, all i can think of is checking your extensions, maybe there an extension installed that allows you to do that, check tools->extensions
 
Old 04-12-2005, 06:24 AM   #3
crAckZ
Member
 
Registered: Sep 2004
Location: LOUISVILLE KENTUCKY
Distribution: mandriva 2006
Posts: 155

Rep: Reputation: 30
on your mouse, are you pushing the center button? i have noticed that if you push the button and try to scroll it does try to move you back. you have to actually roll the mouse button or drag the scroll bar. i havent really thought about this as a problem but i can see how it might get frusterating.
 
Old 04-13-2005, 12:15 AM   #4
Wedley
LQ Newbie
 
Registered: Nov 2002
Location: Australia
Distribution: Mandrake 10.0 (free version)
Posts: 8

Original Poster
Rep: Reputation: 0
Nah, I'm not pushing it when I scroll, and I don't have any extensions installed yet.
 
Old 04-13-2005, 12:23 AM   #5
scuzzman
Senior Member
 
Registered: May 2004
Location: Hilliard, Ohio, USA
Distribution: Slackware, Kubuntu
Posts: 1,851

Rep: Reputation: 47
Have you checked the preferences under "Mouse Wheel"?
 
Old 04-13-2005, 12:36 AM   #6
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 47
Quote:
Originally posted by crAckZ
on your mouse, are you pushing the center button? i have noticed that if you push the button and try to scroll it does try to move you back. you have to actually roll the mouse button or drag the scroll bar. i havent really thought about this as a problem but i can see how it might get frusterating.
Mine does the same thing... sometimes if I am schrolling up or down my middle button is just sensitive enough that it jumps me back a page or two...

I think you can disable by selecting "default" under Edit >> Preferenced >> Advanced >> Mouse Wheel. Change "Alt" to scroll and not back through history.

KC
 
Old 04-13-2005, 12:57 AM   #7
Wedley
LQ Newbie
 
Registered: Nov 2002
Location: Australia
Distribution: Mandrake 10.0 (free version)
Posts: 8

Original Poster
Rep: Reputation: 0
When I go to Edit>Preferences>Advanced there is nothing about mouse wheels nor mice. The only available sections are Accessibility, Browsing, Tabbed Browsing, Software Update, Security, Certificates and Validation. None of these contain any options to do with the mouse wheel, nor does any other section in Preferences that I can see.
 
Old 04-29-2005, 07:08 AM   #8
Wedley
LQ Newbie
 
Registered: Nov 2002
Location: Australia
Distribution: Mandrake 10.0 (free version)
Posts: 8

Original Poster
Rep: Reputation: 0
Uhh... I tried installing the ad-filled version of Opera and it did the exact same thing.

Does that change things?
 
Old 04-29-2005, 09:36 PM   #9
pokemaster
Member
 
Registered: Apr 2005
Location: Massachusetts, USA
Distribution: debian,ubuntu,slackware
Posts: 110

Rep: Reputation: 17
Check out your xorg.conf file (/etc/X11/xorg.conf on my machine), look for the entry for your mouse. Make sure that the following lines appear as they are here:

Option "Buttons" "5"
Option "ZAxisMapping" "4 5"

I know my touchpad includes a horizontal scroll.. when I use it, Firefox goes forward/back. I'm assuming your computer thinks your scrollwheel is horizontal.

Also, if the above doesn't work, tell it your mouse has 7 buttons (which is probably doesn't,) and the ZAxisMapping is "6 7" (or maybe "7 6".... hmm, don't remember too well.) Point being, some mice use slightly different scroll protocol and need some tweaking to use the default mouse driver.

In any case, good luck with the whole thing!
 
Old 04-30-2005, 01:43 AM   #10
Wedley
LQ Newbie
 
Registered: Nov 2002
Location: Australia
Distribution: Mandrake 10.0 (free version)
Posts: 8

Original Poster
Rep: Reputation: 0
Hmm... there wasn't a xorg.conf, but there is XF86Config-4. There was no Option "Buttons" bit in that file, though I tried both your other suggestions with the ZAxisMapping bit and neither of them seemed to have any effect, neither good nor bad.

This is what the mouse section of that file originally said, if it helps...
Code:
Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "ExplorerPS/2"
    Option "Device" "/dev/mouse"
    Option "ZAxisMapping" "6 7"
EndSection
 
Old 04-30-2005, 02:00 PM   #11
pokemaster
Member
 
Registered: Apr 2005
Location: Massachusetts, USA
Distribution: debian,ubuntu,slackware
Posts: 110

Rep: Reputation: 17
Might be a rather dumb question, but did you restart the X-server when you made changes? XF and xorg don't automagically re-parse the config files unless you restart. Try changing the ZAxisMapping to "4 5", then hit Ctrl-Alt-Backspace, which will either just restart your session or have you login again. Either way, your config will be re-parsed, and see if it makes a difference

Make a backup of your original config file, just in case, so you can restore it from the console if you break the gui... shouldn't be an issue though where you're only messing with the mouse.
 
Old 04-30-2005, 09:00 PM   #12
Wedley
LQ Newbie
 
Registered: Nov 2002
Location: Australia
Distribution: Mandrake 10.0 (free version)
Posts: 8

Original Poster
Rep: Reputation: 0
Trust me - when you're dealing with me, no question is too dumb.

I didn't think to restart the X server, actually, which is kind of embarassing because I would have done that even if I were using Windows and something like this happened. So I tried it again, and bingo. Firefox has never been happier. Thanks for spelling it out - I no longer have to browse with Konqueror, which is a new kind of awesome.

...

Damn it. I just remembered, there was another reason I stopped using Firefox. Whenever I tried to organize my bookmarks, I'd like try to drag them to the order I wanted them in, but no matter what they'd just re-organize themselves randomly. But, I guess that's a problem for another thread.

Last edited by Wedley; 04-30-2005 at 09:02 PM.
 
Old 04-30-2005, 10:16 PM   #13
pokemaster
Member
 
Registered: Apr 2005
Location: Massachusetts, USA
Distribution: debian,ubuntu,slackware
Posts: 110

Rep: Reputation: 17
lol, glad I could help you out. As for the bookmark thing, since I'm already here.... try Bookmarks > Manage Bookmarks, then View > Unsorted

Also maybe important, are the bookmarks "randomly" re-organized, or do they organize to the same locations every time (Firefox has a feature where it sorts bookmarks by date created, date visited, date modified, etc. if you want it to.)

If that doesn't fix it, I'm at a complete loss, and you probably *should* start another post.

Again, good luck!
 
Old 05-01-2005, 12:56 AM   #14
Wedley
LQ Newbie
 
Registered: Nov 2002
Location: Australia
Distribution: Mandrake 10.0 (free version)
Posts: 8

Original Poster
Rep: Reputation: 0
Nope, that took care of it alright. It was going Sorted by Description, but I'd tried adding alphabetical descriptions and it didn't seem to make a difference. Ditto for Sorted by Name. But Unsorted it's fine, and I prefer to manually sort them anyway. Excellent. Now I have no problems with Firefox at all. Thanks again.
 
Old 04-20-2012, 10:12 PM   #15
Elmware
Member
 
Registered: May 2006
Location: Canada
Distribution: Slackware 13 and fedora 15
Posts: 32

Rep: Reputation: 0
This bug has been plaguing me for quite some time. I've even had it happen with the touchpad as well as the mouse, and even while dragging the scrollbar up itself.

I'm running Fedora 16x64bit on a Toshiba Satellite model L750C.

This is really annoying.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox pauses when scrolling long distances Charred Slackware 5 07-15-2005 02:04 PM
Sound stops when scrolling in Firefox samael26 Debian 3 05-13-2005 07:36 PM
firefox makes system freeze when amule is running granth Slackware 24 04-04-2005 09:06 PM
xmodmap for multiple mice? external and laptop mice scrolling back/forward, etc. bleargh Linux - Software 3 12-31-2004 08:48 AM
hard scrolling vs soft scrolling (console) haxcess Linux - General 2 08-30-2004 12:17 AM


All times are GMT -5. The time now is 03:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration