LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-10-2001, 01:24 AM   #1
RicCrouch
LQ Newbie
 
Registered: Jun 2001
Posts: 6

Rep: Reputation: 0
Unhappy


OK, like a dummy, I went into Xconfigurator to change my video resolution to 1024x768x24. When it didn't test correctly, *I* thought that it was because X was already running, SO... you guessed it: I skipped the test and rebooted. And of course I have it (stupidly) set to go automatically to XWindows, which just gives me a big 'ol black screen. Short of a boot disk (which I don't have, other than the install one), is there another way to FORCE it to boot to text mode rather than X?

Oh, RH 7.1, by the way...

Thanks,
Ric Crouch
Linux Newbie
 
Old 06-10-2001, 07:16 AM   #2
kris.kj.jacobs
Member
 
Registered: Jun 2001
Location: Belgium
Distribution: Mandrake
Posts: 57

Rep: Reputation: 15
You're using lilo to boot, aren't you ?

When lilo is installed in graphical mode, choose failsafe mode.

When you have text-mode lilo you should do the following:

1/ At the lilo prompt, press the [TAB] key. You will get the possible choices on your screen (probabely "linux" and "dos").
2/ Enter lilo init=/sbin/init 3

This will start linux in runlevel 3, which means you won't get X.

To turn off X for later reboots, go into the file /etc/inittab and change the default runlevel to 3 by changing the following line:

id:3:initdefault:

Btw, there's a little explanation on the runlevels in the comment block at the top of /etc/inittab.
 
Old 06-10-2001, 04:06 PM   #3
mcleodnine
Senior Member
 
Registered: May 2001
Location: Left Coast - Canada
Distribution: s l a c k w a r e
Posts: 2,731

Rep: Reputation: 45
<CTRL><ALT><BACKSPACE> should kill the xsession...
 
Old 06-10-2001, 04:56 PM   #4
RicCrouch
LQ Newbie
 
Registered: Jun 2001
Posts: 6

Original Poster
Rep: Reputation: 0
kris: Yep. Using the graphical lilo. Get a nifty Red Hat graphic, and my two boot options in HUGE type at the right. How do I choose failsafe mode? That's not on the list.

I MAY be able to get to the /etc/inittab using the boot disk (turns out with 7.1, you can once again use the install disk as a rescue disk... thank goodness) and editing the file.

mcleodnine: Yep, that's what *I* thought, but for some reason, that isn't getting me out. What happens is that the system beeps, the monitor goes off, and the system is apparently locked. NOT a good situation.

Anyway, thanks for the help. I will try these suggestions!

Ric
 
Old 06-10-2001, 07:12 PM   #5
smoshea
LQ Newbie
 
Registered: Jun 2001
Posts: 17

Rep: Reputation: 0
At the big ole Red Hat boot prompt press 'ctrl+x' this should give you the plain old lilo prompt. From there you can type 'linux single' this will drop you into a shell, from there you can edit the '/etc/inittab' file.

HTH

Stuart
 
Old 06-12-2001, 06:58 AM   #6
RicCrouch
LQ Newbie
 
Registered: Jun 2001
Posts: 6

Original Poster
Rep: Reputation: 0
Smile That did it!

Using the rescue mode of the boot disk, I was able to put my /etc/inittab back to what it was. Then I used "linux single", ran Xconfigurator, and now I am back in business!

Thanks for all the help, guys!
Ric
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu screwed up my second Windows (/dev/hda5 HPFS/NTFS) partition howyen Ubuntu 5 04-12-2005 01:11 PM
screwed up, wife will force windows on me if I don't fix this elsmack Linux - Newbie 6 03-18-2005 03:01 AM
Install (fresh) FC2 screwed Windows parttions tho_x_tran Fedora - Installation 1 08-10-2004 02:11 PM
How I screwed my mbr...FC2 & W2k, windows unable to boot even after reinstallation! shamael Linux - Newbie 3 05-24-2004 11:26 PM
Windows Screwed my computer over JHuizingh Linux - General 18 03-31-2002 11:44 PM


All times are GMT -5. The time now is 05:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration