LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-15-2005, 04:58 PM   #1
undeaf
Member
 
Registered: Feb 2005
Distribution: Suse Suse 10.1, Xubuntu 7.1
Posts: 44

Rep: Reputation: 15
screwed up my monitor settings, won't boot


I've been using suse 9.1 for about a month and a half. Recently, I changed the monitor and graphics settings in Yast from the 60hz monitor it kept detecting to what I have(old viewsonic 17ps, up to 1152x85hz), I clicked save instead of test because test seemed to freeze on any setting,(yeah, I know that was really stupid) and after that, it won't boot anymore, I get a blank screen where KDE would start loading. Failsafe mode doesn't work either. (the monitor does not go into idle mode when I get the blank screen)

In Knoppix I looked for the /etc/x11/xorg.conf file, didn't find it but found something called IIRC xf86org of which the contents seemed alike, I tried editing the maximum refresh rates in there from 86khz horizontal and 160hz vertical to 60khz and 75hz, I also tried renaming a file I found in that directory called xf86org.bak to xf86org. None of that worked.

What can I do to try to get it working again? Or would I most likely be better of just reinstalling it?
 
Old 02-15-2005, 05:16 PM   #2
roAder
Member
 
Registered: May 2004
Location: Sweden, Stockholm
Distribution: Slackware 10.1
Posts: 142

Rep: Reputation: 15
First of all.
Xorg and XF86 are two types of X configuration utils.
Dont mix em, It only causes problems if you dont know what you are doing.
Well the KDE boot screen that freezes, try to press Alt+Ctrl+Backspace.
If this works, try reconfigurating your X using this command in SuSE (I think):
xf86config.
follow the steps and everything should work out for you.
 
Old 02-15-2005, 09:10 PM   #3
JoannesX
Member
 
Registered: Dec 2004
Location: Brazil
Distribution: Slackware
Posts: 99

Rep: Reputation: 15
the information above is pretty useful and it should work..
as said, Xorg and XF86 are different types of config...

so look at one thing: you seem to have looked in the wrong file
what you saw while runnig Knoppix was Knoppix's grafical configuration..

what you have to do to see your Suse config, is mounting the partition where it is installed in an existing directory and access the files that are there.. THEY are suse's right configuration files..

caught it?

I've done that a million of times, friend.. had the same annoying problems when first installed linux..

ahh and if you're sure you have a /etc/X11/xorg.conf
run xorgconfig not XF86Config

Last edited by JoannesX; 02-15-2005 at 09:13 PM.
 
Old 02-16-2005, 12:53 AM   #4
rnturn
Senior Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0, RHEL5,6), CentOS, SuSE (10.x, 11.x, 12.2, 13.2), Solaris (8-10), Tru64, MacOS, Raspian
Posts: 1,108

Rep: Reputation: 64
YaST ought to help...

"Won't boot" means you boot into level 5 (I take it). But the system does boot; it just isn't giving you the X login dialog screen.

You should still be able to get to a text console (using Ctrl-Alt-F[1-6]). From there you can log in as root and run 'YaST'. Follow the menues to 'Hardware' -> 'Graphics Card and Monitor'. At that point you have the option to change settings and/or reprobe the hardware and set up the basic X configuration. Also, if memory serves, any previous X configuration file(s) are saved off to the side. You can 'diff' them later to see what the change was that hosed things up.

Good luck.
 
Old 02-16-2005, 01:16 AM   #5
undeaf
Member
 
Registered: Feb 2005
Distribution: Suse Suse 10.1, Xubuntu 7.1
Posts: 44

Original Poster
Rep: Reputation: 15
Forgot to mention, I had already tried alt+ctrl+backspace and alt+ctrl+f2. No effect.

And in knoppix I did look under /mnt/hda2/etc/x11/

In failsafe mode, it actually doesn't end up with a blank screen, it freezes after these lines:

Checking file systems...
fsck 1.34 (25-Jul-2003)
/dev/hda3:recovering journal
/dev/hda3:clean, 9615/4210688 files, 1236188/8418060 blocks done
 
Old 02-16-2005, 08:18 AM   #6
JoannesX
Member
 
Registered: Dec 2004
Location: Brazil
Distribution: Slackware
Posts: 99

Rep: Reputation: 15
haven't you been forcing any non-normal shutdown??
it seems your file system is a little "messed-up"
or maybe you could have installed linux on some bad blocks..
 
Old 02-16-2005, 01:54 PM   #7
undeaf
Member
 
Registered: Feb 2005
Distribution: Suse Suse 10.1, Xubuntu 7.1
Posts: 44

Original Poster
Rep: Reputation: 15
Yes I have forced shut down 2 or 3 times when it got jammed and started going balistic on the hard disk. I assumed it was because I only have 512 megs of ram, does that make it a bad idea to use anything heavier than debian? I'm rather reluctant to install debian because knoppix keeps jamming after a short time of using it. My swap partition is two gigs IIRC, should that be bigger?

I doubt bad blocks are the problem, I installed it on a new (samsung) hard disk, and it doesn't get very hot.

If the problem has been caused by changing the monitor and video card settings, what other files would I need to learn about and edit?

Last edited by undeaf; 02-16-2005 at 02:16 PM.
 
Old 02-16-2005, 07:52 PM   #8
JoannesX
Member
 
Registered: Dec 2004
Location: Brazil
Distribution: Slackware
Posts: 99

Rep: Reputation: 15
you shouldn't be having problems bacause of memory and swap..
journaling filesystems such as ext3 should be safer
but it doesn't mean they can't be corrupted..
and it seems your kernel is running some script to recover the journaling..
editind the xorg.conf or xf86 GUI settings should be enough

if reformating and reinstalling is not a frustrating thing
for you and if you backup everything you need,
it's worth the attempt

Last edited by JoannesX; 02-16-2005 at 07:56 PM.
 
Old 02-16-2005, 11:08 PM   #9
undeaf
Member
 
Registered: Feb 2005
Distribution: Suse Suse 10.1, Xubuntu 7.1
Posts: 44

Original Poster
Rep: Reputation: 15
I'm trying to avoid reformating because getting the data off that drive seems problematic because suse and windows on another disk are not getting along too well on my PC, and on a 70 gig fat32 logical partition on my linux drive some of the directories don't show up right in WIN, and scandisk doesn't want to touch that partition, giving some excuse about insuficient memory. I think I'm likely going to have to format that partition anyway and not allow linux and windows to write to the same partition anymore, but I thought getting everything off that partition would be safest and easiest from within suse.

On the other hand, I have /home on a separate partition, and I'm under the impression that that should make formating/reinstalling easier.
 
Old 02-16-2005, 11:37 PM   #10
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
Try booting with the option of 'single'. This should boot you into a non-graphical single user (root) mode. Then you can change the /etc/inittab entry so that the computer boots into init level 3.
 
Old 02-17-2005, 01:41 AM   #11
Mr. Hill
Member
 
Registered: Feb 2005
Location: Pepperland
Distribution: Arch Wombat, FreeBSD Current, OpenBSD 3.7
Posts: 238

Rep: Reputation: 30
Has happened to me so many times, it's crazy. If it just flashes into a black screen right as you're about to log into KDE you have the same problem as I once did. Only I changed my screen res. not any specific monitor changes.

As it's rebooting punch in "ctrl+alt+FX" (The "X" stands for the numbers 1-5 or 1-6 I think, just do F1 for now). Login and you should be able to choose some option to see your screen res or your monitor display and such just play around with it for a bit.

You can also go in as a single user but I don't highly recommend that. Something else is just reinstalling your distro and resetting all of the screen stuff as they should, then when you boot back in get a driver so you'll be able to make changes without crashes.

Last edited by Mr. Hill; 02-17-2005 at 01:55 AM.
 
Old 02-17-2005, 04:49 PM   #12
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
My suggestion to boot using the option single, was for just once, to change the default level (editing /etc/inittab) so you can start at the console without the screen blanking on you. Then you can reboot or type 'init 3' as root.
 
Old 02-17-2005, 07:18 PM   #13
undeaf
Member
 
Registered: Feb 2005
Distribution: Suse Suse 10.1, Xubuntu 7.1
Posts: 44

Original Poster
Rep: Reputation: 15
I edited /etc/inittab and changed the boot level to three, but I could not get xf86config to fix the problem. I guess I'll have to format the / partition and reinstall. Sorry about all the trouble.

About how knoppix kept freezing on my system, I checked the disc it was on(CMC magnetics manufactured and about half a year old) with nero scandisk like I did before using it to try to fix this problem, and it has some errors that ECC couldn't overcome, although it was supposedly perfectly fine before, so nevermind those knoppix lockups.

Last edited by undeaf; 02-17-2005 at 07:20 PM.
 
Old 02-17-2005, 10:48 PM   #14
JoannesX
Member
 
Registered: Dec 2004
Location: Brazil
Distribution: Slackware
Posts: 99

Rep: Reputation: 15
sorry if I couldn't help... :-(
do as you wish and post back the results..
 
Old 02-18-2005, 08:29 PM   #15
undeaf
Member
 
Registered: Feb 2005
Distribution: Suse Suse 10.1, Xubuntu 7.1
Posts: 44

Original Poster
Rep: Reputation: 15
I reinstalled, and this time I left the monitor on 1024*85hz. But after I did an online update of everything recomended by Yast plus the nvidia drivers, next time I rebooted, I got the same problem again!

So I reinstalled again, and this time I didn't turn on autologgin so that if it happens again I'll know if it locks up when X starts, or when KDE starts. I guess I should install fluxbox or something in case this is a KDE problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
screwed up mysql settings salparadise Linux - Software 5 05-11-2004 11:35 AM
Switch from 17" monitor to 15" monitor. Need to know how to change settings. DoThatPlan Linux - Hardware 1 04-14-2004 09:11 PM
HELP: Screwed up monitor resolution Cookie Linux - General 4 03-29-2004 10:39 PM
HELP! Screwed up on configuring monitor config, in FGLXCONIFG! Cant see anything! RHLinuxGUY Linux - Hardware 2 01-10-2004 03:58 AM
change with monitor settings messed up boot centr0 Linux - Newbie 2 02-26-2003 10:31 PM


All times are GMT -5. The time now is 10:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration