LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-15-2008, 04:02 PM   #1
gNguyen
Member
 
Registered: Jul 2008
Distribution: FreeBSD, Slackware, Debian
Posts: 67

Rep: Reputation: 15
Screen Resolution too small when upgrading Ubuntu to 8.10


I had Ubuntu Dapper, then upgraded to Ubuntu 8.04. The Xorg worked fine until I upgraded to Ubuntu 8.10. I'm using an old laptop and the screen resolution is 800x600 and I wish to make it 1024x768(which was what it was on Windows XP). I tried doing xrandr but the only option that comes up is 640x480 or 800x600. I ran xvidtune and it works, but I don't know how to use it. Here's my Xorg.conf:

Code:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
	Identifier	"Configured Video Device"
EndSection

Section "Monitor"
	Identifier	"Configured Monitor"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
	Device		"Configured Video Device"
EndSection
Please Help!!!!
 
Old 10-15-2008, 04:27 PM   #2
ghostis
LQ Newbie
 
Registered: Mar 2007
Location: Boston
Distribution: Kubuntu and Debian Etch
Posts: 10

Rep: Reputation: 0
dpkg-reconfigure xserver-xorg

Hi!

Try running:
Code:
% sudo dpkg-reconfigure xserver-xorg
This will ask you detailed questions about what you want from the X server, including all resolutions.

If this doesn't work, post your model of laptop and its specs. One of us can probably post a working xorg.conf for that model.

-Adam Keck


Quote:
Originally Posted by gNguyen View Post
I had Ubuntu Dapper, then upgraded to Ubuntu 8.04. The Xorg worked fine until I upgraded to Ubuntu 8.10. I'm using an old laptop and the screen resolution is 800x600 and I wish to make it 1024x768(which was what it was on Windows XP). I tried doing xrandr but the only option that comes up is 640x480 or 800x600. I ran xvidtune and it works, but I don't know how to use it. Here's my Xorg.conf:

[CODE]# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
{snip}
 
Old 10-15-2008, 04:51 PM   #3
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,037

Rep: Reputation: 968Reputation: 968Reputation: 968Reputation: 968Reputation: 968Reputation: 968Reputation: 968Reputation: 968
Quote:
Originally Posted by ghostis View Post
This will ask you detailed questions about what you want from the X server, including all resolutions.
Not with (Beta) Ibex it won't - you'll get the same junk as posted above.
Maybe it'll be better on release - I wouldn't bet on it.

I had to steal xorg.conf from another working distro for my Inspiron 1100 (I keep it just to see if it can be made to work).
 
Old 10-15-2008, 06:22 PM   #4
Ryanjon7
Member
 
Registered: Apr 2006
Location: North Vancouver, B.C., Canada
Distribution: Fedora 14
Posts: 38

Rep: Reputation: 15
This is a good example to always back up important config files;

ex. xorg.conf
grub.conf

etc . . .

I you are using gnomb just go to System -> Preferences -> Hardware and select Screen Resolution. Change it to 1024x768 and it will write it to the xorg.conf file. Then logout and back in and it should work. You can find the similar setting under KDE menu . . .
 
Old 10-16-2008, 11:42 PM   #5
rigacasey
LQ Newbie
 
Registered: Apr 2007
Posts: 13

Rep: Reputation: 1
Quote:
Originally Posted by gNguyen View Post
I had Ubuntu Dapper, then upgraded to Ubuntu 8.04. The Xorg worked fine until I upgraded to Ubuntu 8.10. I'm using an old laptop and the screen resolution is 800x600 and I wish to make it 1024x768(which was what it was on Windows XP). I tried doing xrandr but the only option that comes up is 640x480 or 800x600. I ran xvidtune and it works, but I don't know how to use it. Here's my Xorg.conf:

Code:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
	Identifier	"Configured Video Device"
EndSection

Section "Monitor"
	Identifier	"Configured Monitor"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
	Device		"Configured Video Device"
EndSection
Please Help!!!!

1. Open terminal
2. Give command "sudo displayconfig-gtk"
3. Enter password
4. Select as monitor Generic LCD 1024x768, 60Hz
5. Close terminal
6. Log out all users
7. Log in again
8. Go to Screen Resolution and 1024x768 will now be an option
9 Done

I hope this does it for you

Last edited by rigacasey; 10-16-2008 at 11:44 PM.
 
Old 10-19-2008, 07:02 AM   #6
phoe
LQ Newbie
 
Registered: Oct 2008
Posts: 7

Rep: Reputation: 0
Nope...

"sudo displayconfig-gtk" doesn't work on my install within VirtualBox (command not found) - this was after downloading the latest install last night and grabbing all the updates it could install (IIRC it couldn't install all for some reason)

Editing xorg.conf has no effect either.

edit: installing the guest additions didn't help either, but would only work for VirtualBox users anyway...

from the VirtualBox menus "install guest additions"
open a terminal
sudo nautilus
run the "VBoxLinuxAdditions-86.run" program from the CD

Last edited by phoe; 10-19-2008 at 07:19 AM.
 
Old 10-20-2008, 11:05 AM   #7
ghostis
LQ Newbie
 
Registered: Mar 2007
Location: Boston
Distribution: Kubuntu and Debian Etch
Posts: 10

Rep: Reputation: 0
Xorg.conf

As root:

Make sure you have the right packages for a generic Xserver:

o aptitude install xserver-xorg xserver-xorg-video-vesa

Copy the following to /etc/X11/xorg.conf

Code:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
	FontPath	"/usr/share/fonts/X11/misc"
	FontPath	"/usr/X11R6/lib/X11/fonts/misc"
	FontPath	"/usr/share/fonts/X11/cyrillic"
	FontPath	"/usr/X11R6/lib/X11/fonts/cyrillic"
	FontPath	"/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/Type1"
	FontPath	"/usr/X11R6/lib/X11/fonts/Type1"
	FontPath	"/usr/share/fonts/X11/100dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi"
	FontPath	"/usr/share/fonts/X11/75dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi"
	# path to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"int10"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc104"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
EndSection

Section "Device"
	Identifier	"Generic Video Card"
	Driver		"vesa"
	VideoRam	4096
EndSection

Section "Monitor"
	Identifier	"Generic Monitor"
	Option		"DPMS"
	HorizSync	28-50
	VertRefresh	43-75

#	Set DisplaySize if you want the fonts to scale
#	It's in WxH in mm
#
#	DisplaySize	850 650

EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"Generic Video Card"
	Monitor		"Generic Monitor"
	DefaultDepth	16
	SubSection "Display"
		Depth		1
		Modes		"1024x768"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1024x768"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1024x768"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1024x768"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1024x768"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1024x768"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
EndSection

Section "DRI"
	Mode	0666
EndSection
o Restart X

HTH,

Adam Keck

Last edited by ghostis; 10-20-2008 at 11:07 AM.
 
Old 10-29-2008, 05:47 PM   #8
beik
LQ Newbie
 
Registered: Oct 2008
Posts: 1

Rep: Reputation: 0
Hi I just wanted to say I have an iMac running Parallels 3.0 with 1680x1050 resolution.

I also have a MacBook Pro 1440x900 similar configuration.

It is really humorous how extraordinarily complicated, convoluted the myths and truths are regarding screen resolution in Ubuntu. There aren't as many rumors about King Tut's Tomb in Egypt in 3,000 years as there are about trying to set screen resolutions in Ubuntu. It really is crazy. In the past year of computing this is my #1 headache. Thanks to this thread if any of the above works! I am trying now!
 
Old 04-15-2009, 02:39 PM   #9
marjbr8888
LQ Newbie
 
Registered: Apr 2009
Location: idaho
Distribution: 2000pro, xp, sidux, debian, nearly all
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by rigacasey View Post
1. Open terminal
2. Give command "sudo displayconfig-gtk"
3. Enter password
4. Select as monitor Generic LCD 1024x768, 60Hz
5. Close terminal
6. Log out all users
7. Log in again
8. Go to Screen Resolution and 1024x768 will now be an option
9 Done

I hope this does it for you
This worked perfectly and solved all of my damn ubuntu screen res problems. much thanks, marjbr/jon
 
  


Reply

Tags
resolution, screen, vesa, xorgconf


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Screen Resolution too small + no option to change it gNguyen Linux - Newbie 20 10-14-2008 05:19 PM
Screen Looks Small in 1024x768 Screen Resolution jlconferido Linux - Newbie 26 04-11-2007 06:55 AM
Small screen on Nec Versa SX with Ubuntu zeldafan8626 Linux - Laptop and Netbook 2 02-04-2006 11:58 PM
Resolution screen to small on knoppix burnt1ce85 Linux - Newbie 1 12-11-2004 11:48 AM
Screen resolution is too small! Josnap Slackware 1 03-30-2003 11:36 PM


All times are GMT -5. The time now is 10:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration