LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-16-2007, 02:16 PM   #1
mg92865
Member
 
Registered: Jun 2006
Distribution: Ubuntu
Posts: 35

Rep: Reputation: 16
Screen Resolution - No 1024x768, only 800x600 & smaller


The computer named blackbox was previously windows xp, and there was no resolution problem with 1024x768 on a 19" monitor (CRT). Now that I have moved this machine to linux (ubuntu 7.04, server and desktop, and fedora 6) the best I seem to get is 800x600.

Searches suggest several logs to check depending on the version and distribution. Like looking in the grub.config file-however no options for configuring the card appear there. Is there a way to check the hardware under linux to see if the built in video card is capable of 1024x768? If I can confirm that linux should be able to display this, I can then go deeper into resolving the problem.

Thank you,

Mike

PS: Screen resolution using a live cd with all three distributions seems like 1024x768, however upon rebooting from hard driveafter an installation, viewed icons are 800x600.
 
Old 10-16-2007, 03:54 PM   #2
Drax946
Member
 
Registered: Jun 2005
Location: WV USA
Distribution: Debian/Ubuntu
Posts: 43

Rep: Reputation: 15
There are several threads at LinuxQuestions.org which hit this topic. A quick search about screen resolution would probably turn up quite a feast on the subject. The reason seems to be many distros go their own way when working with the configuration files for X.org.

With that said, here is something I hope which will help from the Xorg manpage ( command: man Xorg ) :

Quote:
Xorg -configure
When this option is specified, the Xorg server loads all video
driver modules, probes for available hardware, and writes out
an initial xorg.conf(5) file based on what was detected. This
option currently has some problems on some platforms, but in
most cases it is a good way to bootstrap the configuration pro‐
cess. This option is only available when the server is run as
root (i.e, with real-uid 0).
The resolution you are currently seeing and why may be answered in this section of the manpage:

Quote:
CONFIGURATION
Xorg typically uses a configuration file called xorg.conf for its ini‐
tial setup. Refer to the xorg.conf(5) manual page for information
about the format of this file.

Xorg has a mechanism for automatically generating a built-in configura‐
tion at run-time when no xorg.conf file is present. The current ver‐
sion of this automatic configuration mechanism works in two ways.

The first is via enhancements that have made many components of the
xorg.conf file optional. This means that information that can be
probed or reasonably deduced doesn’t need to be specified explicitly,
greatly reducing the amount of built-in configuration information that
needs to be generated at run-time.

The second is to have "safe" fallbacks for most configuration informa‐
tion. This maximises the likelihood that the Xorg server will start up
in some usable configuration even when information about the specific
hardware is not available.


The automatic configuration support for Xorg is work in progress. It
is currently aimed at the most popular hardware and software platforms
supported by Xorg. Enhancements are planned for future releases.
I hope these get you pointed in the right direction to resolve your resolution problem.
 
Old 10-16-2007, 05:07 PM   #3
petern2
Member
 
Registered: Sep 2005
Location: Melbourne, Australia
Distribution: XP, Windows 7, PCLinuxOS
Posts: 41

Rep: Reputation: 15
You could try this:

Open a terminal, and log in as root, then type: dpkg-reconfigure xserver-xorg

and press enter. This works for most (all?) linux distros. This will reconfigure all the xorg values - mouse, keyboard, monitor, etc. Then scroll through the screens and enter your preferred values. The defaults will work for most of them, until you get to the screen which sets the resolution. You should be able to set it to 1024x768 there. It may be that value was simply unchecked by default.

If 1024x768 works for the live distros, then there isn't a problem with the video card or monitor, just the default values. I've had to do this a couple of times with Kubuntu.
 
Old 10-17-2007, 12:41 AM   #4
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
You can run the command lspci and look for VGA; the output will look like this
Code:
wim@btd-techweb01:~$ /sbin/lspci
00:00.0 Host bridge: Intel Corp. 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub Interface (rev 03)
00:01.0 PCI bridge: Intel Corp. 82845G/GL[Brookdale-G]/GE/PE Host-to-AGP Bridge (rev 03)
00:1d.0 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #1 (rev 02)
00:1d.1 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #2 (rev 02)
00:1d.2 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #3 (rev 02)
00:1d.7 USB Controller: Intel Corp. 82801DB (ICH4) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB/ER Hub interface to PCI Bridge (rev 82)
00:1f.0 ISA bridge: Intel Corp. 82801DB (ICH4) LPC Bridge (rev 02)
00:1f.1 IDE interface: Intel Corp. 82801DB (ICH4) Ultra ATA 100 Storage Controller (rev 02)
00:1f.3 SMBus: Intel Corp. 82801DB/DBM (ICH4) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB (ICH4) AC'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV6 [Vanta/Vanta LT] (rev 15)
02:08.0 Ethernet controller: Intel Corp. 82801BD PRO/100 VE (LOM) Ethernet Controller (rev 82)
wim@btd-techweb01:~$
The blue line gives the video card; next you can check the specs for that card. Further check the specs for your monitor.
The dpkg-reconfigure command posted by petern2 above should do the trick once you have the information.

If you still run into problems, please post the above details (make/model of both videocard and monitor) as well as the sections device, monitor and screen of your xorg.conf.

PS Grub would be the last thing to look at to solve this issue (in my opinion).
 
Old 10-17-2007, 11:23 AM   #5
Boow
Member
 
Registered: Feb 2004
Distribution: Slackware 10.2
Posts: 669

Rep: Reputation: 32
Try looking into the NoEDID option you put it in your xorg.conf. google is your friend.
 
Old 10-17-2007, 02:17 PM   #6
mg92865
Member
 
Registered: Jun 2006
Distribution: Ubuntu
Posts: 35

Original Poster
Rep: Reputation: 16
Thank, problem solved

Thanks to each of you who posted a response to my question. I took the "/sbin/lspci" command and determined what card was running. The following was the result:

00:02.0 VGA compatible controller:
Intel Corporation 82845G/GL[Brookdale-G]/GE
Chipset Integrated Graphics Device (rev 01)

I attempted to use this to determine if the card is capable of displaying 1024x768; I found tech info on Intel's site, but nothing that I understood to say yes, it will display at this resolution (I knew it would because it worked on windows).


Where would I actually find the info that states it will display up to a specific resolution?


Yes, I likely should have searched under xorg instead of screen resolution. I tried that and found the answer to my problem in a post on this site regarding Fedora 7 and only 800x600 resolution. The poster suggested "system-config-display". This allows a graphical interface to add an 1024x768 option to the file: etc/X11/xorg.conf. Reboot, and the system boots to 1024x768.

I went back an actually looked in the xorg.conf file (after making a copy). I now see where this entry is inserted. If I delete the "1024x768" from the options, the system then displays only in the options listed "800x600" "640x480".

Again, thank you for contributions, the problem is solved, and I learned some additional in the process.

mg92865
 
Old 12-03-2010, 12:49 AM   #7
Stavrowsky
Member
 
Registered: Dec 2010
Posts: 34

Rep: Reputation: 1
Solution to 800x600 max res for Debian 5 (Lenny) on AMD64

Let me begin by saying I'm about as new to Linux as you can be (having just made my first installation a week ago. At initial installation, I had a choice of about 9 screen resolutions. A Couple of days into using linux, the machine decided it was going to give me a choice of 640x480 and 800x600 and nothing else. If, however, I ran a live CD of a different Distro, the screen came up in 1024x768. The problem was obviously in the Lenny Distro on my hard disk.

After many hours of searching the web, and looking at numerous suggested answers, I was repeatedly led back to the xorg.conf file. Some of the solutions proposed suggested I automatically reconfigure it using "dpkg-reconfigure xserver-xorg" (or a slight variation of that command) in root terminal mode, and then just answer the questions posed to me as the program reconfigured xorg.conf. Didn't work. I don't know if it's peculiar to Debian 5, or just my particular example of it, but the only thing that would get reconfigured was the keyboard.

I found a number of suggestions that I include a "Modes" section in xorg.conf. Please DON'T do that in Debian 5. X-Windows won't load at next reboot. If you track the problem you'll get an error message saying "Modes" is not a valid parameter for xorg. I removed it, and went back to the drawing board.

I found an example of a manual reconfiguration for the same problem in Ubuntu (a Debian offshoot), regarding specifying screen resolutions in the "Screen" section, and copied that, virtually verbatim, into xorg. After reboot, nothing changed.

I then found another screed recommending that monitor specifics be inserted. My monitor section had the identifyer simply as "Configured Monitor". I copied a sample configuration into xorg, changed the parameters to those of my monitor, left the "screen" section as it was, rebooted, and VIOLA!!! 9 resolution options!

My monitor is an Emachines F1770 CRT (hey- I paid three whole dollars for it at the thrift store. I'm not giving up on it easily!), with the following sync rates: H 31.5-68.6 kHz, V 60-100 Hz. I used the monitor model number for my identifyer. So... knowing that, here is the process:

SOLUTION:

1.) From your desktop, switch user (under the "system" drop down menu). Log in as "root", with whatever password you have set up during initial installation.
2.) Click on the "computer" icon, followed by "file system", the "etc", then "X11". Then double click on xorg.conf to open it in GEdit, the graphical text editor that comes with Debian 5.
3.) Copy the following into your file, then replace the monitor identifyer and sync rates with those particular to your setup.

Section "Monitor"

Identifier "F1770"

Option "DPMS"

HorizSync 31.5-68.8

VertRefresh 60-100

EndSection



Section "Screen"

Identifier "Screen0"

Device "Videocard0"

Monitor "F1770"

DefaultDepth 24

SubSection "Display"

Viewport 0 0

Depth 24

Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"

EndSubSection

EndSection

4.) Once you have pasted the above in, and made your adjustments to it, make sure you remove any traces of the previous "Screen" and "Monitor" sections. If you accidentally leave a a previous "EndSection" there, for example, Debian won't understand and won't load the X-Server when you reboot. I was careful to ensure that my new entries were in the same format as the rest of the file (the same number of vacant lines between entries, parameters tabbed over so that they were in line with other file parameters, etc.) I don't know if that is necessary, but i figured it couldn't hurt.

5.) Save the file. GEdit will automatically save your previous version of xorg.conf in the X11 folder, looking some thing like "xorg.conf.201012002164220". If worst comes to worst, you can delete the xorg.conf file and rename the backup to xorg.conf to get back your original configuration.

6. Log out of "root", into your user session, and reboot..........

with any luck, that will fix your problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't get screen resolution to 1024x768 marta Debian 18 03-26-2010 05:33 PM
Screen Resolution 800x600 with black borders JoSch1337 Linux - Hardware 6 11-10-2006 02:43 PM
Why can't you get a higher screen resolution than 800x600 on SUSE? yekrahs Suse/Novell 11 02-09-2006 05:58 PM
default screen resolution smaller than max. resolution ?? Thoddy Linux - General 2 11-10-2005 02:33 AM
screen resolution 800x600 chocloman Slackware 4 03-19-2005 10:41 AM


All times are GMT -5. The time now is 08:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration