LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-27-2009, 09:45 AM   #1
coramill
LQ Newbie
 
Registered: Jul 2008
Posts: 5

Rep: Reputation: 0
Screen Resolution locked at 640 x 480 @ 60


My system initially was set to 600 x 800 screen resolution. Some time ago I started getting complaints at log on that the monitor type could not be detected. I apparently did something that resulted in permanently setting the screen resolution to 640 x 480. When I enter the screen setting dialog all drop down options are fixed. No refresh, no screen rotate nothing can be changed.

I have searched the forums for similar problems and found several, but the solutions offered assume a bit more expertise than I possess.

Any guidance to fix this would be appreciated.

System Details:
Monitor KDS 17" shared with WinXP system.
Max. Resolution 1600 x 1200 (verified on XP machine)
Vendor built desktop
MB = ASUS P5E-VM-HDMI
OS = Ubuntu 8.04 (Hardy) (vendor installed) with all update
LAN = Wired D-Link DI-524 router on Microsoft Windows Network
Antivirus = Norman w/updates current and found clean.
Microsoft Windows Network = Workgroup


xorg.conf contains the following:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real"
xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
Boardname "vesa"
Busid "PCI:0:2:1"
Driver "vesa"
Screen 0
EndSection

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "Plug 'n' Play"
Modelname "Plug 'n' Play"
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync
-hsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 640 480
Modes "640x480@60"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "screen1" 0 0
EndSection
Section "Module"
Load "glx"
Load "GLcore"
Load "v4l"
EndSection
Section "device" #
Identifier "device1"
Boardname "Intel 965"
Busid "PCI:0:2:0"
Driver "i810"
Screen 0
Vendorname "Intel"
EndSection
Section "screen" #
Identifier "screen1"
Device "device1"
Defaultdepth 24
Monitor "monitor1"
EndSection
Section "monitor" #
Identifier "monitor1"
Gamma 1.0
EndSection
Section "ServerFlags"
EndSection
 
Old 05-27-2009, 10:19 AM   #2
rsciw
Member
 
Registered: Jan 2009
Location: Essex (UK)
Distribution: Home: Debian/Ubuntu, Work: Ubuntu
Posts: 206

Rep: Reputation: 44
Code:
Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
Defaultdepth 24
SubSection "Display"
Depth 24
Modes "640x480" "800x600" "1024x768" "1280x1024" "1600x1200"
EndSubSection
EndSection
change the modes in the Section "Screen"
That should, hopefully, do it.

If you only want exactly one mod (say 1600x1200), just enter
Modes "1600x1200"
instead
 
Old 05-27-2009, 12:04 PM   #3
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 190Reputation: 190
Quote:
shared with windows XP system
Are you using a KVM now that you didn't have before ? if so it is probably blocking the DDC probe fro myour PC to the monitor when it's trying to detect the monitors capabilities.

let us know if rsciw's solution works for you or not. If not, you can diable DDC probing, and use a modeline to set the resolution you want.
 
Old 05-27-2009, 12:17 PM   #4
coramill
LQ Newbie
 
Registered: Jul 2008
Posts: 5

Original Poster
Rep: Reputation: 0
As I said I lack expertise--how do I access > Section "Screen" < in order to modify it?

No the KDS is the one I've had for some time--I did replace an older monitor that died but I had the replacement KDS in place for some time before I started getting complaints during boot up.

Regards,

John
 
Old 05-28-2009, 08:31 AM   #5
coramill
LQ Newbie
 
Registered: Jul 2008
Posts: 5

Original Poster
Rep: Reputation: 0
Solved screen resolution issue

After further research I finally came across the missing information on how to modify the xorg.conf file. After discovering how to open a terminal I input "gksudo gedit/etc/X11/xorg.conf" after the $ sign. Then I attempted to cut and paste the contents of "xorg.confg backup.txt" which dated from before the screen resolution problem occured. This resulted in a screen full of errors. But this action apparently destroyed the active xorg file. When I rebooted Hardy came up in the KDS' maximum 1200x1600 75Hz mode and I could now change the resolution to other values. Apparently it recreated the xorg.conf file automatically and was able to query the monitor to find the maximum resolution and refresh rate. It still doesn't allow the screen to be rotated, but it may be that this feature only works with monitors that support it.

I did a search to find the new xorg.conf but only found earlier (backup?) versions. Where does this file reside and how do you view the contents?

Regards,

John
 
Old 05-28-2009, 09:50 AM   #6
amani
Senior Member
 
Registered: Jul 2006
Location: Kolkata, India
Distribution: Debian 64-bit GNU/Linux, Kubuntu64, Fedora QA, Slackware,
Posts: 2,766

Rep: Reputation: Disabled
The latest X does not use xorg.conf unless it is asked to do so.

Default location /etc/X11
 
Old 05-28-2009, 10:47 AM   #7
coramill
LQ Newbie
 
Registered: Jul 2008
Posts: 5

Original Poster
Rep: Reputation: 0
Unused xorg.conf

I assume that "X" refers the latest release of Ubuntu. You are correct, I located the xorg.conf at /etc/x11 and it had not changed--it still listed 640x480@60 as the only resolution option. So I have no idea what happened when I screwed arround with gedit. But some how it got fix. I guess it must be gnomes at work.

Regards,

John
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot get xorg to recognize greater than 640 x 480 skidvd Linux - Hardware 3 04-02-2008 12:00 AM
install mandrake 9.1 with 640*480 screen resolution ezone Linux - Newbie 1 10-20-2004 09:56 AM
X stuck in 640 by 480? RevOddball Linux - Software 2 10-13-2004 06:40 PM
S3 Virge DX can't get higher than 640 x 480 meeshka Linux - Hardware 3 09-05-2003 12:53 AM
X only working with 640*480 and 8bps ex0 Linux - General 2 07-14-2003 12:04 AM


All times are GMT -5. The time now is 04:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration