LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-18-2008, 12:22 PM   #1
purrcy
LQ Newbie
 
Registered: Aug 2008
Location: I live in Santa Paula, CA
Posts: 27

Rep: Reputation: 15
screen resolution for Ubuntu during install (RESOLVED)


Hi,

I've tried to install Ubuntu & Kbuntu, but when the OS is installed the screen resolution is too small for me to navigate the desktop and to reset the monitor properties and the screen resolution. I wind up reinstalling PCLOS, which I like very much and where I know how to do these things, but I would like to give Ubuntu/Kbuntu a try since I see that they are so popular.

So, how do I set the monitor properties and the screen resolution?

Last edited by purrcy; 12-27-2008 at 05:52 PM.
 
Old 12-18-2008, 12:58 PM   #2
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18 MATE, antiX-16.1, MX-16
Posts: 1,974
Blog Entries: 8

Rep: Reputation: 723Reputation: 723Reputation: 723Reputation: 723Reputation: 723Reputation: 723Reputation: 723
Look here:

http://distrowatch.com/weekly.php?is...070903&mode=68
 
Old 12-18-2008, 01:00 PM   #3
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 5, Linux Lite
Posts: 4,312

Rep: Reputation: 209Reputation: 209Reputation: 209
When you install either Ubuntu or Kubuntu, try Alt & Ctrl & +/- keys on the number pad to change screen resolutions on the fly.
 
Old 12-18-2008, 01:13 PM   #4
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,090
Blog Entries: 3

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
system-> preference--> screen--> resolution
 
Old 12-18-2008, 01:27 PM   #5
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 5, Linux Lite
Posts: 4,312

Rep: Reputation: 209Reputation: 209Reputation: 209
Quote:
Originally Posted by Drakeo View Post
system-> preference--> screen--> resolution
The OP cannot do that:
Quote:
...but when the OS is installed the screen resolution is too small for me to navigate the desktop and to reset the monitor properties and the screen resolution...
 
Old 12-23-2008, 12:33 PM   #6
purrcy
LQ Newbie
 
Registered: Aug 2008
Location: I live in Santa Paula, CA
Posts: 27

Original Poster
Rep: Reputation: 15
Thanks all. Read and understood.
 
Old 12-25-2008, 05:55 PM   #7
purrcy
LQ Newbie
 
Registered: Aug 2008
Location: I live in Santa Paula, CA
Posts: 27

Original Poster
Rep: Reputation: 15
Sorry, either that stuff didn't work or I didn't understand it. xorg.conf was a little different that was stated in the distrowatch article, so I haven't messed with it yet. I'm going to have to do a little more research.
 
Old 12-25-2008, 08:05 PM   #8
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 5, Linux Lite
Posts: 4,312

Rep: Reputation: 209Reputation: 209Reputation: 209
You have now marked your header as 'RESOLVED' if this is the case, can you post the solution so that it may benefit others who encounter the same problem.
 
Old 12-26-2008, 06:19 AM   #9
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18 MATE, antiX-16.1, MX-16
Posts: 1,974
Blog Entries: 8

Rep: Reputation: 723Reputation: 723Reputation: 723Reputation: 723Reputation: 723Reputation: 723Reputation: 723
Smile

purrcy,

This is an example of an /etc/X11/xorg.conf file. I have deleted some of the Modelines for brevity.



# /etc/X11/xorg.conf (Xorg X Window System server configuration file)
#
# This file was generated by fll_xorgconfig, the F.U.L.L.S.T.O.R.Y.
# Xorg Configuration tool.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
Section "ServerLayout"
Identifier "Xorg Configured"
Screen "Screen 0"
InputDevice "Keyboard 0"
InputDevice "Logitech USB-PS/2 Optical Mouse 0"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "true"
EndSection

Section "InputDevice"
Identifier "Keyboard 0"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
Option "XkbOptions" "altwin:super_win"
EndSection

Section "InputDevice"
Identifier "Logitech USB-PS/2 Optical Mouse 0"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "Protocol" "Auto"
Option "Emulate3Buttons" "true"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Device 0"
Driver "nv"
BoardName "nVidia Corporation NV44 [GeForce 6200 TurboCache(TM)]"
BusID "PCI:5:0:0"
EndSection

Section "Monitor"
Identifier "Monitor 0"
ModelName "VP730 Series"
HorizSync 30-82
VertRefresh 50-75
# 640x350 @ 85.00 Hz (GTF) hsync: 31.28 kHz; pclk: 25.02 MHz
Modeline "640x350" 25.02 640 656 720 800 350 351 354 368 -HSync +Vsync

etc, etc......................
...................................................

# 1920x1440 @ 75.00 Hz (GTF) hsync: 112.73 kHz; pclk: 297.59 MHz
Modeline "1920x1440" 297.59 1920 2072 2280 2640 1440 1441 1444 1503 -HSync +Vsync
EndSection

Section "Screen"
Identifier "Screen 0"
Monitor "Monitor 0"
DefaultColorDepth 24
SubSection "Display"
Depth 8
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "off"
EndSection
.............................................................................................

Look at the Distrowatch article again.

In the above example with a DefaultColorDepth of 24 and a required resolution of 1280 x 1024 you would need to scroll down to Depth 24 and on the line beneath (Modes) type "1280x1024" in the space before "1152x864".
Your DefaultColorDepth and screen resolution may be different of course.
I hope this clarifies things a little.
 
Old 12-26-2008, 05:48 PM   #10
purrcy
LQ Newbie
 
Registered: Aug 2008
Location: I live in Santa Paula, CA
Posts: 27

Original Poster
Rep: Reputation: 15
I worked on this all day, became upset and installed Debian over it. I had the same problem there and couldn't figure out how to fix it, either. Ubuntu looked promising so I'll reinstall it and try again. I'll be getting back to you again later.
 
Old 12-26-2008, 11:09 PM   #11
purrcy
LQ Newbie
 
Registered: Aug 2008
Location: I live in Santa Paula, CA
Posts: 27

Original Poster
Rep: Reputation: 15
Below is the Xorg.conf that I got from my MiniMe X11 folder. Below that is the xorg.conf that comes from Ubunbu. Notice that they are quite a bit different. So, how do I modify the latter so do what the former does? Can I just copy and paste?


# File generated by XFdrake (rev 57713)

# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
# font server independent of the X server to render fonts.
FontPath "unix/:-1"

# minimal fonts to allow X to run without xfs
FontPath "/usr/share/fonts/misc:unscaled"
EndSection

Section "Extensions"
Option "Composite"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
AllowMouseOpenFail # allows the server to start up even if the mouse does not work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "XkbModel" "microsoftpro"
Option "XkbLayout" "us"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IntelliMouse"
Option "Device" "/dev/mouse"
EndSection

Section "InputDevice"
Identifier "Mouse2"
Driver "evdev"
Option "product" "0x0006"
Option "vendor" "0x0002"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Samsung"
ModelName "Samsung SyncMaster 900NF"
HorizSync 30-110
VertRefresh 50-160

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce 3 to GeForce 4 (96xx)"
Driver "nv"
Option "DPMS"
Option "SWCursor"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 15
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 16
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 24
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
InputDevice "Mouse2" "SendCoreEvents"
Screen "screen1"
EndSection



# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection
 
Old 12-27-2008, 11:55 AM   #12
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18 MATE, antiX-16.1, MX-16
Posts: 1,974
Blog Entries: 8

Rep: Reputation: 723Reputation: 723Reputation: 723Reputation: 723Reputation: 723Reputation: 723Reputation: 723
Smile

purrcy,

With regard to Debian's xorg.conf, you need it to look like this extract:-
Debian xorg.conf

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce 3 to GeForce 4 (96xx)"
Driver "nv"
Option "DPMS"
Option "SWCursor"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Omitted various bits.................

Subsection "Display"
Depth 24
Modes “2048x1536” "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection
EndSection
.................................................................................................... ..................................
Your monitor has a native display of 2048x1536 @69MHz @DefaultColorDepth of 24.
However, your graphics card MAY not be capable of reaching this resolution so you may have to settle for a lower resolution (> 1024x768 but < 2048x1536).
Search for some information on your graphics card. If 2048x1536 is okay then this is the figure which must be entered in your xorg.conf file (see above).

Method:
First, backup the existing xorg.conf file to a flash stick or similar. Call it, say,
/etc/X11/xorg.confdeb

Make sure you have vim installed.
Go to Synaptic Package Manager, give your root password, press Enter and type vim
in the Search box. Press Enter.


If vim is not installed (empty box) then install it (Mark, Mark, Apply, Apply).
A brief vim tutorial is here:
http://www.stat.tamu.edu/~dahl/teach...tml/index.html
Just have a quick look at the "Get Started" section.

Go to Terminal and type su (press Enter)
Type your root password ????????? (press Enter)

Type vim /etc/X11/xorg.conf
(Double check your typing and remember to put a space between vim and /etc/, then press Enter).
You are now in Command mode.
Press “i” for Insert mode.
Use the Down Arrow key to move the cursor to the start of the line beginning Modes.
Use the Right Arrow key to move the cursor one space to the right of the s
in Modes (for Depth 24).
Now type “2048x1536” (Do not forget the quote marks) and leave a space before “1024x768”.
Press Esc to enter Command mode.
Type :wq
Press Enter.

Switch off pc and restart.
If it is still not correct then you may have to use a lower resolution but hopefully you will be okay with 2048x1536.

EDIT

To modify the Ubuntu xorg.conf file try this, using a similar procedure as detailed for Debian.
For Ubuntu (in Terminal) type sudo vim /etc/X11/xorg.conf
Press Enter and give the password.
.....................................................................

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
SubSection "Display"
Modes "2048x1536"
EndSubSection
EndSection

......................................................................

Do a copy of the original file first and read the vim tutorial with regard to deleting, moving text, using backspace, Delete and Enter etc etc so that you feel confident about modifying the Ubuntu xorg.conf file.

Good luck.

Last edited by beachboy2; 12-27-2008 at 05:53 PM.
 
Old 12-27-2008, 05:52 PM   #13
purrcy
LQ Newbie
 
Registered: Aug 2008
Location: I live in Santa Paula, CA
Posts: 27

Original Poster
Rep: Reputation: 15
Thanks everyone. I got the resolution to work! I used

sudo nvidia-xconf

to generate a xorg.conf file. It had some trouble, but made up things as it went along. I had to change

Option "Emulate3Buttons" "no"

to

Option "Emulate3Buttons" "yes"

to get my MS Intellimouse to work with all five buttons (although I cant program the buttons, but they do what I want them to do anyway.) I then altered some of the vedio information with what I got from my MiniMe xorg.conf file. I did this all on the Ubuntu Text Editor and saved the results to my desktop. I then copied the file to /etc/X11 with

sudo cp xorg.conf-new /etc/X11/xorg.conf

and that was it. I rebooted and it started with 1600x1200 resolution; I used System}Preferences}Screen Resolution to change the resolution to 1024x768. And that was it. Everything seems to work just fine. Thanks again. I couldn't have done it without you guys.


Here is my xorg.conf:

# xorg.conf after running sudo nvidia-xconf with modifications:
#
#
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder57) Mon Oct 27 14:37:20 PST 2008
#
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Module"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "keyboard"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "yes"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
VendorName "Samsung"
ModelName "Samsung SyncMaster 900NF"
HorizSync 30-110
VertRefresh 50-160

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync

EndSection

Section "Device"
Identifier "Configured Video Device"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce 3 to GeForce 4 (96xx)"
Driver "nv"
Option "DPMS"
Option "SWCursor"

EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "True"
Subsection "Display"
Depth 24
Modes "1600x1200" "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubSection

EndSection
 
Old 12-28-2008, 02:56 AM   #14
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18 MATE, antiX-16.1, MX-16
Posts: 1,974
Blog Entries: 8

Rep: Reputation: 723Reputation: 723Reputation: 723Reputation: 723Reputation: 723Reputation: 723Reputation: 723
purrcy,

That's excellent news, well done.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Screen Resolution on Ubuntu SonicStream Ubuntu 6 04-26-2008 06:53 AM
Ubuntu Install Screen Resolution hzadell Linux - Newbie 13 05-03-2007 10:59 AM
Only 640x480 screen resolution on ubuntu 5.10 nickleus Linux - Newbie 6 02-20-2006 03:01 AM
Screen Resolution Problem in Ubuntu 5.04 crash_override_me Ubuntu 2 09-03-2005 04:22 AM
Screen resolution with Ubuntu Linux kjmorris Linux - Laptop and Netbook 1 03-02-2005 06:37 AM


All times are GMT -5. The time now is 04:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration