LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-07-2005, 02:13 AM   #1
bitcmos
LQ Newbie
 
Registered: Sep 2005
Location: RWS, Ca
Distribution: Fedora Core 4, Debian
Posts: 3

Rep: Reputation: 0
Screen Resolution Changes on login


I just installed Fedora Core 4 and I am having trouble configuring my monitors to use a resolution of 1280x1024. I tried changing the settings in /etc/X11/xorg.conf and when I login as root the settings take effect. The login screen appears to be at the 1280x1024 settings but when i login as a regular user the screen changes back to the default 800x600 almost immediately. After searching many forums I haven't found anybody with this problem before and am hoping somebody might have an idea where to start.

Here is my system info:

# uname -r
2.6.12-1447_FC4

I am using a KOGI 17" L7EH LCD screen with manual specs:
Resolution: 1280x1024
H. Scan: 64.3
V. Scan: 60.0
Pol. +/+
Pixel (MHz) 108.0

Video Card is On board and according to the GUI display setting tools I am using the Intel 810 Video Card driver.

I verified root is using these settings when I log into X as root and using the command xvidtune and ddcprobe (which don't work unless I am root.)

[root@peach]# /usr/sbin/ddcprobe

[root@peach]# vim /etc/X11/xorg.conf

Videocard DDC probe results
Description: Intel Corporation i810 Graphics Controller
Memory (MB): 1

Monitor DDC probe results
ID: GVT1702
Name: L7EH
Width (mm): 340
Height(mm): 270

my xorg.conf looks like this:

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/input/mice"
Option "Buttons" "7"
Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "LCD Panel 1280x1024"
HorizSync 31.5 - 67.0
VertRefresh 50.0 - 75.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "i810"
VendorName "Videocard vendor"
BoardName "Intel 810"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

I want to say that I have my configuration settings correct because when I log in as root the resolution is correct, but I don't want to be logging in all the time as root.

Do I need to set any user specific permissions to allow the settings to take effect? I have tired to diagnose the problem by looking through /var/log/Xorg.0.log but I couldn't really tell what was going on here. I could post that output as well if it would help, but it is very long. Any help is appreciated.

Thank you.
 
Old 09-07-2005, 09:56 AM   #2
pnellesen
Member
 
Registered: Oct 2004
Location: Missouri, USA
Distribution: Slackware 12.2, Xubuntu 9.10
Posts: 371

Rep: Reputation: 31
Are you using KDE or GNOME? There should be a "Control Center" app in either one of those that allows you to set screen resolution on a per-user basis...
 
Old 09-07-2005, 12:06 PM   #3
bitcmos
LQ Newbie
 
Registered: Sep 2005
Location: RWS, Ca
Distribution: Fedora Core 4, Debian
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by pnellesen
Are you using KDE or GNOME? There should be a "Control Center" app in either one of those that allows you to set screen resolution on a per-user basis...
I am using GNOME2.10.0. I am normally weary about using GUI tools as I like to know what is going on under the hood, but I can't find a Control Center app. The only GUI tools I have found that adjust Screen Resolution are:

Desktop>>Preferences>>Screen Resolution
and
Desktop>>System Settings>>Display

Neither of these have any per user settings that I could find. I looked around at some other apps, but none seemed to deal with the Screen Resolution and user settings. Do you know the actual name of the app or where it is located?

=====================

n/m You have to use the Screen Resolution GUI tool as the user that you want to have the resolution for. I logged in as a different user and changed the resolution and it worked. Thanks!

Out of curiosity, do you know where the per user settings are located on disk? And is there a way to change the default? I checked the box to make that resolution default on the computer, but it didn't affect existing users. Is it only for new users that this will take effect?

I am going to be remotely administering changes to this box and I would like to know how to set changes that will affect all users.

Thank you very much!
 
Old 09-07-2005, 12:25 PM   #4
pnellesen
Member
 
Registered: Oct 2004
Location: Missouri, USA
Distribution: Slackware 12.2, Xubuntu 9.10
Posts: 371

Rep: Reputation: 31
Quote:
Originally posted by bitcmos
n/m You have to use the Screen Resolution GUI tool as the user that you want to have the resolution for. I logged in as a different user and changed the resolution and it worked. Thanks!

Out of curiosity, do you know where the per user settings are located on disk?
Oops - I forgot to mention "login as the user you want to change the resolution for...". No, I con't know where those settings are - I took a look through my home directory but couldn't find anything specifying screen settings - maybe somewhere in /etc/X11?
 
Old 09-07-2005, 06:34 PM   #5
bitcmos
LQ Newbie
 
Registered: Sep 2005
Location: RWS, Ca
Distribution: Fedora Core 4, Debian
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by pnellesen
Oops - I forgot to mention "login as the user you want to change the resolution for...". No, I con't know where those settings are - I took a look through my home directory but couldn't find anything specifying screen settings - maybe somewhere in /etc/X11?
For some reason when I log out and log back in even if I check the box to make the settings default in Screen Resolution and check the box to save setup on the logout screen when I log back in they go back to 800x600.

After checking some web pages I found this:

http://www.yolinux.com/TUTORIALS/GNOME.html#CONFIGFILES

After modifying the file:

/home/myUser/.gconf/desktop/gnome/screen/default/0/%gconf.xml

I was able to get the settings to stick. Am I doing something wrong to get the default settings to change using the GUI tools?

It works now, so now its just my insatiable curiosity about how the GUI tools work which needs to be satisfied.

Thanks for your help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
login screen resolution morph100 Linux - Software 2 09-14-2005 04:10 AM
X login screen uses wrong resolution with viewport donni Linux - Software 2 06-12-2005 12:57 PM
FC3 - Can't change resolution on signon screen or root login with riva128 video card mackayr Fedora 2 02-07-2005 01:06 PM
X resolution at initial login screen billgatos Slackware 1 08-30-2004 03:30 AM
Change Fedora Login Screen to KDE login screen ada601 Linux - Software 2 08-15-2004 06:07 PM


All times are GMT -5. The time now is 03:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration