LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-16-2004, 04:40 AM   #1
Lego3
LQ Newbie
 
Registered: Jun 2004
Posts: 3

Rep: Reputation: 0
Unhappy Screen problems "No screens found"


I accidently chose virtual desktop when installing SOT linux. When I thought I had removed it and restarted it couldn't start the graphical interface anymore.
It says "No screens found".
What can I do? Something I've missed in /etc/X11/XF86Config ?
 
Old 06-16-2004, 05:04 AM   #2
Lego3
LQ Newbie
 
Registered: Jun 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Btw, it also says every 5th minute "INIT: Id 'x' respawning too fast: disabled for 5 minutes"
 
Old 06-16-2004, 05:31 PM   #3
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
In the /etc/inittab file, change the default runlevel from 5 to 3. At this point, you start x-windows with the startx command. But it won't respawn if it fails.

Re-run the graphics setup. The no screens found is usually seen if you haven't found the correct video driver, or all of the video modes for the monitor are invalid.

A log of the startup messages is kept in /var/log/. the log file may have a -0.log ending. It will show which resolution modes it tried.

If you have a problem finding a the correct driver file, you could use the generic 'vesa' driver. Doing this could eliminate the video driver as the problem. If x-windows still doesn't start, look at your monitor model settings for resolution settings.
 
Old 03-22-2006, 08:08 AM   #4
Eloi84
LQ Newbie
 
Registered: Mar 2006
Posts: 1

Rep: Reputation: 0
how do i re-run the graphics setup? i'm not comfortable working with linux yet...
 
Old 03-22-2006, 08:59 AM   #5
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Try "xorgconfig" or "xf86config".
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dell Dimension 2100 XOrg "No Screens Found" sigloiv Linux - General 0 02-17-2005 05:57 PM
Nvidia Driver "screens found but no working config" under suse 9.2 ultramancool Linux - Hardware 1 02-15-2005 02:59 PM
Mandrake 10.1/GeForce 4600... xorg error "no screens found" SAFX Mandriva 8 10-18-2004 01:02 PM
Driver "nvidia" causes Fatal Error: no screens found Gamezace Linux - Newbie 3 04-19-2004 05:06 PM
the old "no screens found" again w/ ati aiw 9600 128 pro greenareyou Linux - Newbie 2 02-05-2004 12:57 AM


All times are GMT -5. The time now is 10:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration