LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-21-2004, 03:05 PM   #1
kaz4u2dig
Member
 
Registered: Jan 2004
Distribution: Suse Pro 9.0
Posts: 84

Rep: Reputation: 15
Question screen in linux is TOO BIG!!! no solution


Hello,
I pieced a pc together and loaded SuSe 7.0 personal and the screen resolution is too big. Its so big that I cannot see the buttons at the bottom (OK, APPLY, CLOSE, ets..) Now how am I supposed to learn anything if on most windows I cannot say "ok". Now I managed to get around enough to search just about every setting on the KDE. The closest I came to fixing the screen resolution is "cache" if i recall correctly. when I moved it, it didnt stop on known numners such as (1024, etc.), It would stop on 1074 or something like that. Now I read just about every forum on Google trying to fix this annoying problem and I am so new to linux that I dont even know what to do with a command like "xf86config" when i put it in the Konsole logged on as root it brings up a paragraph of useless info. It lookes nothing like what the forums described. I pressed continue looking for anything to do with video... and there wasnt any.. just mouse, keyboard, etc. I also tried the command "sax" in the Konsole and I have never seen a ridiculous array of colors... screen went crazy and I had to restart my machine. How do I get a decent resolution? Please if your greatful enough to help me could you not skip over some simple things that you would normally take for granted. (eg. go to configure... where would this be... what menu), please include all characters on any commands used in the Konsole.

Thanks
 
Old 01-21-2004, 03:33 PM   #2
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
As root you must edit /etc/X11/XF86Config-4 to suit your hardware and personal preferences and then restart the X server (log out and then log in again).

First set the correct settings for your monitor, HorizSync and VertRefresh. Refer to your monitor manual for the correct settings or use www.google.com/linux for a bit of browsing.
The monitor section looks something like this:
Code:
Section "Monitor"
        Identifier      "Monitor0"
        VendorName      "Monitor Vendor"
        ModelName       "Monitor Model"
        HorizSync       31.5 - 57.0
        VertRefresh     50.0 - 90.0
EndSection
You'll want the correct settings here or you will not be able to find a decent setting.

The Screen section is equally important. It can be long with lots of different modes listed or it could be short with just one Display subsection and one mode for that subsection. If you have only one setting there you won't be able to change modes, but a first priority is getting it up and working correctly and a resolution which works for you.
Code:
Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        DefaultDepth    16
        SubSection "Display"    # Here we only use one Display subsection
                Depth     16
                Modes           "1024x768"   # ...and only one mode for that Display
        EndSubSection
#        SubSection "Display"    # These four lines are commented out using "#" so they won't be used
#                Depth     24     # ...but I added them so you can see how to use more than one Display subsection
#                Modes           "1024x768" "800x600" 
#      EndSubSection
EndSection
Also make sure you are using the correct driver for your graphics card. For more information on what hardware is supported by what drivers, refer to the documentation on www.xfree86.org.


Håkan

Last edited by hw-tph; 01-21-2004 at 03:35 PM.
 
Old 01-21-2004, 04:08 PM   #3
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Try, when logged into X, hitting control, alt and + (the plus sign on keypad, not next to backspace). This will cycle through all your set screen resolutions in /etc/X11/XF86Config. If that doesn't get you where you need to be, you should get to a command line and reconfigure your X.

I don't know how Suse works for the configuring X, but in slackware, you must be root and in command line and run xf86config. It will be a text based configurator that you'll have to enter in information regarding your hardware and your preferences.

If this doesn't work, you can always edit it manually in a terminal or Konsole by using a text editor (I'm only familiar with vi so I'll walk you through it). Login as root. If you're not already do this:

su -
enter root password

Now, type:

cp /etc/X11/XF86Config /etc/X11/XF86Config.old <always back up changes>

Now type:

vi /etc/X11/XF86Config <note the capitalization>

You'll open up the file and it will look crazy at first. It's not so bad. Use your down arrow or page down keys to move down and up/page up to go up (obviously). Go down until you get to your "Screen section". It should look similar to this:

Code:
# **********************************************************************
# Screen sections
# **********************************************************************

# Any number of screen sections may be present. Each describes
# the configuration of a single screen. A single specific screen section
# may be specified from the X server command line with the "-screen"
# option.
Section "Screen"
Identifier "Screen 1"
Device "VESA Framebuffer"
Monitor "My Monitor"

# If your card can handle it, a higher default color depth (like 24 or 32)
# is highly recommended.

# DefaultDepth 8
# DefaultDepth 16
DefaultDepth 24
# DefaultDepth 32

# "1024x768" is also a conservative usable default resolution. If you
# have a better monitor, feel free to try resolutions such as
# "1152x864", "1280x1024", "1600x1200", and "1800x1400" (or whatever your
# card/monitor can produce)

Subsection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubsection
Subsection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubsection
Subsection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubsection
Subsection "Display"
Depth 32
Modes "1024x768" "800x600" "640x480"
EndSubsection

EndSection
Now the section above is set to a default depth of 32 (yours might differ). The Default Depth settings are shown with:

Modes "1024x768" "800x600" "640x480"

This will default X's resolution to 1024x768. If you hit CTRL+ALT++ you will cycle through 640x480 and then to 800x600. If you hit CTRL+ALT+-, you will cycle through 800x600 then 640x480.

If yours looks like the one above with the multiple default depths, you'll need to comment out the ones you don't want with a # sign, and uncomment (remove #) from the one you do want.

Move your cursor (using arrow keys) to the beginning of the line you want to comment out. Hit your I (eye not ell) key to get into Insert mode. Now type #. Hit Esc key. Use arrows to get to the # sign at the beginning of the line you want to uncomment (make available) and hit your X key. The # sign is deleted.

If yours doesn't look like that and only has one line of DefaultDepth with a number you don't like (say 8) and you want to make it 24, then move your cursor to the 8 and hit your X key. It's gone. Now hit your I (eye not ell) key and type 24. Now hit Esc again.

Go to the line with the modes that is your DefaultDepth (in this example 24) so:

Depth 24
Modes "1024x768" "800x600" "640x480"

if you don't want it to start at 1024x768 but rather 800x600, move your cursor to the " infront of 1024x768" and hit your X key until it's gone. If you want to re-add the mode, but not as the default resolution for DefaultDepth 24, put it somewhere else by moving your cursor where you want it to be, and hit I (eye not ell) then typing "1024x768".

Now, to write and save the file, you'll need to do hit Esc and type:

:wq <notice the : (colon)--VERY important>

If you do something wrong and can't fix it and start freaking out, at anytime, you can hit

Esc
:q!

to quit without saving. Don't worry though, because you already backed up the original, you can use that one again as if nothing ever happened. Once you quit vi, you'll be back to the command line. If you fsck it up too much and want to use the original, type this:

rm /etc/X11/XF86Config

then

mv /etc/X11/XF86Config. old /etc/X11/XF86Config

You can then startx as though nothing ever happend (but that's not what we want--we want to fix your resolution. )

If you're unsure of vi, try pico /etc/X11/XF86Config or nano /etc/X11/XF86Config or another editor of your choice. I've never used anything but vi so maybe someone else can help you there.

Hopefully this gets you where you need to be.

Last edited by Texicle; 01-21-2004 at 04:19 PM.
 
Old 01-21-2004, 04:10 PM   #4
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Oh yeah, on Suse it could very well be /etc/X11/XF86Config-4 as hw-tph said. If so, then the above directions should be followed but add -4 to all the references of /etc/X11/XF86Config.
 
Old 01-21-2004, 06:39 PM   #5
kaz4u2dig
Member
 
Registered: Jan 2004
Distribution: Suse Pro 9.0
Posts: 84

Original Poster
Rep: Reputation: 15
hw-tph - I tried your instructions and this is where i got:
"edit /etc/X11/XF86Config-4"
this did something... then I logged out and back in again into root because i dont know how to create a login name and password... any how
then i found the frequencies for my monitor.... and thats it
i dont know where to go to enter them... STUCK
PLEASE HELP!

texicle here is how far i got with your instructions:
i have tried that short cut with cntrl+alt++ on the keypad... it doesnt work
secondly
"XF86Config"
The XF86Config file usually resides in /user/X11R6/lib/X11 or /etc. A sample ......... text ! ......... Press enter to continue, or ctrl-c to abort.
the rest is all about mouses... nothing about monitors
"su -"
cp /etc/X11/XF86Config /etc/X11/XF86Config.old
enter
vi /etc/X11/XF86Config
bunch of quotation marks and blank screen except for at the bottom:
"/etc/X11XF86Config" [New File] 0,0-1 All
what now... looks like a dead end to me! Arrows and Page dn dont work!
<sigh> I have yet to see a reason to use this OS please make me a believer.
 
Old 01-21-2004, 09:00 PM   #6
fancypiper
Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
When you are using x and the window is bigger than the screen, you can drag the window around if you hold down alt and then left click-drag with the mouse.

Look through the software available in your yast tool and see if you can install either Midnight Commander or nano. Both of these have easy to use editing commands.

An Introduction to the Midnight Commander
Midnight Commander home page
Nano text editor

# Configuring X
Linux Hardware Compatibility HOWTO - video cards
The Linux XFree86 HOWTO
Configuring XFree86 for a Non-Specific Linux Distribution
Common X configuring tools:
You may have one or more of these tools:
XF86Setup
XFree86 -configure
Xconfigurator
xf86cfg
xf86config
xconf
ATI Linux drivers
If you need the nVidia driver, you want the Linux IA32 driver unless you just bought the new AMD 64 bit CPU

Last edited by fancypiper; 01-21-2004 at 09:03 PM.
 
Old 01-21-2004, 09:06 PM   #7
kaz4u2dig
Member
 
Registered: Jan 2004
Distribution: Suse Pro 9.0
Posts: 84

Original Poster
Rep: Reputation: 15
fancypiper you rock!
 
Old 01-21-2004, 11:21 PM   #8
kaz4u2dig
Member
 
Registered: Jan 2004
Distribution: Suse Pro 9.0
Posts: 84

Original Poster
Rep: Reputation: 15
ok finally found the file and learned how to change it and save it as above... but still nothing happens... i restarted, refreshed, and upped the cache, but nothing happens... same resolution...

NO RESOLUSION TO THIS PROBLEM AHHHHHHHH! THIS OS *%*^
 
Old 01-21-2004, 11:28 PM   #9
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Did you try one of the following from FancyPiper's suggestion?

Quote:
You may have one or more of these tools:
XF86Setup
XFree86 -configure
Xconfigurator
xf86cfg
xf86config
xconf
Try typing any of those as root into your command line. Make sure your capitalization is correct as well. This should get you well on your way to where you want to be. Otherwise, please give us more detail of your XF86Config-4 file and more details on the problem.
 
Old 01-21-2004, 11:33 PM   #10
kaz4u2dig
Member
 
Registered: Jan 2004
Distribution: Suse Pro 9.0
Posts: 84

Original Poster
Rep: Reputation: 15
HIS REPLIES TAUGHT ME ALOT... BUT NOT TO SOLVE THIS PROBLEM... IN ADDITION I DID LEARN THAT UNTIL I AM A GURU WITH 10 YEARS EXPERIENCE, LINUX IS AND WILL BE EXTREMELY DIFFICULT TO USE FOR SIMPLE TASKS AND THE HARDWARE CONFIGURATION IS JUST NOT POSSIBLE FOR A NEWB.
 
Old 01-21-2004, 11:44 PM   #11
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
WTF are you talking about? You think everyone here was just born with the knowledge of Linux? We all started learning it. You started learning windows at some point too. And it wasn't easy at first.

And you're WRONG about it being now and will be int he future extremely difficult to use for simple tasks. I've been a windows user since it came out and was using DOS when I was like 11 or something. I've used every windows OS out there. At home, I've been running Linux for the past 2 years. I'd never seen it before.

If you don't want to take the time to learn how to use it and use it well, then it's probably not for you. But remember you gave windows a chance and learned it, so give this one a chance too.

We've given you everything you need to fix your problem, and it doesn't work. Either you didn't read all that stuff, didn't try any of it, or the problem is different from what you're saying and you need to explain it a little better for us. Everything everyone has said in this thread should've solved your problem.

If not, perhaps re-install it and choose the correct options when setting up X.
 
Old 01-27-2004, 06:28 PM   #12
claudius753
Member
 
Registered: Jan 2004
Distribution: Mac OS X 10.6.4 "Snow Leopard", Win 7, Ubuntu 10.04
Posts: 322

Rep: Reputation: 31
Not sure if this is the same problem that i am having.

I've looked over those sites and config tools. I'm still having this problem.

I'm running VectorLinux 4.0 with XFree86 4.3.0
My desktop is cut off. Its as if some one cropped the desktop so only the upper right corner (about 1/4 off the left and 1/4 off the bottom). The workspace tool bar thingy (called taskbar in linux?) still there but there are icons that extend beyond where the screen ends. I've used 800x600 16bit in windows 98 on this laptop before i installed linux, so i am sure that the card will handle it.

This happens when i use IceWM, Fluxbox, and XFCE.

The fonts are also wierd looking, and if you cropped a picture and zoomed it, loosing resolution.

previously i had RH 9 on it and it worked fine but was incredibly slow, so i tried Vector which is for older computer.

Any other ideas?
 
Old 01-27-2004, 09:55 PM   #13
kaz4u2dig
Member
 
Registered: Jan 2004
Distribution: Suse Pro 9.0
Posts: 84

Original Poster
Rep: Reputation: 15
ctnl + alt + -
other than that learn how to configure the XF86Config file its in one of my posts in the past week or so
 
Old 01-28-2004, 12:37 AM   #14
elevators_out
LQ Newbie
 
Registered: Jan 2004
Posts: 5

Rep: Reputation: 0
I am wondering if this problem is much simpler than it has been made out to be. I had, or at least thought I had a similiar problem when installing linux. I am using Red Hat 9 and am in Gnome. My computer has a sucky generic compaq video card and a 15 inch monitor.

I was thinking that I couldn't see the "close" "ok" and other buttons at the bottom of some windows, when I finally realized that some windows do not have "ok" buttons. In those windows you just hit the configuration you want and hit X and it saves it. On any other window if you hit the max button it will make it fit the screen so you can see the buttons at the bottom. OBviously as a Windows user I am always used to haveing an OK or Cancel button, so it was confusing at first to find some places with no ok button. Please, do not be upset with me if you already knew this, but if not it may be something to keep in mind.
 
Old 01-28-2004, 07:44 AM   #15
bluesman2333
Member
 
Registered: Dec 2003
Location: Phoenix, Az.
Distribution: Xubuntu Edgy
Posts: 330

Rep: Reputation: 30
This problem (the OP's problem) is exactly like the one I had when I first installed Linux. My canvas was way to big for my physical viewing area on the monitor. I hit the configure button on the monitor and changed the settings directly on the monitor. I was not aware you could do it in software, as I saw this as a hardware problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
qemu screen WAY too big Devbmx Linux - Software 1 05-03-2005 07:28 AM
Solution: Login XDM Screen instead of KDM jess1975 Suse/Novell 2 04-26-2005 01:51 AM
tv-out, screen too big.. Hex29A Linux - Hardware 1 02-10-2004 10:23 AM
Screen Mackin' Big and Off Screen With Slackware. SammyK Linux - General 1 10-01-2003 08:16 AM
Black screen when starting X -- solution! glorinc Linux - Hardware 1 07-22-2002 05:59 PM


All times are GMT -5. The time now is 07:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration