LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-17-2006, 08:09 PM   #1
kimo_anton
LQ Newbie
 
Registered: Jul 2006
Posts: 29

Rep: Reputation: 15
SCIM input box


Hey everybody,

I'm running Zenwalk and having trouble with SCIM. I've got it installed - such that I have a little tool bar on my screen that allows me to switch through different IMEs and such, but when I open Abiword or anything else that I'd like to type in a foreign language on, specifically Japanese, I don't get the little "input box" that I've read I'm supposed to get. I've tried right clicking on on the field and changing "input method" but the only option is "default". I've also tried pressing "ctrl+space" to no avail.

any clues?
 
Old 10-18-2006, 12:03 AM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948
scim is only a frontend. You also need to install an IME program like anthy or prime, plus the related anthy-scim, prime-scim, etc. packages. That's the nice thing about the scim system, you can switch between many different input editors.

Here's a good page on International text support. It focuses on Debian, but I'm sure you can adapt it to your system. http://www.jw-stumpel.nl/stestu.html
 
Old 10-19-2006, 04:34 PM   #3
kimo_anton
LQ Newbie
 
Registered: Jul 2006
Posts: 29

Original Poster
Rep: Reputation: 15
Thanks for the reply David.

I briefly skimmed (no pun intended) the page you sent me and will read it in more detail today. But I just wanted to let you know a couple things that I should have earlier while I have your attention.
I should have mentioned that I have downloaded and installed the follwing:

anthy-8130
m17n-db-1.3.3
m17n-docs-1.3.3
m17n-liub-1.3.3
scim-anthy-1.2
scim-m17n-0.2.1
scim-table-0.5.7
scim-1.4.5

When I do a scim -l, this is what I get:

jim[~]$ scim -l
Smart Common Input Method 1.4.5


Available FrontEnd module:
socket
x11

Available Config module:
simple
socket
dummy

Available IMEngine module:
anthy
m17n
rawcode
socket
table
I've started scim by running various combinations of these options, but I always get the same result. I"m very much a newbie with regards to linux and any kind of computer programing in general, but if I had to guess I would say that something has to be changed to tell my computer to use scim for input. I added the following lines to my .xinitrc file as per some instructions I read somewhere:

LC_TYPEC="ja_JP.UTF8"
export XMODIFIERS=@im=SCIM
export GTK_IM_MODULE="scim"
export QT_IM_MODULE="scim"
scim -f x11 -d

I don't know if this is correct or even does anything, but it is the only thing I can think of that might be wrong since it's the only thing I'm not sure about.

The only other information I think I can provide you with is that I'm running on Zenwalk which runs on a XFCE based desktop.

Thanks again,
Jim
 
Old 10-26-2006, 07:16 PM   #4
kimo_anton
LQ Newbie
 
Registered: Jul 2006
Posts: 29

Original Poster
Rep: Reputation: 15
Got It

http://www.linuxquestions.org/questi...85#post2478685
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can I input other languages use SCIM on an English session? jialin Fedora 2 05-09-2006 09:13 AM
Japanese input not working in Qt with SCIM-QTIMM AireTamStorm Linux - Software 1 04-30-2006 10:33 AM
Is there anyone who know how to use the smart common input method (scim) TruongAn Linux - General 0 11-05-2005 07:21 AM
chinese input SCIM -d doesn't work xjchen001 Linux - Newbie 1 09-15-2005 09:14 PM
Chinese input using SCIM in OpenOffice satellite360 Linux - Software 4 05-17-2005 09:21 AM


All times are GMT -5. The time now is 03:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration