LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-05-2006, 07:48 PM   #1
ronyfedrer
LQ Newbie
 
Registered: Aug 2006
Distribution: Gentoo and only Gentoo
Posts: 8

Rep: Reputation: 0
Question Scanning for unwanted modules at boot


Am using gentoo kernel 2.6.17-gentoo-r4,during the system boot process the comp scans for more than 20 drivers ," eg:scanning for ehci-hcd in ..../module.dep....file or directory not found".i think most of the drivers it scans are related to usb(ehc-hcd,usb-storage,uhci-hcd,sl811-hcd...etc),ieee 1394..then a lot of drivers related to sata(sata_via,sata_promise,sata_sis..etc)..and ends the scanning session with the modules like dm_mod,dm-mirror.No problem for me to boot in gentoo.i got USB ports in my computer,i compiled the kernel both by disabling and enabling my USB ports,but still got the same scan message at boot.i didnt have any sata support or firewire either in my hardware hence not in the kernel too,also hotplug is disabled.Help me on this.
 
Old 08-06-2006, 01:07 PM   #2
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 14.2 Solus
Posts: 2,264

Rep: Reputation: 51
Is there an actual question in there someplace?
 
Old 08-06-2006, 06:55 PM   #3
ronyfedrer
LQ Newbie
 
Registered: Aug 2006
Distribution: Gentoo and only Gentoo
Posts: 8

Original Poster
Rep: Reputation: 0
the question..how can i eliminate those scans at the boot
 
Old 08-06-2006, 06:57 PM   #4
ronyfedrer
LQ Newbie
 
Registered: Aug 2006
Distribution: Gentoo and only Gentoo
Posts: 8

Original Poster
Rep: Reputation: 0
how can i eliminate these scans at the boot..eventhough no problem for me for booting into kernel..the scanning failed logs scrolling down the screen is realyy annoying
 
Old 08-06-2006, 07:23 PM   #5
sabit
Member
 
Registered: Dec 2004
Distribution: Gentoo
Posts: 44

Rep: Reputation: 15
Try editing /etc/modules.autoload and deleting the unused modules.

(also /etc/modules.autoload.d/kernel-2.6)
 
Old 08-06-2006, 07:49 PM   #6
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,959

Rep: Reputation: Disabled
2.6.17-gentoo-r4 - this looks like you compiled it yourself. So why did you build all those modules in first place?
 
Old 08-07-2006, 02:14 AM   #7
ronyfedrer
LQ Newbie
 
Registered: Aug 2006
Distribution: Gentoo and only Gentoo
Posts: 8

Original Poster
Rep: Reputation: 0
nothing unusual at modules.autoload.yes i compiled the module myself but i given support for those usb modules in my previously built kernel..but again showing the same "scanning for ...",at the boot time.These scanning happens just after the hardware detection.The initrd image am using is still the old one,is that causing the problem?
 
Old 08-08-2006, 10:10 AM   #8
ronyfedrer
LQ Newbie
 
Registered: Aug 2006
Distribution: Gentoo and only Gentoo
Posts: 8

Original Poster
Rep: Reputation: 0
i got the exact problem seen in this this thread,http://forums.gentoo.org/viewtopic.php?t=466962,this thread ends with no solution..if any one can resurrect this from scratch..that will be great
 
Old 08-08-2006, 10:39 AM   #9
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,959

Rep: Reputation: Disabled
First, configure your kernel for your hardware. It takes some time because you have to step thru all submenus, disable everything you do not need. Compile everything in what you do need, leave ALSA as modules (and some other things not always in use as floppy, etc.). There is no point using initrd with self-compiled kernel.
Second, since you already have same version of kernel installed - clean up /lib/modules/<your_kernel_version> before running 'make modules_install'.
 
Old 08-08-2006, 12:27 PM   #10
ronyfedrer
LQ Newbie
 
Registered: Aug 2006
Distribution: Gentoo and only Gentoo
Posts: 8

Original Poster
Rep: Reputation: 0
i already done all those things mentioned above..i even deleted the modules folder before the compilation of my new kernel,again it is ended with same problem,if any one nevemind ,please go through this link http://forums.gentoo.org/viewtopic.php?t=466962
If any one can say a good solution to this problem is really helpful
 
Old 08-08-2006, 12:45 PM   #11
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,959

Rep: Reputation: Disabled
OK, there is a common mistake even seasoned Gentoo users do sometimes - they forget to mount /boot before copying the kernel image there. This means your new kernel ends up in /boot directory of root partition and is not used at all. Make sure you have your /boot mounted before installing kernel.
 
Old 08-08-2006, 06:23 PM   #12
ronyfedrer
LQ Newbie
 
Registered: Aug 2006
Distribution: Gentoo and only Gentoo
Posts: 8

Original Poster
Rep: Reputation: 0
Thats a good guess but i dont have any seperate boot partition,so that possibility rules out.i think this is the problem with modules,first i got the kernel that comes with the fresh installation of gentoo,then i changed it to the current one,but one thing i noticed is that,when booting from gentoo 2006 live cd,it scans for these modules at the boot,and the scan is a success there,the error produced is that"on scanning the corresponding modules are not found in module.dep",if anything interesting strikes to any one please keep posting.
 
Old 08-08-2006, 06:41 PM   #13
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,959

Rep: Reputation: Disabled
Are you sure you cleaned up /etc/modules.autoload.d/kernel-2.6 as sabbit suggested in post #5? And removed initrd from grub.conf as I suggested in post #9?
 
Old 08-09-2006, 02:19 AM   #14
ronyfedrer
LQ Newbie
 
Registered: Aug 2006
Distribution: Gentoo and only Gentoo
Posts: 8

Original Poster
Rep: Reputation: 0
yes thats it.i noticed your comment about the initrd in your previous post as initrd has got nothing to do with newly compiled kernel,but it didnt striked me that the same thing causing the problem for me,actually initrd was really un-noticable.Now i removed the line of initrd in grub.conf and now my gentoo boots without any scanning.
And my experience with this problem was very funny,i compiled the kernel for about dozen times,played with modules..any way it was a very learning experience for me.thanks really to Emerson,sabot,sabot for responding.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
using modules.conf to start modules at boot knobby67 Debian 1 05-31-2006 11:54 AM
Suse Linux 9.1 Pro: boot hang on "scanning pci..." paulsm4 Linux - Software 1 11-16-2004 02:54 PM
how do i boot into linux without it scanning all hd Razgo Linux - General 12 12-28-2003 06:03 AM
Scanning sistem on boot?!? caphclimber Linux - Software 4 09-03-2003 06:28 PM
Re: modprobe: Note: /etc/modules.conf is more recent than lib/modules/2.4.9/modules.d Andy.M Linux - General 1 01-24-2002 01:50 AM


All times are GMT -5. The time now is 12:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration