LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-20-2005, 06:16 PM   #1
nox9colt45
LQ Newbie
 
Registered: Mar 2005
Posts: 12

Rep: Reputation: 0
Saving file in Kernel


I know this is probably elementry to a lot of you, and ive done it once and just cant remember how.

I have edited my XF86Config file in kernel, (X server isnt working) and i forget the keyboard command to save file.

Thanks
 
Old 03-20-2005, 06:21 PM   #2
simeandrews
Member
 
Registered: May 2004
Distribution: Debian
Posts: 341
Blog Entries: 1

Rep: Reputation: 30
What editor are oyu using? if you're using pico, than I think it is ctrl+s. Or is there some special xf86 editor? I'm just trying to think up solutions here.
 
Old 03-20-2005, 06:23 PM   #3
nox9colt45
LQ Newbie
 
Registered: Mar 2005
Posts: 12

Original Poster
Rep: Reputation: 0
well, not sure exactly. In Suse 9.2 kernel, i just type

Edit XF86Config


When already in the directory obviosuly. If there is a better way to edit the file im open for suggestions.

Last edited by nox9colt45; 03-20-2005 at 06:58 PM.
 
Old 03-20-2005, 06:53 PM   #4
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
You mean console, not kernel

Try:

pico XF86cfg

(or whatever the file is called)
 
Old 03-20-2005, 06:57 PM   #5
nox9colt45
LQ Newbie
 
Registered: Mar 2005
Posts: 12

Original Poster
Rep: Reputation: 0
lol sry, wasnt thinking. Pico was an unknown command.
 
Old 03-20-2005, 07:02 PM   #6
simeandrews
Member
 
Registered: May 2004
Distribution: Debian
Posts: 341
Blog Entries: 1

Rep: Reputation: 30
Try "vi" or "vim" followed by the name of the file.
 
Old 03-20-2005, 07:06 PM   #7
nox9colt45
LQ Newbie
 
Registered: Mar 2005
Posts: 12

Original Poster
Rep: Reputation: 0
that works, but its pretty much the exact same editor. I did find this post...



about the whole vi command thing, to exit with saving, type ":wq"



But dont understand how to type in :wq. i type it in as its inside the file...?

By the way, thakns for quick responses, ive been sitting here on my windows machine with my XF86Config file open in the console on other computer
 
Old 03-20-2005, 07:08 PM   #8
simeandrews
Member
 
Registered: May 2004
Distribution: Debian
Posts: 341
Blog Entries: 1

Rep: Reputation: 30
Also, to save, press <esc> , then type :save
 
Old 03-20-2005, 07:10 PM   #9
simeandrews
Member
 
Registered: May 2004
Distribution: Debian
Posts: 341
Blog Entries: 1

Rep: Reputation: 30
Wow we just responded at the exact same time. Anyway, to put anything in, press the <esc> key I figured out. Then just type :whatever
 
Old 03-20-2005, 07:11 PM   #10
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
do this at the terminal prompt, exactly as I say it:
Code:
cat > ~/.vimrc
set nocompatible
set backspace=2
set ruler
syntax on
press ctrl-d to exit that.

Next:
vim XF86cfg
(or whatever the filename is)

Press i to enter insert mode (so you can edit the text) then press escape when you're done and THEN type :wq to save it.
 
Old 03-20-2005, 07:14 PM   #11
simeandrews
Member
 
Registered: May 2004
Distribution: Debian
Posts: 341
Blog Entries: 1

Rep: Reputation: 30
WE have an instant messenger kinda thing going on here.
 
Old 03-20-2005, 07:16 PM   #12
nox9colt45
LQ Newbie
 
Registered: Mar 2005
Posts: 12

Original Poster
Rep: Reputation: 0
ok, last but not lesat,

That worked great thanks, but when i try to save it, it says...

Readonly option is set. (Add ! argument to overwrite)


so i tried :save !XF96Config -> sayed saved or something, but didntt. opened it back up and my edit wasnt there.


i missed like 2 post's there while i was typing this lol..... so i still need to try your post komo.


Ok did all that, and i like the change :-). But i get the same error abuot readonly option is set as i said above. (using :wq)


EDIT:
Got it working by typing :wq! Thanks a lot guys. Just too bad that edit didnt fix my problem. Got a few more hours of fliddling.

Thanks again! <3

Last edited by nox9colt45; 03-20-2005 at 07:24 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
saving file blackzone Programming 5 01-21-2005 06:51 PM
saving file darkangel29 Linux - Newbie 2 11-25-2004 02:16 PM
Saving as a file in C++ dfownz Programming 3 07-03-2004 09:39 AM
software organization, file systems, and kernel saving??? Ekj530 Slackware 2 09-08-2003 01:13 AM
Saving file as PDF crash89 Linux - General 2 09-05-2001 10:05 PM


All times are GMT -5. The time now is 06:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration