LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-13-2003, 12:48 PM   #1
garr0323
Member
 
Registered: Oct 2003
Distribution: Slackware9.1, Mandrake9.1
Posts: 70

Rep: Reputation: 15
Samba wont start


I have been asking a lot of questions lately so im sorry but i have been trying things on my own and i have gotten them to work but i cant get samba to work.

I downloaded the binary file and compiled and installed everything successfully. i looked at some help files that i found on the internet about enabling SWAT.

swat stream tcp nowait.400 root /usr/sbin/swat swat
this is what the control entry might look like and this is what mine looks like. the inetd is running.

But when i went to use swat i typed in http://localhost:901. and it didnt find it.

if i didnt word this right or something please let me know. i am getting very angry. thanks
 
Old 10-13-2003, 01:53 PM   #2
jdc2048
Member
 
Registered: Jul 2002
Location: Ohio, USA
Distribution: Redhat, Gentoo, Solaris, HP-UX, etc...
Posts: 391

Rep: Reputation: 30
Don't worry about asking questions, that is what the forum is for.

Do you have an entry in /etc/services mapping swat to port 901?


------------------
Jeremiah
 
Old 10-13-2003, 01:59 PM   #3
garr0323
Member
 
Registered: Oct 2003
Distribution: Slackware9.1, Mandrake9.1
Posts: 70

Original Poster
Rep: Reputation: 15
yes i opened /etc/services and it said
"swat 901/tcp # samba web configuration tool'
 
Old 10-13-2003, 02:25 PM   #4
alm
Member
 
Registered: Mar 2003
Location: Sweden
Distribution: RedHat
Posts: 32

Rep: Reputation: 15
I am just a newbie trying to help, but,
you are sure that the program is set to localhost and not to some other protocol like eth0?
And also, that there is no firewall preventing access?

What often is the case (for me) when a program doesn't work is that I've been misconfiguring the config-files in some way but I can't help you with SWAT.

Does this make any sense to you?
 
Old 10-13-2003, 02:44 PM   #5
jdc2048
Member
 
Registered: Jul 2002
Location: Ohio, USA
Distribution: Redhat, Gentoo, Solaris, HP-UX, etc...
Posts: 391

Rep: Reputation: 30
run the command "chkconfig swat --list" and post the output.


<edit>

Just realized I don't know if you are running RH or not. The command above works on RH, not sure if it works elsewhere as I am not running anything else right now.

Last edited by jdc2048; 10-13-2003 at 02:45 PM.
 
Old 10-13-2003, 02:47 PM   #6
garr0323
Member
 
Registered: Oct 2003
Distribution: Slackware9.1, Mandrake9.1
Posts: 70

Original Poster
Rep: Reputation: 15
where would i check to see if it is set to localhost?
 
Old 10-13-2003, 03:03 PM   #7
alm
Member
 
Registered: Mar 2003
Location: Sweden
Distribution: RedHat
Posts: 32

Rep: Reputation: 15
does jdc's suggestion apply? otherwise,

if you type "netstat -l " (that is an l as in linux)

do you get a line like this?
tcp 0 0 *:swat *:* LISTEN
 
Old 10-13-2003, 03:53 PM   #8
Tyir
Member
 
Registered: Sep 2003
Distribution: Slackware 9.1 with fluxbox
Posts: 259

Rep: Reputation: 30
hi, i have the same problem, but there is no swat listing in /etc /sevices

where am I supposed to put that line?
"swat 901/tcp # samba web configuration tool'

Also, i DONT get this
tcp 0 0 *:swat *:* LISTEN
in netstat
 
Old 10-13-2003, 04:01 PM   #9
jdc2048
Member
 
Registered: Jul 2002
Location: Ohio, USA
Distribution: Redhat, Gentoo, Solaris, HP-UX, etc...
Posts: 391

Rep: Reputation: 30
Tyir,
If you don't have that piece in your /etc/services file, then you won't get the output from netstat.

Put that "swat 901/tcp # sam...." piece anywhere in that file. It is easier to keep track of if you put it in numerical order, but it is not necessary.
 
Old 10-13-2003, 04:03 PM   #10
alm
Member
 
Registered: Mar 2003
Location: Sweden
Distribution: RedHat
Posts: 32

Rep: Reputation: 15
Tyir:

Read the manual : "man swat"


/ alm
 
Old 10-13-2003, 04:10 PM   #11
Tyir
Member
 
Registered: Sep 2003
Distribution: Slackware 9.1 with fluxbox
Posts: 259

Rep: Reputation: 30
I already had the file for the Xinetd installtion

/etc/xinetd.d/swat
 
Old 10-13-2003, 04:20 PM   #12
garr0323
Member
 
Registered: Oct 2003
Distribution: Slackware9.1, Mandrake9.1
Posts: 70

Original Poster
Rep: Reputation: 15
no i didnt get the "tcp 0 0 swat listen

I am running Slackware9.1
 
Old 10-13-2003, 04:21 PM   #13
alm
Member
 
Registered: Mar 2003
Location: Sweden
Distribution: RedHat
Posts: 32

Rep: Reputation: 15
Tyir:

If your computer is like mine, edit that file so that the last line reads disabled = no
Then kill the xinetd (i needed to start it up manually again aswell with "xinetd")

Last edited by alm; 10-13-2003 at 04:22 PM.
 
Old 10-13-2003, 04:22 PM   #14
garr0323
Member
 
Registered: Oct 2003
Distribution: Slackware9.1, Mandrake9.1
Posts: 70

Original Poster
Rep: Reputation: 15
this is what the output of netstat -l

garrett@garrett:~$ netstat -l
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 *:time *:* LISTEN
tcp 0 0 *:submission *:* LISTEN
tcp 0 0 *:finger *:* LISTEN
tcp 0 0 *:x11 *:* LISTEN
tcp 0 0 *:auth *:* LISTEN
tcp 0 0 *:ftp *:* LISTEN
tcp 0 0 *:ssh *:* LISTEN
tcp 0 0 *:631 *:* LISTEN
tcp 0 0 *:smtp *:* LISTEN
udp 0 0 *:biff *:*
udp 0 0 *:biff *:*
udp 0 0 *:ntalk *:*
udp 0 0 *:ntalk *:*
udp 0 0 *:time *:*
udp 0 0 *:time *:*
udp 13124 0 *:bootpc *:*
udp 0 0 *:32852 *:*
udp 0 0 *:631 *:*
Active UNIX domain sockets (only servers)
Proto RefCnt Flags Type State I-Node Path
unix 2 [ ACC ] STREAM LISTENING 6590 /tmp/ksocket-garrett/kd
einit-:0
unix 2 [ ACC ] STREAM LISTENING 6620 /tmp/ksocket-garrett/kl
aunchert9oSla.slave-socket
unix 2 [ ACC ] STREAM LISTENING 7131 /tmp/ksocket-garrett/kd esud_:0
unix 2 [ ACC ] STREAM LISTENING 6594 /tmp/.ICE-unix/dcop2429 -1065980458
unix 2 [ ACC ] STREAM LISTENING 6727 /tmp/.ICE-unix/2452
unix 2 [ ACC ] STREAM LISTENING 6563 /tmp/.X11-unix/X0
unix 2 [ ACC ] STREAM LISTENING 6687 /tmp/mcop-garrett/garre tt_home-098f-3f89922b
unix 2 [ ACC ] STREAM LISTENING 1112 /dev/gpmctl
 
Old 10-13-2003, 04:32 PM   #15
alm
Member
 
Registered: Mar 2003
Location: Sweden
Distribution: RedHat
Posts: 32

Rep: Reputation: 15
garr0323:

You DID restart inetd, right?
If swat was running there would've been a line in the output with swat in it...
My guess is either (1) the line containing the configuration of swat in inetd.conf is wrong (2) you didn't kill off inetd properly (3) you didn't install it correctly (check /usr/sbin/swat).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
when i try to start samba pdc's smb service nmbd failed to start . sandeepchau123 Linux - Newbie 2 10-20-2007 02:59 PM
x wont start! Username[SWE] Debian 5 08-02-2004 05:17 PM
x wont start jsmarshall85 Debian 14 07-22-2004 05:41 PM
Samba wont start Chijtska Linux - Networking 5 02-10-2002 08:00 PM
when i restart SAMBA,it says:stop samba failed,start SAMBA OK! whepin Linux - Networking 3 12-26-2001 06:54 AM


All times are GMT -5. The time now is 12:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration