LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-13-2005, 10:12 PM   #1
HighLife
Member
 
Registered: Feb 2003
Posts: 36

Rep: Reputation: 15
Samba Upgrade Advice


We have a RH7.3 server running Samba 2.2.7a

Yesterday I was trying to troubleshoot a small issue with roaming profiles and it looks like I uncovered a bug in the Samba version we are using.

To fix it I need to upgrade to Samba 3.0.10 or higher. I did not originally set this server up, and it has ran reasonably faultlessly since being set-up. I have some basic Linux skills but am still a novice in most areas.

So - the questions:

1) Does anybody know if I can expect any issues upgrading from Samba 2.2.7a to 3.0.20 on RH7.3?

2) I could not find an RPM package for Samba 3.0.10 so downloaded the 3.0.20 .tar.gz package and am currently practising compiling it for RH7.3 on a spare non-production machine. I have never done a compile from source before. Should I try and make an RPM package from this to install it or just install it with 'make install'?

3) Do I need to uninstall the previous version of Samba before installing the new version?

Any other tips for a novice trying to carry out the upgrade with not many clues!?

Cheers, Jase
 
Old 09-13-2005, 11:06 PM   #2
HighLife
Member
 
Registered: Feb 2003
Posts: 36

Original Poster
Rep: Reputation: 15
..some more info.

I just tried:

#rpm -qa | grep samba

On the server and it didnt return any results. I take this as Samba wasnt installed using rpm in the first place. If I do need to uninstall the current version before I install the upgrade, how do I do this? I know using rpm its as easy as #rpm -e samba_##.##
 
Old 09-14-2005, 10:23 PM   #3
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,241

Rep: Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325
Just FYI, RH7.x is way old and hasn't been supported eg security patches for yrs.
Also, things like the compiler etc have advanced a lot.
You may have major probs getting new software to compile / work.
Also, you are definitely at risk from the security point of view.
If at all possible, please upgrade.
 
Old 09-15-2005, 12:08 AM   #4
HighLife
Member
 
Registered: Feb 2003
Posts: 36

Original Poster
Rep: Reputation: 15
Thanks for your reply Chrism01, yeah I realise our RH7.3 is very much out of date but it has ran flawlessly for 2 years, we are a small network(20-30 users) and the RH machine is on a private network behind a hardware firewall router. So whilst everything was working fine I didnt see any reason to upgrade - especially since RH is no longer and I'd have to either go to Enterprise or another flavour of Linux.

Now we have had a problem I will upgrade the servers but I need to get this Samba bug sorted first to keep us going until I can plan and perform the O/S upgrade. I have a backlog of other projects to finish before then!(I'm the only IT guy here and my main job is Lotus Notes application development!)

FYI, I managed to compile Samba 3.0.20 onto my RH7.3 test mule machine and it appear to have worked ok? I do not have a client server network configured for this particular machine but it compliled and installed without any errors and the smbd nmbd services started ok, so I assume that the installation went ok and any problem from here will be config related?

Can anyone tell me how I uninstall the old version of Samba before installing the new one? As I mentioned, it does not appear to be listed in the rpm packages database so I'm assuming it was not installed using rpm?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat 7.2 upgrade/security advice stoke Red Hat 2 03-21-2005 06:29 AM
Upgrade kernel - advice? bruno buys Debian 10 09-24-2004 05:21 PM
Hardware upgrade advice EnVoy Linux - Hardware 3 11-20-2003 02:06 AM
General Debian Upgrade Advice mudelf Linux - General 2 10-27-2003 07:13 AM
Hardware Upgrade Advice KungFuHamster General 11 10-09-2003 09:14 AM


All times are GMT -5. The time now is 09:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration