LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-12-2009, 12:14 PM   #1
john test
Member
 
Registered: Jul 2008
Distribution: ubuntu 9.10
Posts: 527
Blog Entries: 1

Rep: Reputation: 35
samba swat won't load


I execute:
Code:
$ firefox localhost:901
and it fails to connect
if I do:
Code:
 $ firefox localhost:631
the CUPS page comes up.

is there something I need to do in smb.conf to enable SWAT?
 
Old 04-12-2009, 12:22 PM   #2
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
is the service listening on port 901 ?
Did you open the port in your firewall?
 
Old 04-12-2009, 12:54 PM   #3
john test
Member
 
Registered: Jul 2008
Distribution: ubuntu 9.10
Posts: 527
Blog Entries: 1

Original Poster
Rep: Reputation: 35
Had Ubuntu 7.04 == Samba was installed but did not work -- That said firefox localhost:901 used to work.
Dumped 7.04 and loaded ubuntu 8.04 and then loaded Samba. Samba now works nicely, but firefox localhost:901 fails.

I'm a newbie and the firewall is as it installed several hours ago.

How would I go about discovering if Samba/SWAT is listening on port 901?

Thanks for your help!
 
Old 04-12-2009, 01:16 PM   #4
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Code:
netstat -ltnup
or
Code:
lsof -i4 | grep LISTEN
or
Code:
telnet 127.0.0.1 901
 
Old 04-12-2009, 01:19 PM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,963

Rep: Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530
In a nutshell swat is a web server application to setup the smb.conf file and it runs from xinetd. You need to verify if swat is installed, configured and if xinted has been started.

There is lots and lots of information on the web about samba and swat.
https://help.ubuntu.com/community/Swat
 
Old 04-12-2009, 01:33 PM   #6
john test
Member
 
Registered: Jul 2008
Distribution: ubuntu 9.10
Posts: 527
Blog Entries: 1

Original Poster
Rep: Reputation: 35
Thanks for the help the results you requested are below

]code]
# telnet 127.0.0.1 901
Trying 127.0.0.1...
telnet: Unable to connect to remote host: Connection refused


# lsof -i4 | grep LISTEN
cupsd 4898 root 3u IPv4 21358 TCP localhost:ipp (LISTEN)
smbd 4955 root 19u IPv4 12998 TCP *:microsoft-ds (LISTEN)
smbd 4955 root 20u IPv4 12999 TCP *:netbios-ssn (LISTEN)


# netstat -ltnup
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:139 0.0.0.0:* LISTEN 4955/smbd
tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN 4898/cupsd
tcp 0 0 0.0.0.0:445 0.0.0.0:* LISTEN 4955/smbd
tcp6 0 0 :::22 :::* LISTEN 4838/sshd
udp 0 0 192.168.1.125:137 0.0.0.0:* 4953/nmbd
udp 0 0 0.0.0.0:137 0.0.0.0:* 4953/nmbd
udp 0 0 192.168.1.125:138 0.0.0.0:* 4953/nmbd
udp 0 0 0.0.0.0:138 0.0.0.0:* 4953/nmbd
udp 0 0 0.0.0.0:55384 0.0.0.0:* 4859/avahi-daemon:
udp 0 0 0.0.0.0:5353 0.0.0.0:* 4859/avahi-daemon:
[/code]
So nothing is listening on port 901
What do I need to do to cause that to happen?
 
Old 04-12-2009, 01:35 PM   #7
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Quote:
So nothing is listening on port 901
What do I need to do to cause that to happen?
Read the post from michaelk
 
Old 04-12-2009, 03:20 PM   #8
john test
Member
 
Registered: Jul 2008
Distribution: ubuntu 9.10
Posts: 527
Blog Entries: 1

Original Poster
Rep: Reputation: 35
Whoops Didn't mean to step on MichaelKs post
Thanks to both of you
Sambas up, SWAT is up and I'm off and learning
The commands went into notes and the Site is bookmarked
Thanks again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to up samba with swat winxlinx Linux - General 4 02-08-2006 11:57 AM
Swat will not load! NRHBasher Red Hat 4 03-22-2004 05:03 PM
Swat will not load! NRHBasher Linux - Newbie 7 03-21-2004 11:53 AM
SAMBa and SWAT Snake007uk Linux - General 8 05-16-2002 08:30 PM
samba swat has me chens_83 Linux - General 2 03-22-2002 07:31 PM


All times are GMT -5. The time now is 08:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration