LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-10-2007, 12:10 AM   #1
coffeekid
LQ Newbie
 
Registered: May 2005
Location: Flagstaff, Arizona
Distribution: FC, SuSE, Ubuntu, OSX
Posts: 5

Rep: Reputation: 0
Samba Situation


The Situation: Configuring Samba (on FC6) in a 3 station environment. Running XP Pro on the other two boxes. I'm not interested in running Samba in a PDC capacity. I just need simple file and print sharing.

The Setup: XP boxes already configured for printer and file sharing (netbios enabled); disabled windows firewalls (just in case) on both; all stations can ping each other. Here's how Samba is now configured (because I've played with it ad naseum). Added a share directory /home/samba (Writable and Visible checked). Under access I've enabled only the specific user “j.doe.” On the Basic tab under Preferences >> Server Settings, the Workgroup is set to “samba” (yeah catchy I know; both XP boxes are set to the same Workgroup). On the Security tab Authentication Mode = Unix User / Encrypt Passwords = Yes / Guest Account = nobody. Under Preferences >> Samba Users, Unix Username = j.doe / Windows Username = john / Samba Password = the XP password. I enabled Samba as a trusted service on the Firewall.

The Problem: I have received two different errors on the XP stations

1. \\Localhost \samba is not accessible. You might not have permission to use this network resource. Contact the administrator of the server to find out if you have access permissions.

2. \\Localhost \samba is not accessible. You might not have permission to use this network resource. You were not connected because a duplicate name exists on the network. Go to System in control Panel to change the computer name and try again.

Both computer names are different on the XP boxes.

On more than two different occasions I have accessed the Samba directory on each XP box only to have it blue screen as it opened the folder.

Limited accessibility only occurred immediately after changing the permissions via the root GUI. After a little more reading I then forced rights by # chown 777 /home/samba.

I've spent a lot of time reading and trying to figure this out . . . but . . . to no avail. Anyone with any thoughts?

PS: Yes I did run # testparm . . . all good!

-ck
 
Old 01-10-2007, 04:32 AM   #2
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,517

Rep: Reputation: 90
One idea: How did you access the samba share from XP? The "localhost" is puzzling me, seems like the XP boxes don't know where to find the share!? I usually open the Windows Explorer, click on Network, Whole Network, Microsoft Network (AFAIR it's called something like this, I have no Windows access at the moment) and then on the workgoup's name. There your Linux box should be shown. This way I don't have to remember the IP address or modify the HOSTS file on Windows.
 
Old 01-10-2007, 04:52 AM   #3
Kanon
Member
 
Registered: Sep 2004
Location: Norge
Distribution: Debian
Posts: 116

Rep: Reputation: 15
I have no clue..but I usualy forget to make user pw: smbpasswd <user>
 
Old 01-10-2007, 05:03 AM   #4
shorty943
Member
 
Registered: Dec 2006
Location: Tailem Bend. South Australia
Distribution: Mandriva 2006
Posts: 124

Rep: Reputation: 15
Coffekid, do you use smb4k? My general config lookslike



network set samba as master browser or all windows machines will vote a master network browser amongst themselves.

netbios name ?your server name

domain (workgroup) ? your wkgrp

socket opt tcp_nodelay so rcvbuf

scope empty

remote smb port 139

shares are mounted at /home/user/smb4k/

authentication default login well me, in your case use your normal account

super user sudo

further to that I place a desktop short cut to the samba shares on my server on my Win boxes for easy access.

smb4k just has to be the easiest samba config ever, all graphic, just a few mouse clicks and all is done

Hoping this can help,

Shorty943

registered Linux user
437639 registered Linux machine 77042

Last edited by shorty943; 01-10-2007 at 05:10 AM.
 
Old 01-10-2007, 12:17 PM   #5
coffeekid
LQ Newbie
 
Registered: May 2005
Location: Flagstaff, Arizona
Distribution: FC, SuSE, Ubuntu, OSX
Posts: 5

Original Poster
Rep: Reputation: 0
titopoquito: Correct. I usually access the Samba share via Windows Explorer >> My Network Places >> Entire Network >> Microsoft Windows Network. At this point I can see the Workgroup created for both the XP boxes and FC6. There I can see the 3 machines. "Localhost" is *nix box.

Kanon: Yes, I made sure the passwords were correct and synchronized.

shorty943: No I don't use smb4k. It's my understanding that this runs on KDE. I'm using GNOME. Maybe I'll load KDE and smb4k. At this point I'm not really sure what else to do. Thanks for the suggestion.
 
Old 01-10-2007, 12:31 PM   #6
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,517

Rep: Reputation: 90
Quote:
Originally Posted by coffeekid
"Localhost" is *nix box.
So "Localhost" is really the name of the box, not a mistake? I'm not sure if that is possible. How does Windows resolve this name? I would fear that it cannot distint between "Localhost" and "localhost" which should be the Windows box itself? To be sure about this I would try to ping "Localhost" and see which IP is resolved, if it differs from 127.0.0.1
 
Old 01-10-2007, 02:45 PM   #7
dv502
Member
 
Registered: Sep 2006
Location: USA - NYC
Distribution: Whatever icon you see!
Posts: 642

Rep: Reputation: 57
This is how I connect to my linux box from windows

This has work for me. The first thing is to adjust
the firewalls if any, on linux and windows to allow communications
between them.

Next, edit the /etc/samba/smb.conf file and change the workgroup = MYGROUP to workgroup = YOUR_GROUP_NAME
An example workgroup = STAFF

Save and exit.

Next, add a valid linux user to the smbuser list
As root, type this
smbpasswd -a username

Now you have two accounts - a linux account and a samba
account. You will use the samba account when connecting
from windows to linux via samba.

Next start or restart the samba server.

Now go to your windows box network places and then workgroups. Double-click on the samba server. Enter the username and password you created with the samba account.

And now you should see your linux home directory.

Last edited by dv502; 01-10-2007 at 02:46 PM.
 
Old 01-10-2007, 04:04 PM   #8
julian_gm
LQ Newbie
 
Registered: Jan 2007
Distribution: Fedora Core 6
Posts: 5

Rep: Reputation: 0
I have the same problem mate, if I stop the firewall i can get in from the windows machines, give it a try , type "service iptables stop" and try to access the samba server from xp.

if it works, restart the service , go to the firewall and enable samba.
for the duplicated name error, add this line to the smb.conf file in the global section
netbios name = ANYTHING_BUT_LOCALHOST

hope it helps

Last edited by julian_gm; 01-10-2007 at 04:25 PM.
 
Old 02-18-2007, 07:28 PM   #9
smilliken
LQ Newbie
 
Registered: Jan 2007
Location: BC
Distribution: Mepis 8/8.5
Posts: 3

Rep: Reputation: 0
Turn Off Guarddog

I follow some of the above post. I turned off Guarddog and added no users/passwords. Went to the windows server and the Linux bos was listed in the Windows workgroup. Could browse/copy from and to the Windows box. Started smk4b and it saw all of the Windows boxes on the network. Mounted the drives and was albel again browes/copy from the Windows boxes to the Linux.
 
Old 02-18-2007, 07:45 PM   #10
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,858

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Some linux distributions use localhost as a default hostname. samba uses hostname by default for the netbios name however localhost in networking is the local loopback network adapter i.e. IP address of 127.0.0.1 on every TCP/IP configured computer. So your actually trying to access shares on the client instead of the server. The simplest solution is to add an option in the global section of your smb.conf file like

netbios name = MyComputerName (Change MyComputerName accordingly)

Be sure to restart samba. You should see MyComputerName in network places. Might have to select view network computers and also make sure the workgroup name is the same for all computers. Another way of lookin at shares on the linux via the command box

net view
or
net view \\MyComputerName

Last edited by michaelk; 02-19-2007 at 07:34 AM.
 
Old 02-18-2007, 10:28 PM   #11
inspiron_Droid
Member
 
Registered: Dec 2006
Distribution: Debian (Wheeze)
Posts: 391

Rep: Reputation: Disabled
You should also add the ipaddres of your samba server to the firewall white lists on the windows clients.
 
  


Reply

Tags
client, configuration, permissions, samba, xp


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Serious situation, please help wardialer Mandriva 10 04-22-2005 01:43 AM
my situation thing0 Linux - Newbie 9 02-18-2005 12:22 PM
Need advice on situation I am having BajaNick General 9 07-01-2004 12:46 AM
L 99 99 99 situation after Suse 8.x Wizno Linux - Newbie 3 10-26-2003 02:27 PM
need help with 'no boot' situation fsull Linux - Newbie 7 03-07-2003 11:37 PM


All times are GMT -5. The time now is 11:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration