LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 03-26-2004, 01:08 PM   #1
EnigmaX
Member
 
Registered: Jul 2003
Distribution: Fedora Core 4
Posts: 107

Rep: Reputation: 15
Samba Shares not working


I two shares on a network ran by samba, one works, one doesn't. One is just a read-only folder, and that's the one that works.
The one that doesn't work is the one I have write access and stuff like that in.

Here is.. most of the config file...

[global]
workgroup = BUSINESS
server string = Linux Pwnz
netbios name = Linux-Tech
guest account = nobody
load printers = no
log file = /var/log/samba.%m
max log size = 50
security = share
ssl CA certDir = /etc/ssl/certs
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

dns proxy = no

#============================ Share Definitions ==============================
[iso]
comment = iso
browseable = yes
path = /home/enigx/iso/cd
guest ok = yes
public = yes
read only = yes
writable = no

[Shadow]
comment = Shadow's Files
path = /home/shadow
valid users = shadow
public = no
writable = yes




I have a user named shadow
I did smbpasswd shadow <password>

Is something wrong with the settings?
Note: If I set the security to user, than iso doesn't work.. Dunno if that would make shadow work thuogh..
 
Old 03-26-2004, 01:33 PM   #2
jsokko
Member
 
Registered: Mar 2004
Location: Phila, PA
Distribution: SuSE 9.0 / RH 9 / Slackware 9.1
Posts: 110

Rep: Reputation: 15
1. keep security at user level and not share level.
2. remove your shadow account from samba by using smbpasswd -d.
3. recreate the user by using smbpasswd -a [username]. Make sure you have created a linux user with the same ID first.
4. create a guest account for your ISO share and add by using smbpasswd -a (like #3).
5. restart service
6. check your connection & logs.


J
 
Old 04-01-2004, 07:47 AM   #3
EnigmaX
Member
 
Registered: Jul 2003
Distribution: Fedora Core 4
Posts: 107

Original Poster
Rep: Reputation: 15
I did all that.. I get the following error (I believe because the security is set to user):
\\Linux-tech is not accessible.
The account is not authorized to log in from this station

----

What should I do to make it so that doesn't show up? :/
 
Old 04-01-2004, 09:46 AM   #4
jsokko
Member
 
Registered: Mar 2004
Location: Phila, PA
Distribution: SuSE 9.0 / RH 9 / Slackware 9.1
Posts: 110

Rep: Reputation: 15
Check to see if you have username map = /etc/samba/smbusers or /etc/samba/private/smbusers set. by default, slack shouldn't but who knows... and if it has been uncommented, make sure to create the file and add yourself to it by inserting:

[linuxID] = [smbID]

OR commenting that line out with a semicolon.

and check to see if you have a lmhosts file in /etc/samba/private. if you do, list your machine that you'll be connecting from to the samba share. Make sure to update your /etc/hosts file to make sure it knows your machine's IP if you're not using DHCP.

and try something like this for your Home folder... this will map ALL Samba users to their respective home dirs on the linux box... put this in smb.conf in place of your [shadow] share.

[homes]
comment = Home For Everyone
browseable = yes
writeable = yes
valid users = %S
create mode = 0664
directory mode = 0775


let me know if and how it works out for you.

Last edited by jsokko; 04-01-2004 at 09:51 AM.
 
Old 04-01-2004, 11:16 AM   #5
EnigmaX
Member
 
Registered: Jul 2003
Distribution: Fedora Core 4
Posts: 107

Original Poster
Rep: Reputation: 15
I don't have either the lm file or the username map

This will mostly be a server so I need to be able to access it from many different places, so the first way sounds better to fix :/

I added a smbusers file, and username map = to it
Then I added:
shadow = shadow
iso = iso


To the file... iso being the guest username, and both of the linux username and samba username are the same

Also, why isn't the computer visable in the network? I can only access it by typing \\Linux-tech in the address bar

Thanks...
 
Old 04-01-2004, 11:21 AM   #6
jsokko
Member
 
Registered: Mar 2004
Location: Phila, PA
Distribution: SuSE 9.0 / RH 9 / Slackware 9.1
Posts: 110

Rep: Reputation: 15
I think you're misunderstanding the Home share ... it'll automatically take you to your home dir based on your ID.... it's not a public folder. try it.

As for your samba server not being visible to other machines... are you running a dns service on any machine? make sure your DNS is set for your proper workgroup / domain.
 
Old 04-01-2004, 12:02 PM   #7
EnigmaX
Member
 
Registered: Jul 2003
Distribution: Fedora Core 4
Posts: 107

Original Poster
Rep: Reputation: 15
The only DNS setting I have in the config file is "dns proxy = no"

It showed up when the setting was on "share", but it doesn't show up when it's on "user".

I also want these folders (shadow, and others) to be accessible by any login, not just the login on the current machine. :/

Maybe that's why it isn't working.. because it isn't on any of the servers logins.. But how would I make these folders passwored, but accessible from any machine under any login in the network ? :/

Thanks agian lol.. I had this working at one point under mandrake, still kinda new to slack networking
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba Config not working setting up user shares. cogs_bobv Linux - Software 9 10-11-2005 08:58 PM
Samba 3.0.6 - How to mount Samba Shares from Windows 2003? kp1 Linux - Software 2 09-10-2004 06:03 PM
NFS and Samba shares not working on MDK10, kernel 2.6.6 server DaneM Linux - Software 1 05-29-2004 08:42 PM
Linux can mount samba shares but not windows shares bindsocket Linux - Software 1 12-01-2003 05:28 PM
Mounting Samba shares and Samba Share Login time112852 Linux - Software 1 09-14-2003 02:23 PM


All times are GMT -5. The time now is 07:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration