LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-14-2012, 04:48 AM   #1
ntokozo
LQ Newbie
 
Registered: Jun 2012
Posts: 6

Rep: Reputation: Disabled
Samba Share


Hi

Can you please assist me on this matter. I have created a samba share for windows guys to be able to load they software. I have updated the smb.conf. I have created a user "user1" and the password. with the user i have created i can access the folder /home/software using the ip address on windows. the problem is when i add other users they can see the folder but they cant access the contacts of that folder.
 
Old 06-14-2012, 07:23 AM   #2
Satyaveer Arya
Senior Member
 
Registered: May 2010
Location: Palm Island
Distribution: RHEL, CentOS, Debian, Oracle Solaris 10
Posts: 1,415

Rep: Reputation: 305Reputation: 305Reputation: 305Reputation: 305
You didn't mention which OS are you using? And can you show us your configuration file, let us see what you have configured?
 
Old 06-14-2012, 07:31 AM   #3
ntokozo
LQ Newbie
 
Registered: Jun 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
samba share

Centos 5.8
# ----------------------- Network Related Options -------------------------
#
# workgroup = NT-Domain-Name or Workgroup-Name, eg: MIDEARTH
#
# server string is the equivalent of the NT Description field
#
# netbios name can be used to specify a server name not tied to the hostname
#
# Interfaces lets you configure Samba to use multiple interfaces
# If you have multiple network interfaces then you can list the ones
# you want to listen on (never omit localhost)
#
# Hosts Allow/Hosts Deny lets you restrict who can connect, and you can
# specifiy it as a per share option as well
#
workgroup = WORKGROUP
server string = Samba Server Version %v

; netbios name = MYSERVER

; interfaces = lo eth0 192.168.12.2/24 192.168.13.2/24
; hosts allow = 127. 192.168.12. 192.168.13.

# --------------------------- Logging Options -----------------------------
# ---------------------------Share Definitions ------------------------------
# A publicly accessible directory, but read only, except for people in
# the "staff" group
; [public]
; comment = Public Stuff
; path = /home/samba
; public = yes
; writable = yes
; printable = no
; write list = +staff

[software]
path = /home/software
writable = yes
create mode = 0770
directory mode = 0770
share modes = yes
guest ok = no
valid users = @software

i have also added the users on the /etc/group
goofy:x:500:
lenovo:x:501:
software:x:502:lenovo,Thami,Modise,nkagisang,robbie,reshen,nowellin,clinton,suvan,toka,tinyiko,roy
Thami:x:503:
Modise:x:504:
nkagisang:x:505:
robbie:x:506:
reshen:x:507:
nowellin:x:508:
clinton:x:509:
suvan:x:510:
toka:x:511:
tinyiko:x:512:
roy:x:513:

Last edited by ntokozo; 06-14-2012 at 07:39 AM.
 
Old 06-14-2012, 08:13 AM   #4
lithos
Senior Member
 
Registered: Jan 2010
Location: SI : 45.9531, 15.4894
Distribution: CentOS, OpenNA/Trustix, testing desktop openSuse 12.1 /Cinnamon/KDE4.8
Posts: 1,144

Rep: Reputation: 217Reputation: 217Reputation: 217
Quote:
Originally Posted by ntokozo View Post
Centos 5.8
...


; public = yes
; writable = yes
; printable = no
; write list = +staff

[software]
path = /home/software
writable = yes
create mode = 0770
directory mode = 0770
share modes = yes
guest ok = no
valid users = @software

i have also added the users on the /etc/group
...
You don't have the right permissions maybe ?
like :
directory mode = 0770 --> 775
 
Old 06-14-2012, 08:22 AM   #5
ntokozo
LQ Newbie
 
Registered: Jun 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
samba share

Lithos still having the same issue even thou i have changed the permissions directory mode = 0770 --> 775
 
Old 06-14-2012, 08:50 AM   #6
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 8,133

Rep: Reputation: 2273Reputation: 2273Reputation: 2273Reputation: 2273Reputation: 2273Reputation: 2273Reputation: 2273Reputation: 2273Reputation: 2273Reputation: 2273Reputation: 2273
can you please explain what does "they can see the folder, but cannot access the content" exactly mean?
Probably they can see only the name of the share but cannot log in. You can try to increase log level and see the log files.
 
Old 06-14-2012, 08:58 AM   #7
ntokozo
LQ Newbie
 
Registered: Jun 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
the path is like this /home/software/software--->> microsoft office 2000,xp,2003,2007,2010.
they can only go up to this folder /home/software when they try to access /software access denied.
 
Old 06-14-2012, 09:01 AM   #8
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 8,133

Rep: Reputation: 2273Reputation: 2273Reputation: 2273Reputation: 2273Reputation: 2273Reputation: 2273Reputation: 2273Reputation: 2273Reputation: 2273Reputation: 2273Reputation: 2273
so check the logs and permissions on those directories/files (I mean the real dirs and files, not the samba permissions)







_____________________________________
If someone helps you, or you approve of what's posted, click the "Add to Reputation" button, on the left of the post.
Happy with solution ... mark as SOLVED
(located in the "thread tools")
 
Old 06-14-2012, 09:36 AM   #9
ntokozo
LQ Newbie
 
Registered: Jun 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
Samba Share

this is how it looks
/home
drwx------ 2 clinton clinton 4096 Jun 14 08:56 clinton
drwx------ 15 goofy goofy 4096 Jun 13 11:58 goofy
drwx------ 2 lenovo lenovo 4096 Jun 13 12:41 lenovo
drwx------ 2 root root 16384 Jun 13 13:25 lost+found
drwx------ 2 Modise Modise 4096 Jun 14 08:55 Modise
drwx------ 2 nkagisang nkagisang 4096 Jun 14 08:55 nkagisang
drwx------ 2 nowellin nowellin 4096 Jun 14 08:55 nowellin
drwx------ 2 reshen reshen 4096 Jun 14 08:55 reshen
drwx------ 2 robbie robbie 4096 Jun 14 08:55 robbie
drwx------ 2 roy roy 4096 Jun 14 08:56 roy
drwxrwx--- 7 root software 4096 Jun 13 17:47 software
drwx------ 2 suvan suvan 4096 Jun 14 08:56 suvan
drwx------ 2 Thami Thami 4096 Jun 14 08:55 Thami
drwx------ 2 tinyiko tinyiko 4096 Jun 14 08:56 tinyiko
drwx------ 2 toka toka 4096 Jun 14 08:56 toka

/home/software
drwxrwx--- 38 lenovo lenovo 4096 Jun 13 19:36 Drivers
drwxrwx--- 2 lenovo lenovo 4096 Jun 13 13:41 Microsoft Dec 2010 Patches
drwxrwx--- 15 lenovo lenovo 4096 Jun 13 13:53 Service-Packs
drwxrwx--- 161 lenovo lenovo 4096 Jun 13 17:46 Software
drwxrwx--- 2 lenovo lenovo 4096 Jun 13 17:47 win 7
 
Old 06-14-2012, 09:41 AM   #10
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 8,133

Rep: Reputation: 2273Reputation: 2273Reputation: 2273Reputation: 2273Reputation: 2273Reputation: 2273Reputation: 2273Reputation: 2273Reputation: 2273Reputation: 2273Reputation: 2273
so the directory /home/software is only readable for the user lenovo and group lenovo. The samba users belong to the group software and it has no any right on this directory. So either you change the ownership of this dir (to lenovo:software) or add read/write/execute permissions to other.




_____________________________________
If someone helps you, or you approve of what's posted, click the "Add to Reputation" button, on the left of the post.
Happy with solution ... mark as SOLVED
(located in the "thread tools")
 
1 members found this post helpful.
Old 06-14-2012, 09:57 AM   #11
ntokozo
LQ Newbie
 
Registered: Jun 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
@pan64

thanks bro its working now. all i did was to grant rwx to the Software directory and the few desktop techis can access all those folders.

thanks bro.
 
Old 06-15-2012, 12:50 AM   #12
Satyaveer Arya
Senior Member
 
Registered: May 2010
Location: Palm Island
Distribution: RHEL, CentOS, Debian, Oracle Solaris 10
Posts: 1,415

Rep: Reputation: 305Reputation: 305Reputation: 305Reputation: 305
But play safe with giving permissions to others also. You are giving full access to others also. If you require you can limit the access of those directories by setting the permissions accordingly.
Good Luck!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Why is the SAMBA share option 'grayed out' in the share dialog? Atari911 Slackware 1 03-18-2011 08:00 PM
can't mount samba share and then write to the share calbazon Linux - Software 8 10-10-2010 02:35 AM
mount windows share export to samba share -> improve network performance tuning newuser77 Linux - Server 1 07-23-2008 12:28 PM
searching samba share breaks connection to share Elomis Linux - Server 1 05-11-2007 01:28 AM
Simple Samba Setup, Share & Not Share timmywo Linux - Software 4 07-30-2004 08:27 AM


All times are GMT -5. The time now is 08:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration