LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-26-2006, 01:25 PM   #1
Josh100
Member
 
Registered: Feb 2006
Distribution: Mandriva, Suse 10.2
Posts: 39

Rep: Reputation: 15
Samba Server And Permissions


Hey All,

I'm having a problem getting users working with samba, what i'm trying to do is make my suse 10.2 machine host all of my music, work, pictures, movies etc.

I've got:

username - group
user1 - share
user2 - share
user3 - share

the shared folders owner is root and the group is share

the permissions are rwxr-x-- but i can only log into the folder as root

any ideas how i can get it so you can log in with the user name and not as root?

Last edited by Josh100; 05-26-2006 at 01:29 PM.
 
Old 05-26-2006, 02:18 PM   #2
nabeelmoidu
Member
 
Registered: Jul 2005
Location: Bangalore
Distribution: Fedora
Posts: 71

Rep: Reputation: 15
Post your smb.conf

Post your smb.conf , what permissions have you given to the shares
 
Old 05-26-2006, 03:38 PM   #3
Josh100
Member
 
Registered: Feb 2006
Distribution: Mandriva, Suse 10.2
Posts: 39

Original Poster
Rep: Reputation: 15
the 2 folders i'm trying to share are music and shared
Code:
# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
# Date: 2006-05-02
[global]
	printcap name = cups
	cups options = raw
	map to guest = Bad User
	include = /etc/samba/dhcp.conf
	logon path = \\%L\profiles\.msprofile
	logon home = \\%L\%U\.9xprofile
	logon drive = P:
	add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
	domain logons = Yes
	domain master = Yes
	winbind gid = 10000-20000
	winbind uid = 10000-20000
	os level = 65
	preferred master = Yes
	idmap gid = 10000-20000
	idmap uid = 10000-20000
	local master = Yes
	security = user
	workgroup = SUSE
	idmap gid = 10000-20000
	idmap uid = 10000-20000

[homes]
	comment = Home Directories
	valid users = %S, %D%w%S
	browseable = No
	read only = No
	inherit acls = Yes

[shared]
	comment = Network Profiles Service
	path = /home/shares/shared
	read only = No
	store dos attributes = Yes
	create mask = 0600
	directory mask = 0700
	guest ok = yes

[users]
	comment = All users
	path = /home
	read only = No
	inherit acls = Yes
	veto files = /aquota.user/groups/shares/

[groups]
	comment = All groups
	path = /home/groups
	read only = No
	inherit acls = Yes

[printers]
	comment = All Printers
	path = /var/tmp
	printable = Yes
	create mask = 0600
	browseable = No

[print$]
	comment = Printer Drivers
	path = /var/lib/samba/drivers
	write list = @ntadmin root
	force group = ntadmin
	create mask = 0664
	directory mask = 0775

[music]
	comment = Music
	inherit acls = yes
	path = /home/shares/music/
	guest ok = No
	case sensitive = no
	msdfs proxy = no

[netlogon]
	comment = Network Logon Service
	path = /var/lib/samba/netlogon
	write list = root
 
Old 05-26-2006, 05:51 PM   #4
nabeelmoidu
Member
 
Registered: Jul 2005
Location: Bangalore
Distribution: Fedora
Posts: 71

Rep: Reputation: 15
try this

add writeable = yes to the shares
 
Old 05-28-2006, 06:56 AM   #5
Josh100
Member
 
Registered: Feb 2006
Distribution: Mandriva, Suse 10.2
Posts: 39

Original Poster
Rep: Reputation: 15
I tried adding that through Yast but it just wouldn't let me

I think i've solved the issue, i didn't know you had to add a new user to samba

Does the new Samba user link to the linux account with the same name, with the same groups and permissions etc?
 
Old 07-03-2006, 03:01 PM   #6
kbz
LQ Newbie
 
Registered: May 2006
Distribution: SuSE
Posts: 7

Rep: Reputation: 0
I seem to be having a permission issue, but I am unable to solve my problem. I have read darn near every link I can find about Samba and permissions...
Code:
[global]
   workgroup = My
   printing = cups
   printcap name = cups
   printcap cache time = 750
   cups options = raw
   map to guest = Bad User
   include = /etc/samba/dhcp.conf
   logon path = \\%L\profiles\.msprofile
   logon home = \\%L\%U\.9xprofile
   logon drive = P:
   security = user
   encrypt passwords = yes
   ldap suffix = dc=example,dc=com
   add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
   domain logons = no
   ldap idmap suffix = ou=Idmap
   ldap machine suffix = ou=Computers
   local master = yes
   passdb backend = smbpasswd
   wins server =
   wins support = yes
   domain master = false
   preferred master = yes
   os level = 65
[homes]
   comment = Home Directories
   valid users = %S
   browseable = yes
   read only = No
   inherit acls = Yes
   guest ok = no
   printable = no
[profiles]
   comment = Network Profiles Service
   path = %H
   read only = No
   store dos attributes = Yes
   create mask = 0600
   directory mask = 0700
   browseable = yes
   guest ok = no
   printable = no
[users]
   comment = All users
   path = /home
   read only = No
   inherit acls = Yes
   veto files = /aquota.user/groups/shares/
   browseable = yes
   guest ok = no
   printable = no
[groups]
   comment = All groups
   path = /home/groups
   read only = No
   inherit acls = Yes
   browseable = yes
   guest ok = no
   printable = no
[printers]
   comment = All Printers
   path = /var/tmp
   printable = yes
   create mask = 0600
   browseable = yes
   guest ok = yes
[print$]
   comment = Printer Drivers
   path = /var/lib/samba/drivers
   write list = @ntadmin root
   force group = ntadmin
   create mask = 0664
   directory mask = 0775
   browseable = yes
   guest ok = yes
   printable = no
[brett]
   comment = brett's bin
   path = /home/brett/bin/
   valid users = brett
   read only = no
   writeable = yes
   browseable = yes
   guest ok = no
   printable = no
[My Documents]
   comment = My Technical Documents
   path = /mydata/mydocs/
   writeable = yes
   browseable = yes
   read only = no
   guest ok = no
   printable = no
[My Clients]
   browsable = yes
   comment = Client Folder
   path = /mydata/myclients/
   writeable = yes
   inherit acls = yes
   guest ok = yes
   printable = no
   create mask = 0775
   directory mask = 0775
The "My" libraries don't seem to work. I have changed about everything I can find, only to get the same error, "not accessible. You may not have permission to use this network resource."

I have checked to make sure the path is correct... Wish it was that easy, or stupid.

 
Old 07-04-2006, 02:20 AM   #7
nabeelmoidu
Member
 
Registered: Jul 2005
Location: Bangalore
Distribution: Fedora
Posts: 71

Rep: Reputation: 15
I think its got something to do with the naming of your MY shares. Try avoiding the gap and giving some other name like MyDocs or something .
 
Old 07-05-2006, 10:38 AM   #8
kbz
LQ Newbie
 
Registered: May 2006
Distribution: SuSE
Posts: 7

Rep: Reputation: 0
Thanks for the response. I tried that, but it did not work.
Any other ideas? I am grasping at straws at this point...
 
Old 07-05-2006, 11:45 AM   #9
nabeelmoidu
Member
 
Registered: Jul 2005
Location: Bangalore
Distribution: Fedora
Posts: 71

Rep: Reputation: 15
Can you show the output of smbclient -L localhost
Verify that /mydata/mydocs and the other folder do exist.
Also post the samba logs related to this issue
 
Old 07-05-2006, 12:01 PM   #10
kbz
LQ Newbie
 
Registered: May 2006
Distribution: SuSE
Posts: 7

Rep: Reputation: 0
I moved the share out of the root to /home/ (which Samba shares by default) and added

[mydocs]
browseable = yes
comment = My Technical Documents
path = /home/mydocs
writeable = yes

Just to see if that made a difference.

It started working. Can I not add Libraries to the root and share them?

Sorry as for the logs you would like to see? I am VERY new to this, like 2 weeks new. Can you tell me where to look for them?
 
Old 07-05-2006, 05:15 PM   #11
kbz
LQ Newbie
 
Registered: May 2006
Distribution: SuSE
Posts: 7

Rep: Reputation: 0
Ok Samba officially sux! Had a power flicker and smb.conf was wiped clean. Luckily I had a backup, but now Samba tells me I don't have permissions to anything...

Last edited by kbz; 07-05-2006 at 05:28 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba domain member server (DMS) group permissions in network with a Samba PDC srosa Linux - Networking 0 05-01-2006 06:55 PM
SAMBA says 'Samba Server is not accebile, you might have no permissions' Ahmad Gurchani Linux - General 1 01-01-2005 11:34 AM
Samba and permissions ezra143 Linux - Software 8 11-05-2003 06:39 PM
Samba permissions djtsa Linux - Newbie 6 10-03-2003 08:22 AM
Samba Permissions ppuddick Linux - Networking 2 08-02-2002 04:03 PM


All times are GMT -5. The time now is 02:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration