LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-25-2003, 08:21 PM   #1
jdklein1975
LQ Newbie
 
Registered: Feb 2003
Posts: 19

Rep: Reputation: 0
SAMBA problem - connecting to linux from windows


I have a problem with SAMBA. I beleive it is all setup correctly since I can connect properly to the shares via the linux machine. When I go to my windows xp machine, I try to setup a Network Place but I get a messgae that the path is not found. The share name I am trying to connect to is 'johklein' and the IP address for the linux machine is 192.168.0.169. I attempt to connect as '\\192.168.0.169\johklein' I am running RH 8.0. Incedentally, I can not connect via the hostname b/c it is not seen on the network. The hostname for the linux machine is 'linux1' but when I ping via the hostname, the machine is not found. When I ping via the IP address, the ping is successful. Any ideas? I am very new to linux.
 
Old 02-25-2003, 08:26 PM   #2
scheidel21
Senior Member
 
Registered: Feb 2003
Location: CT
Distribution: Debian 6-7, WIN 7-10, WIN SRV 03-12r2
Posts: 1,309

Rep: Reputation: 98
lets see your samba config file it should see the hostname on the network, at least via the workgroup
 
Old 02-25-2003, 08:39 PM   #3
jdklein1975
LQ Newbie
 
Registered: Feb 2003
Posts: 19

Original Poster
Rep: Reputation: 0
Here it is:

[global]

# workgroup = NT-Domain-Name or Workgroup-Name
workgroup = MSHOME
netbios name = linux1

printcap name = /etc/printcap
load printers = yes
this tells Samba to use a separate log file for each machine
# that connects
log file = /var/log/samba/log.%m

# Put a capping on the size of the log files (in Kb).
max log size = 50
security = user

# DNS Proxy - tells Samba whether or not to try to resolve NetBIOS names
# via DNS nslookups. The built-in default for versions 1.9.17 is yes,
# this has been changed in version 1.9.18 to no.
dns proxy = no

encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd

[printers]
comment = All Printers
path = /var/spool/samba
browseable = no

[myshare]
comment = John Share
path = /home/johklein
valid users = johklein
public = no
writable = yes
printable = no
create mask = 0765
 
Old 02-25-2003, 08:44 PM   #4
jdklein1975
LQ Newbie
 
Registered: Feb 2003
Posts: 19

Original Poster
Rep: Reputation: 0
Correction to last post:

This section:

[myshare]
comment = John Share
path = /home/johklein
valid users = johklein
public = no
writable = yes
printable = no
create mask = 0765

should be:

[johklein]
comment = John Share
path = /home/johklein
valid users = johklein
public = no
writable = yes
printable = no
create mask = 0765

The name of the share is johklein, not myshare
 
Old 02-26-2003, 02:01 AM   #5
scheidel21
Senior Member
 
Registered: Feb 2003
Location: CT
Distribution: Debian 6-7, WIN 7-10, WIN SRV 03-12r2
Posts: 1,309

Rep: Reputation: 98
Try just using the default homes share...when you logon woth your username it automatically shows your share folder the one that corresponds to your username
 
Old 02-26-2003, 04:35 PM   #6
scottpioso
Member
 
Registered: Jan 2003
Location: United States of America and damn proud of it!
Distribution: Windows 7 prior Red Hat User
Posts: 473

Rep: Reputation: 30
SAMBA problem too!!

Hello,

My problem is similiar, however, this is what is happening with me. When I try to connect to the Linux box from Windows, I get prompted for a user name and password. However, if I just click OK, I go right on through. However, I don't really have access to anything.

Can someone tell me what I need to do to enable myself to log in from Windows to Linux? I have myself set up as a user on the Linux box but can't log in. Any ideas? Thanks.
 
Old 02-26-2003, 05:41 PM   #7
jdklein1975
LQ Newbie
 
Registered: Feb 2003
Posts: 19

Original Poster
Rep: Reputation: 0
I have tried to do that and I get the following error:


No service is operating at the destination endpoint on the remote system.

I have tried to connect via windows mapping and the cmd prompt. I have entered the following at the cmd prompt:

net use x: \\linux1\homes

BTW, I have figured out my HOSTNAME problem.
 
Old 02-26-2003, 06:23 PM   #8
scottpioso
Member
 
Registered: Jan 2003
Location: United States of America and damn proud of it!
Distribution: Windows 7 prior Red Hat User
Posts: 473

Rep: Reputation: 30
What do I put at the x?

net use x: \\linux1\homes
 
Old 02-26-2003, 06:45 PM   #9
jdklein1975
LQ Newbie
 
Registered: Feb 2003
Posts: 19

Original Poster
Rep: Reputation: 0
x is the drive. You are mapping the x drive to the share name on your linux box.
 
Old 03-10-2003, 11:47 PM   #10
gwroy20
Member
 
Registered: Mar 2003
Location: New York City
Distribution: Slackware 9.1, FreeBSD 5.2.1, OpenBSD 3.3
Posts: 89

Rep: Reputation: 15
How did you wind up solving the hostname problem? I'm having the same issue.

I can connect to my Linux machine using it's IP address, but not it's hostname.
 
Old 03-11-2003, 08:10 AM   #11
scottpioso
Member
 
Registered: Jan 2003
Location: United States of America and damn proud of it!
Distribution: Windows 7 prior Red Hat User
Posts: 473

Rep: Reputation: 30
Hmm,

Sounds weird. So, you're saying you can connect from Windows via IP address but not by name? Check in your My Network Places and see if your linux box appears there. If not, I would check to make certain you're in the same workgroup or domain. I'm not certain if you have a domain controller or if this is just a small workgroup. Also, make sure that you can ping the Linux box from windows.

If your Windows box is not in the same workgroup, right click on My Computer, go to Properties, go to Network Identification (I think), select workgroup, and then enter the same workgroup name as your linux box. Make sure you match case exactly!! You'll then have to restart your windows box. At that point, if you're using a router, you'll have to wait 30 seconds for a RIP update to see the Linux box in the workgroup, but after that, it should be there.

Also, double check your smb.conf file to make sure you have your windows users entered there and that their passwords are in the smbpasswd file as well. If their names are not in the smbpasswd file, you'll have to CAT them out. If you need that little script to do that, let me know, and I'll send it to you. I actually found it (believe it or not) in the Red Hat 8.0 for dummies book!!

Hope this helps.

Scott
 
Old 03-11-2003, 09:37 AM   #12
jdklein1975
LQ Newbie
 
Registered: Feb 2003
Posts: 19

Original Poster
Rep: Reputation: 0
You need to edit the "Hosts" files on each of your machines. When windows machines talk to each other, they do it via Netbios protocol but that is not available when talking widnows to linux or vice versa. The Hosts file on the linux machine is at /etc/hosts. The hosts files file on the windows machine is <windows dir>\system32\drivers\etc

Simply put a line item in for each of the machines on your network like this:

192.168.0.194 windows1
192.168.0.107 linux1

Add a line item for each of your machines with the IP address followed by the machine name. No need to worry if you use dynamic IP addresses. The machine's lease on the IP address will stay constant as long as you use the machine regulary enough (at least once a week).
 
Old 05-05-2003, 10:00 AM   #13
M'Lessa
LQ Newbie
 
Registered: May 2003
Posts: 1

Rep: Reputation: 0
No service error

"No service is operating at the destination endpoint on the remote system."

This error occurs if you have Linux's firewall enabled. You have to disable it to use Samba.
 
Old 05-23-2003, 01:02 AM   #14
gwroy20
Member
 
Registered: Mar 2003
Location: New York City
Distribution: Slackware 9.1, FreeBSD 5.2.1, OpenBSD 3.3
Posts: 89

Rep: Reputation: 15
I resolved my problem a few weeks ago, no need to edit the Windows hosts file. You have to make sure that nmbd is running on the linux machine for it to be reachable from a windows machine, it didn't run by default on mine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem connecting SAMBA to Windows 2003 Server Micro420 Linux - Networking 5 11-08-2005 04:53 PM
Connecting to Linux box from Windows with Samba Tylerious Linux - Software 7 10-04-2005 09:28 AM
trouble connecting from windows xp to linux with samba magicked Linux - Networking 4 07-10-2004 10:06 PM
Connecting to Samba Server from Windows explorer Linux - Networking 7 03-16-2003 06:26 PM
connecting to windows workgroup using samba? linoob Linux - Newbie 7 10-23-2002 09:17 PM


All times are GMT -5. The time now is 10:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration