LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-15-2005, 03:01 PM   #1
mvo
Member
 
Registered: Apr 2005
Location: Delhi, India
Distribution: Mostly Fedora
Posts: 42

Rep: Reputation: 15
samba: mount-folder in client gives only root permissions after mounting


Hello!

I use samba as a fileserver, but with my Linux clients I have a permission problem:
The files in the server have 777 and also in the client they show 777-permissions and I want 777 (or at least 774/775), but I cannot change them because the mount-folder changes in 755 as soon as I mount while before mounting the mount folder had 777....

I mount with the cmd (as root):
mount -t smbfs //192.168.3.2/share /home/marcel/share -o username=marcel

my smb.conf is:
[global]
workgroup = test
netbios name = SAMBASERVIDOR
server string = My Lil Linux Box
hosts allow = 192.168. 127.
log file = /var/log/samba/%m.log
log level = 2
security = user
encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
lock directory = /usr/local/samba/var/locks
os level = 64

[homes]
comment = home
browseable = no
writeable = yes
create mask = 0777
directory mask = 0777

[share]
path = /home/share
browseable = yes
writeable = yes
create mask = 0777
directory mask = 0777
locking = yes
public=yes


Can anyone help me out on this one??

Thanks!!

Last edited by mvo; 09-15-2005 at 03:31 PM.
 
Old 09-16-2005, 10:05 AM   #2
fedoen
LQ Newbie
 
Registered: Sep 2005
Posts: 5

Rep: Reputation: 0
Re: samba: mount-folder in client gives only root permissions after mounting

If your folder share belongs to root try changing the owner of the folder to marcel
 
Old 09-16-2005, 10:15 AM   #3
mvo
Member
 
Registered: Apr 2005
Location: Delhi, India
Distribution: Mostly Fedora
Posts: 42

Original Poster
Rep: Reputation: 15
yes, I already tried that one, but whatever owner i give the folder in the server, as soon as i mount (mount -t smbfs //192.168.3.2/share /home/marcel/share -o username=marcel in the terminal ) on a client the owner and group is set to root...
anyone?
 
Old 09-16-2005, 11:39 AM   #4
spade78
LQ Newbie
 
Registered: Feb 2004
Location: San Diego
Distribution: Mac OS X
Posts: 5

Rep: Reputation: 0
Try to specify the uid and gid options which will set ownership when you mount the shares. So instead of this:
mount -t smbfs //192.168.3.2/share /home/marcel/share -o username=marcel

Try this:
mount -t smbfs //192.168.3.2/share /home/marcel/share -o username=marcel,uid=linuxUserName,gid=linuxGroupName
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba Public Folder Permissions decoone Linux - Networking 4 09-26-2007 12:42 AM
Samba Public shared Folder will not hold permissions xzerros Linux - Networking 12 09-26-2005 09:25 AM
permissions difference between /home/..../folder and /root/folder darkleaf Linux - General 3 07-21-2005 05:23 PM
Folder permissions problem with Samba albracco Linux - Networking 4 08-24-2004 10:09 PM
samba folder permissions problem albracco Linux - Software 4 07-02-2004 07:01 PM


All times are GMT -5. The time now is 09:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration