LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-20-2004, 08:05 AM   #1
jfranks214
Member
 
Registered: Feb 2004
Distribution: OpenBSD, FreeBSD
Posts: 70

Rep: Reputation: 15
samba issue


Hi,

Okay so I had a SAMBA user / password set up and it was working fine. I had a drive mapped on my windoze machine to a share that I set up on the SUSE box. The SUSE box was rebooted (we were expecting a power outage that never occured) and suddenly I can't connect.

I tried to reset my samba password, but I get the following message:

iccweb1:~ # smbpasswd -a jfranks
unrecognized character set
unrecognized character set
New SMB password:
Retype new SMB password:
Bind failed: Can't contact LDAP server
Bind failed: Can't contact LDAP server
Failed to add entry for user jfranks.
Failed to modify password entry for user jfranks
iccweb1:~ #


I'm connecting to the box via SSH using PuTTy, and logging in as root. I'm not sure what the unrecognized character set message is about either, but it was doing that when it was working too...... any thoughts?

Jonathan
 
Old 04-20-2004, 05:23 PM   #2
hob
Senior Member
 
Registered: Mar 2004
Location: Wales, UK
Distribution: Debian, Ubuntu
Posts: 1,075

Rep: Reputation: 45
I'd guess that you're storing your usernames/passwords in a LDAP database and that the LDAP service didn't start up when you rebooted the box - the 'bind failed' message means that the smbpasswd program wasn't able to log on to the LDAP service to perform the necessary update.

I'm not sure about the character set message - try looking for references to UTF-8 or Unicode in the Samba and system docs, it may be that they're not enabled somewhere in Samba or SUSE itself.
 
Old 04-20-2004, 06:48 PM   #3
jfranks214
Member
 
Registered: Feb 2004
Distribution: OpenBSD, FreeBSD
Posts: 70

Original Poster
Rep: Reputation: 15
Thanks, I kind of suspected this. I'll see if I can figure out how to restart the service tomorrow. I imagine it's something like /etc/init.d/ldap start .

Thanks for the tip on the character set message too....


Jonathan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba issue? rmarkin Linux - Software 3 09-14-2005 07:44 PM
Samba 3 Issue bLaDe Linux - Networking 6 06-07-2004 01:54 PM
Another Samba issue cmoloney Linux - Networking 1 06-07-2003 07:17 PM
Samba Issue skootr Linux - Software 9 05-14-2003 11:18 AM
Another samba issue xYko Linux - Networking 3 02-27-2003 10:11 AM


All times are GMT -5. The time now is 10:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration