LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-23-2003, 02:23 AM   #1
guitar_genius
LQ Newbie
 
Registered: May 2003
Posts: 3

Rep: Reputation: 0
Angry Samba gui won't start


Hello all,

I recently installed samba on my box running redhat 9.0, and it works just fine. However, just recently I cannot get the gui to come up. When I go to System Settings -> Server Settings -> Samba Server, the gui does not appear after I put in my password. So then I ran the command:

redhat-config-samba

and it gave me a bunch of errors and the gui does not pop up as a result of all the errors. Has anyone else ran into this? Any help would be appreciated.

Thanks,
-Chris
 
Old 05-23-2003, 02:29 AM   #2
yowwww
Member
 
Registered: Apr 2003
Location: Ontario, Canada
Distribution: Arch Linux
Posts: 533

Rep: Reputation: 30
i thought samba was run cli only
 
Old 05-23-2003, 03:12 AM   #3
masand
LQ Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
try samba bowser from samba.org
xsmbrowser is a good one
 
Old 05-23-2003, 11:49 AM   #4
guitar_genius
LQ Newbie
 
Registered: May 2003
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by masand
try samba bowser from samba.org
xsmbrowser is a good one
Thanks for the replys, but all I really want to do is just fix what I have already. Here are the errrors when I type redhat-config-samba:

Traceback (most recent call last):
File "/usr/share/redhat-config-samba/redhat-config-samba.py", line 20, in ?
mainWindow.MainWindow(debug_flag)
File "/usr/share/redhat-config-samba/mainWindow.py", line 58, in __init__
self.samba_data = sambaParser.SambaParser(self)
File "/usr/share/redhat-config-samba/sambaParser.py", line 24, in __init__
self.parseFile()
File "/usr/share/redhat-config-samba/sambaParser.py", line 55, in parseFile
token = self.createToken(line)
File "/usr/share/redhat-config-samba/sambaParser.py", line 127, in createToken token = sambaToken.SambaToken(sambaToken.SambaToken.SAMBA_TOKEN_KEYVAL, (name, value), self.parent)
File "/usr/share/redhat-config-samba/sambaToken.py", line 20, in __init__
raise AttributeError, value
AttributeError: ('this tells Samba to use a separate log file for each machine', '')

I noticed that this was bug number 84272 at bugzilla.com which means there is a solution but I do not have authorization to view it, so if anyone knows the solution...please help.

-Chris
 
Old 05-23-2003, 02:22 PM   #5
guitar_genius
LQ Newbie
 
Registered: May 2003
Posts: 3

Original Poster
Rep: Reputation: 0
Ok, thanks to Brent Fox, the problem is solved.
Just missed a # before a comment in smb.conf which cause the application to crash. Works now!

-Chris
 
Old 04-01-2013, 12:44 AM   #6
YohonOrov
LQ Newbie
 
Registered: Apr 2013
Posts: 1

Rep: Reputation: Disabled
Smile Samba Gui won't start

I would like to thank guitar_genius, as the omission of the # before the line I added in the smb.conf file was my problem also. It now works. I am new to both Linux, and all this terminal stuff. But I suppose the only way you learn it is to just dig in!

John
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
when i try to start samba pdc's smb service nmbd failed to start . sandeepchau123 Linux - Newbie 2 10-20-2007 01:59 PM
gui doesn't start up right away. jerrit Slackware - Installation 2 08-27-2004 12:54 PM
GUI doesn't start Faceless42001 Slackware 3 08-16-2004 12:43 PM
GUI won't start up Wilsonco18 Linux - Newbie 6 11-03-2002 10:46 AM
when i restart SAMBA,it says:stop samba failed,start SAMBA OK! whepin Linux - Networking 3 12-26-2001 05:54 AM


All times are GMT -5. The time now is 10:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration