LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-21-2004, 07:23 PM   #1
rjcmi
LQ Newbie
 
Registered: Feb 2004
Location: Michigan
Distribution: Ubuntu
Posts: 21

Rep: Reputation: 15
Samba Dameon smbd is not running and won't start


I'm trying to get samba up and running to connect to a windows machine. However when i do a ./samba restart command, the only service that stops and restarts is nmbd.

Does anyone have any ideas where I should start the troubleshooting process. My smb.conf file apears to be correct. I've tried a ps -aux and the smbd process is not running, just the nmdb.

Samba 3.0
Debian Woody system.

Thanks in advance for any help.
 
Old 04-21-2004, 09:02 PM   #2
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,810

Rep: Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721
Use the console command testparm to check the syntax of the smb.conf file.

Check the samba logs for any errors. Usual location for logs is /var/log/samba but not sure about debian.
 
Old 04-22-2004, 09:44 AM   #3
rjcmi
LQ Newbie
 
Registered: Feb 2004
Location: Michigan
Distribution: Ubuntu
Posts: 21

Original Poster
Rep: Reputation: 15
Thanks for the help michaelk. I beleive the problem is that when i installed samba I told it to run as a mount, not a dameon.

Does anyone know how i could change that ?

I did try apt-get remove samba and then reinstalled, but still have the same problem.

Thanks in advance.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SMBD not running? alirezan1 Linux - Networking 0 12-21-2004 05:05 AM
Difference between init.d, xinetd and running service as a dameon jstephens84 Linux - Newbie 1 09-13-2004 06:19 PM
Why so many smbd processes running mdkelly Linux - Networking 2 11-05-2003 05:47 PM
SWAT status, SMBD not running Dogface1SG Linux - Networking 5 10-16-2003 01:45 PM
smbd - not keen on running rwhitworth Linux - Networking 3 04-26-2003 05:18 PM


All times are GMT -5. The time now is 01:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration