LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-10-2002, 09:47 AM   #1
mgeorge
LQ Newbie
 
Registered: Apr 2002
Posts: 4

Rep: Reputation: 0
Samba conf


I am trying to connect to a windows share from my linux box. I was able to mount the windows share as root, but I could not change the permissions to allow another user to write to the share. how to change permissions to allow other users to write to the windows share?
 
Old 04-10-2002, 10:09 AM   #2
rlkiddjr
Member
 
Registered: Feb 2002
Distribution: FreeBSD 4.9
Posts: 69

Rep: Reputation: 15
Your question is a bit confusing. Are you trying to connect to a windoze machine from linux, or are you trying to connect to linux from a windoze machine.

Lee
 
Old 04-10-2002, 10:15 AM   #3
mgeorge
LQ Newbie
 
Registered: Apr 2002
Posts: 4

Original Poster
Rep: Reputation: 0
I am on my linux box -- I hava share drive set up on the windows box. I am able to access the windows box from my linux box by using the command mount -t smbfs -o username=xxx //windows/share /linux/directory

This command seems to only work as root. I cannot write to the windows share from linux as anyone except root and I cannot change permissions with chmod. Is there a way to change the permissions??
 
Old 04-10-2002, 10:19 AM   #4
hanzerik
Member
 
Registered: Jan 2002
Location: Cheyenne Wyoming
Distribution: Debian/Raspbian/Mint
Posts: 717

Rep: Reputation: 32
Try changing the permissions on the mount space /linux/directoy so that your users can write to it, before you mount the windows share.
 
Old 04-10-2002, 10:29 AM   #5
mgeorge
LQ Newbie
 
Registered: Apr 2002
Posts: 4

Original Poster
Rep: Reputation: 0
I tried that but I still cannot write to any directories that exist under the share mount point.
 
Old 04-10-2002, 11:09 AM   #6
mgeorge
LQ Newbie
 
Registered: Apr 2002
Posts: 4

Original Poster
Rep: Reputation: 0
Thank you for the help -- I put the option uid=<unix user> in the mount command and that worked.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Reinstalling Samba doesn't recover the original /etc/samba/smb.conf Akhran Debian 2 11-11-2005 01:54 AM
samba conf smb.conf regnier Mandriva 5 02-17-2005 05:27 AM
Samba: /etc/samba/dhcp.conf on SuSE 9.1 sskt74 Linux - Networking 0 01-05-2005 06:03 AM
samba smb.conf lukalinuix Linux - Networking 5 06-21-2004 07:32 AM
having trouble with samba.conf aaronluke Linux - General 0 09-30-2002 08:35 PM


All times are GMT -5. The time now is 05:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration