LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-25-2002, 10:35 AM   #1
lee foster
LQ Newbie
 
Registered: Oct 2002
Posts: 4

Rep: Reputation: 0
Samba


Hi

when i activate samba i get the Server showing in Windows 2k/xp but i cannot browse the server, when i try to map a drive i get Network name not found, although i can ping it by name, so i have name resoloution.

I have stopped and started the SMB and NMB Services to no avail.Also if i try to use SWAT to configure SAMBA http://localhost:901 I get " the connection was refused when trying to connect to ......"

I have edited the XINETD.conf file as some of you suggested in various forums, could anyone give me a copy of a working xinetd.conf and smb.conf that i can test ?

what have i missed here.

I have shares specified also that when i run testparm all comes back o.k.
 
Old 10-25-2002, 03:48 PM   #2
J_Szucs
Senior Member
 
Registered: Nov 2001
Location: Budapest, Hungary
Distribution: SuSE 6.4-11.3, Dsl linux, FreeBSD 4.3-6.2, Mandrake 8.2, Redhat, UHU, Debian Etch
Posts: 1,126

Rep: Reputation: 58
If you see the samba server from windows then do not change much in smb.conf, just one thing: uncomment the encrypted password line (window$, and, especially the XP one prefers sending encrypted passwords), and sighup samba.

Then create the user's samba password like this:
smbpasswd -a username
(The unix user password should be the same)

Always map your network drives with that username and password on window$.

(Theoretically, you could also hack XP to use plain text passwords like samba does by default, but I would not recommend that: XP tends to forget those passwords and you will be always asked for them anytime you connect to a share the first time after restarting your machine. At least this was the case for me.)
 
Old 10-25-2002, 03:50 PM   #3
J_Szucs
Senior Member
 
Registered: Nov 2001
Location: Budapest, Hungary
Distribution: SuSE 6.4-11.3, Dsl linux, FreeBSD 4.3-6.2, Mandrake 8.2, Redhat, UHU, Debian Etch
Posts: 1,126

Rep: Reputation: 58
If you see the samba server from windows then do not change much in smb.conf, just one thing: uncomment the encrypted password line (window$, and, especially the XP one prefers sending encrypted passwords), and sighup samba.

Then create the user's samba password like this:
smbpasswd -a username
(The unix user password should be the same)

Always map your network drives with that username and password on window$.

(Theoretically, you could also hack XP to use plain text passwords like samba does by default, but I would not recommend that: XP tends to forget those passwords and you will be always requested for them anytime you connect to a share the first time after restarting your machine. At least this was the case for me.)
 
Old 10-29-2002, 06:52 AM   #4
kusumoto
LQ Newbie
 
Registered: Mar 2002
Location: Japan
Distribution: RH7.2
Posts: 5

Rep: Reputation: 0
If you change in smb.conf , edit there .

# vi /etc/xinetd.d/swat
service swat
{
disable = no
port = 901
socket_type = stream
wait = no
only_from = 127.0.0.1 192.168.0.0/24
user = root
server = /usr/sbin/swat
log_on_failure += USERID
}

#service xinetd restart

http://eth0(eth1):901
 
Old 10-29-2002, 11:27 PM   #5
J_Szucs
Senior Member
 
Registered: Nov 2001
Location: Budapest, Hungary
Distribution: SuSE 6.4-11.3, Dsl linux, FreeBSD 4.3-6.2, Mandrake 8.2, Redhat, UHU, Debian Etch
Posts: 1,126

Rep: Reputation: 58
I just had one more practical experience with xp home and samba.

A user's username and password were correctly set up both in xp home and samba (unix and samba password were the same); that user saw the samba server, but could not connect to its shares on any ways.

The solution was to enable wins in xp and samba, and also netbios over tcp in xp.

I do not know why this trouble occurred on this machine, since there was nothing like that with other xp home machines on the same network (the only difference between this machine and others was that here the xp administrator's username was renamed to the actual username, while on other xp homes a new, limited user account was set up for the actual user)

Last edited by J_Szucs; 10-29-2002 at 11:30 PM.
 
Old 10-29-2002, 11:45 PM   #6
kusumoto
LQ Newbie
 
Registered: Mar 2002
Location: Japan
Distribution: RH7.2
Posts: 5

Rep: Reputation: 0
When you install linux , do you select firewall "high" ?

If you select "high" , I think your xp machine can't connect to samba-server.

I'm not good at an English, Sorry.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba/Cups print sharing problems (/var/spool/samba files) Gates1026 Linux - General 9 06-23-2013 02:33 AM
Samba - Connecting from WinXP Pro to Samba running on Debian critical Linux - Networking 1 02-03-2005 10:36 AM
I need the content from thegoldenear.org/toolbox/unices/samba/samba-setup.html rtg2001 Linux - Networking 1 08-05-2004 06:54 PM
Samba: Authenticate Linux-Clients in Samba Domain & Mount mule Linux - Software 0 12-10-2003 02:21 AM
when i restart SAMBA,it says:stop samba failed,start SAMBA OK! whepin Linux - Networking 3 12-26-2001 06:54 AM


All times are GMT -5. The time now is 08:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration