LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-24-2002, 01:49 PM   #1
joshuajameswoma
LQ Newbie
 
Registered: Sep 2002
Location: memphis Tn
Distribution: Redhat 7.3
Posts: 11

Rep: Reputation: 0
Samba


Hello. I am setting up Samba. I can ping my server and clients via IP. I can ping all machines via machine name. When I use nmblookup however, I get this message when I try to get info about my samba server:
#nmblookup pogo "pogo"
querying pogo on 192.168.2.255
name_query failed to find the name pogo

What is wrong and how can I fix it????
 
Old 09-24-2002, 01:53 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
Do you have smbd and nmbd running? Try to use smbclient from the machine you're installaing Samba on to connect.
 
Old 09-24-2002, 01:59 PM   #3
joshuajameswoma
LQ Newbie
 
Registered: Sep 2002
Location: memphis Tn
Distribution: Redhat 7.3
Posts: 11

Original Poster
Rep: Reputation: 0
I can connect with smbclient. Both services are running.
 
Old 09-24-2002, 02:16 PM   #4
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
How does your smb.conf file look like?
 
Old 09-24-2002, 03:45 PM   #5
joshuajameswoma
LQ Newbie
 
Registered: Sep 2002
Location: memphis Tn
Distribution: Redhat 7.3
Posts: 11

Original Poster
Rep: Reputation: 0
[global]
 
Old 09-24-2002, 04:00 PM   #6
joshuajameswoma
LQ Newbie
 
Registered: Sep 2002
Location: memphis Tn
Distribution: Redhat 7.3
Posts: 11

Original Poster
Rep: Reputation: 0
[global]
netbios name = pogo
workgroup = workgroup
server string = sambaserver
hosts allow = 192.168.2.165 192.168.2. 12
guest account = pcguest
log file = /var/log/samba/%m.log
max log size = 10
security = user
encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd
unix password sync = yes
passwd program = /usr/bin/passwd %u
passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
pam password change = yes
obey pam restrictions = yes
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
remote browse sync = 192.168.2.255a
remote announce = 192.168.2.255 192.168.2.44
local master = yes
os level = 99
preferred master = yes
wins support = yes
dns proxy = yes
[home]
comment = Home Directories
browseable = yes
writable = yes
valid users = %S
create mode = 0664
directory mode = 0775

I cant get my computer "winclient" to connect to "pogo". All the computers are seen in the workgroup in Win XP. When I click properties of "pogo" while in XP, I get this error message..."The server pogo does not accept remote requests". If I double click on "pogo" I get this response..."\\Pogo is not accessible. you might not have permission to use this network resource. Contact the administrator of the server to find out if you have access permissions. No service is opperating at the destination endpoint on the remote system."

Last edited by joshuajameswoma; 09-24-2002 at 04:08 PM.
 
Old 09-25-2002, 12:48 PM   #7
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
You allow connections only from 2 hosts: 192.168.2.165 and 192.168.2. 12. Is it what you want?
 
Old 09-25-2002, 02:04 PM   #8
joshuajameswoma
LQ Newbie
 
Registered: Sep 2002
Location: memphis Tn
Distribution: Redhat 7.3
Posts: 11

Original Poster
Rep: Reputation: 0
My samba server is on 192.168.2.75 (pogo)
the computer that wishs to connect is 192.168.2.165 (winclient)
[global]
smb passwd file = /etc/samba/smbpasswd
path = /home/joshua
passwd program = /usr/bin/passwd %u
remote announce = 192.168.2.255/workgroup 192.168.2.44
pam password change = yes
auto services = global homes share
dns proxy = yes
encrypt passwords = yes
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
bind interfaces only = yes
wins support = true
force user = joshua
max log size = 100
interfaces = 192.168.2.0/255.255.255.0 127.0.0.1
obey pam restrictions = yes
passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
security = user
unix password sync = Yes
workgroup = workgroup
server string = Sambaserver
local master = yes
netbios name = pogo
log file = /var/log/samba/%m.log
guest account = pcguest
remote browse sync = 192.168.2.165
os level = 99
default = global
[homes]
comment = Home Directories
valid users = %S
create mode = 0664
writeable = yes
directory mode = 0775

Thiis is my current version of smb.conf constructed with WEBMIN.
Please point out any ridiculous errors. This is for my personal network at home.

I have been reading everything I could about samba. Most of which has been cryptic to me.

Last edited by joshuajameswoma; 09-25-2002 at 02:07 PM.
 
Old 09-25-2002, 03:38 PM   #9
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
Is th XP behavour the same as it was with he previous smb.conf?
 
Old 09-25-2002, 04:09 PM   #10
joshuajameswoma
LQ Newbie
 
Registered: Sep 2002
Location: memphis Tn
Distribution: Redhat 7.3
Posts: 11

Original Poster
Rep: Reputation: 0
Yes the behaviour seems the same. Though I have noticed that if I reboot all the machines, pogo wont show up to network neighborhood untill I connect with smbclient as a user in console. I have also logged onto a 2000pro machine. Something else odd...I cannot ping the 2000pro machine from pogo. Im looking into that now... Again I thankyou for your time. I am trying to learn as I have chosen Unix as my focus in college, seemingly at this point unsuccessfully

I have found out why I cannot ping other machine(200pro) and have corrected it.

More info- I also have noticed that all the windows machines are slow to react when I click on workgroups. I have never noticed this before until I setup the linux box.

Last edited by joshuajameswoma; 09-25-2002 at 04:15 PM.
 
Old 09-25-2002, 05:14 PM   #11
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
Hmm, do you have a firewall set? Try ipchains -L and iptables -L. What's the result?
 
Old 09-25-2002, 05:34 PM   #12
joshuajameswoma
LQ Newbie
 
Registered: Sep 2002
Location: memphis Tn
Distribution: Redhat 7.3
Posts: 11

Original Poster
Rep: Reputation: 0
No firewall running.

does this mean anything I found this in log.nmbd

libsmb/namequery.c:getlmhostsent(508)
getlmhostsent: Ill formed hosts line [192.168.2.4]

new-Fixed the lmhost file.

Any Idea why windows return the message..."The server pogo doesnt accept remote requests"

Last edited by joshuajameswoma; 09-25-2002 at 06:21 PM.
 
Old 11-22-2003, 02:24 AM   #13
holder
LQ Newbie
 
Registered: Nov 2003
Location: Canada
Posts: 5

Rep: Reputation: 0
disable firewall

Go to Control Panel, run Lokkit disable the firewall. Do not connect directly your Linux box to the outside. Now for your local network you are wide open. Is not enough to stop the services (ipchains and iptables). As you know you set up from beginning your level of security, that means just few ports are open.
Now your Samba Server accept connections and Windows require a network password. Here you have to work out with Control Panel > Authentication Configuration. Enabling Kerberos Support seems not to work (you can download the new applic such as telnet, Ftp etc that use Kerberos v5).

Use MD5 to hash the passwords.

Make some users and groups. Add the users to the groups. Make the same users and groups in Windows.
If you use SMB authentication you need to edit "smbusers" file where you have Unix names = Samba names.
Create "smbpasswd" file.
This can be done with the following steps:

-- Create a separate password file for Samba based on your /etc/passwd file. This will create Samba users for every user that already exists on your system. To do this by executing the command

#cat /etc/passwd | mksmbpasswd.sh > /etc/samba/smbpasswd

The script should be in the /usr/bin directory.
-- Make sure only root has permission to read and write to the Samba password file with the command

#chmod 600 smbpasswd

-- The script does not copy the passwords. To set the Samba password for each users thus enabling their Samba accounts, use the command

#smbpasswd 'username'

for each user.
-- Edit the smb.conf file to include the two lines

encrypt passwords = yes
smb passwd file = /etc/samaba/smbpasswd

--
Restart Samba with

/etc/rc.d/init.d/smb restart

Install Putty to telnet into your Linux for further tests on users and passwords and to make changes to your smb.conf and shares.
Telnet as normal user and then use #su root to have full rights.


And then
..."The server pogo does accept remote requests"

http://www.chiark.greenend.org.uk/~sgtatham/putty/

Last edited by holder; 09-21-2004 at 02:17 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba/Cups print sharing problems (/var/spool/samba files) Gates1026 Linux - General 9 06-23-2013 02:33 AM
Samba - Connecting from WinXP Pro to Samba running on Debian critical Linux - Networking 1 02-03-2005 10:36 AM
I need the content from thegoldenear.org/toolbox/unices/samba/samba-setup.html rtg2001 Linux - Networking 1 08-05-2004 06:54 PM
Samba: Authenticate Linux-Clients in Samba Domain & Mount mule Linux - Software 0 12-10-2003 02:21 AM
when i restart SAMBA,it says:stop samba failed,start SAMBA OK! whepin Linux - Networking 3 12-26-2001 06:54 AM


All times are GMT -5. The time now is 06:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration