LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-10-2004, 07:58 AM   #1
Oxyd
Member
 
Registered: Oct 2003
Distribution: Fedora Core 3
Posts: 34

Rep: Reputation: 15
Rxvt displaying bad characters


When I run mc in rxvt it looks like this:

http://www.oxyd.wz.cz/public/screenshot.png

Anyone knows why the characters are wrong?

I'm using rxvt 2.6.4

Oxyd
 
Old 12-10-2004, 09:05 AM   #2
mac57
Member
 
Registered: Nov 2004
Location: Texas
Distribution: openSUSE 10.3, Yoper Linux 3.0 , Arch Linux 2007.08
Posts: 253

Rep: Reputation: 30
Apparently mc (and ncurses in general) uses unicode for drawing its lines and boxes, and you need to enable this to make your display from these programs look right. Happily, this is really simple. In your .bashrc (or any other place that is convenient in your start up process) simply put the following:

export TERM=xterm

This cleans up the problem right away, and mc and all other ncurses based programs now look like you would expect.

If you are using KDE, an althernate is to simply select "New Midnight Commander" from Konsole's Session menu. It does exactly the above, setting the TERM var to xterm before running mc. Of course, you have to be using KDE and Konsole for this to work...
 
Old 12-10-2004, 09:19 AM   #3
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 58
Also, if you're using a terminal font that does not provide the extended characters used for drawing the lines you may want to revert to the default xterm fonts.


Håkan
 
Old 12-10-2004, 10:21 AM   #4
Oxyd
Member
 
Registered: Oct 2003
Distribution: Fedora Core 3
Posts: 34

Original Poster
Rep: Reputation: 15
Well - exporting TERM=xterm doesn't work...

I'm using Fluxbox. I used rxvt in previous distros and mc worked fine there. But now I got myself new Fedora and had to compile rxvt myself... I wonder wheter it could be something in compile-time settings?

Oxyd
 
Old 12-11-2004, 12:31 AM   #5
terminator
Member
 
Registered: May 2003
Distribution: Slackware
Posts: 35

Rep: Reputation: 15
try rxvt 2.7.10 or mrxvt, rxvt 2.6.4 might be too old.
 
Old 12-11-2004, 09:13 AM   #6
Oxyd
Member
 
Registered: Oct 2003
Distribution: Fedora Core 3
Posts: 34

Original Poster
Rep: Reputation: 15
I've upgraded to newer version, but the problem persists... I didn't notice before it didn't display right anything but standard ASCII characters (czech characters are also wrong)... So I guess I need to switch to unicode...?

Oxyd
 
Old 12-12-2004, 10:21 AM   #7
Oxyd
Member
 
Registered: Oct 2003
Distribution: Fedora Core 3
Posts: 34

Original Poster
Rep: Reputation: 15
It looks like when I export LANG=utf8 rxvt it works! I wonder how could I do it to be set whenever I open the terminal. I tried setting it into .bashrc and .bash_profile but neither helped...?

EDIT: When I export them in .bashrc I can't use certain czech charecters (for example in kwrite) - it displays just few spaces...

Oxyd

Last edited by Oxyd; 12-12-2004 at 10:43 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Displaying non-English characters in Mdk 10.1 kenhall4 Mandriva 1 03-11-2005 01:53 AM
OpenOffice not displaying German characters drj000 Linux - Software 9 10-11-2004 12:29 PM
Displaying Non-Roman characters with Apache Inexactitude Linux - Networking 1 05-24-2004 05:54 PM
Displaying Japanese characters gjarman Linux - General 1 05-01-2003 05:28 AM
Displaying Japanese characters gjarman Linux - Newbie 0 05-01-2003 01:52 AM


All times are GMT -5. The time now is 06:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration