LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-15-2006, 09:45 AM   #1
Sabinou
Member
 
Registered: Jan 2006
Location: France
Distribution: Debian Wheezy, Webmin + Virtualmin (remote dedi)
Posts: 214

Rep: Reputation: 30
Running without X server


Hello there !

Here's a very newbish question i'm afraid : How is it possible to start a command-line session, without any X server running, while letting system's default at "load graphical interface at startup" ?

You see, I want to install the nvidia driver provided by nvidia, instead of the rpm-based one. My system's default (Mandriva 2006 and KDE 3.4.2) is the graphical mode and when I close my session it immediately starts a graphical session-choser that's most probably already using X. So using AltF6/F5/etcetera switches will allow X instances to remain.

(I cannot use RPMs and must use nvidia's installer because the latest rpm-based package screws up my system and now I don't have any graphical acceleration enabled, and there's no going back since I lost my distro's DVD and the RPM depositories only provide the latest RPMs).

I know it's possible to edit system options so that the system won't start graphical interface at startup, but honestly I'd prefer a way to close X and all X-dependent applications, after the system has started.

So far, the only way I found was to start the system in failsafe mode, but I dont' know if failsafe mode would contain all the required elements to run nvidia's installer.

Thanks if you have the miracle solution ;-)
 
Old 07-15-2006, 10:02 AM   #2
devavictrix
Member
 
Registered: Jan 2006
Posts: 72

Rep: Reputation: Disabled
you need to change something in /etc/inittab

At the top it will read something like :id:5:innitdefault

Change the 5 to a 3.
This will boot you into a command line.
Its goes something like....
0: halt the computer
1: single-user mode
2: multi-user mode without networking
3: multi-user mode with networking
4: reserved for customization, otherwise does the same as 3
5: same as 4, it is usually used for GUI login (like X's xdm or KDE's kdm)
6: reboot the computer
 
Old 07-15-2006, 10:09 AM   #3
bernied
Member
 
Registered: Mar 2006
Location: Edinburgh, UK
Distribution: debian
Posts: 304

Rep: Reputation: 30
Have you tried Ctrl-Alt-F1 ?
Or F2, F3, etc.

Yes I know your display manager is still running on Ctrl-Alt-F6 (or whatever), but are you really sure that you need to kill it?

If you do need to kill the display manager, you need to know which it is.
Try:
Code:
$ ps -ef | grep gdm
root      6993     1  0 14:59 ?        00:00:00 /usr/sbin/gdm
bernie    7163  7152  0 16:10 pts/0    00:00:00 grep gdm
$
if you only get one process (grep gdm), then that's not it, try the same command with kdm instead of gdm, then xdm, until you find it.
Then:
Code:
kill 6993
BUT use the process number of your gdm (or kdm or whatever), not mine.
Then check that it's dead with that ps command again.

It's not a miracle.
 
Old 07-15-2006, 10:12 AM   #4
bernied
Member
 
Registered: Mar 2006
Location: Edinburgh, UK
Distribution: debian
Posts: 304

Rep: Reputation: 30
Then once you've done your nVidia magic, you can just restart the display manager (try the command on that process line - in my case /usr/sbin/gdm)
Or if that doesn't work, just reboot like you know you want to.
 
Old 07-15-2006, 10:17 AM   #5
bernied
Member
 
Registered: Mar 2006
Location: Edinburgh, UK
Distribution: debian
Posts: 304

Rep: Reputation: 30
And if that first kill doesn't work, try:
Code:
kill -9 xxxx
that's like 'kill it harder'
 
Old 07-15-2006, 10:25 AM   #6
Sabinou
Member
 
Registered: Jan 2006
Location: France
Distribution: Debian Wheezy, Webmin + Virtualmin (remote dedi)
Posts: 214

Original Poster
Rep: Reputation: 30
Thanks for the advice, guys.
But you know what ?
The nvidia installer told me that it couldn't find the kernel-source (so it wasn't able to compile it himself), while it IS ACTUALLY already installed.

Sigh ^^

I'll give up until I have the courage to remove all those bloody RPMs, xorg, nvidia, dkms, and install cleanly from scratch ^^
Or, no, I know, i'll try a bit later to uninstall and then reinstall kernel-source, who knows !

Thanks ^^
 
Old 07-15-2006, 10:30 AM   #7
bernied
Member
 
Registered: Mar 2006
Location: Edinburgh, UK
Distribution: debian
Posts: 304

Rep: Reputation: 30
Do you have a pre-compiled kernel installed, without the source code? Unless you compiled your own kernel you are not likely to have the source installed. Looks like nvidia wants the source, so you'd have to get the source package that matches your kernel version.
Code:
uname -r
will tell you the version you're using.
 
Old 07-15-2006, 10:47 AM   #8
Sabinou
Member
 
Registered: Jan 2006
Location: France
Distribution: Debian Wheezy, Webmin + Virtualmin (remote dedi)
Posts: 214

Original Poster
Rep: Reputation: 30
Yeah I have a precompiled version, but I also have had installed (qemu's accelerator required this) the precompiled kernel-source too, from Mandriva's RPM.
Sometimes you can't expect logic from a system ^^
 
Old 07-15-2006, 04:27 PM   #9
Sabinou
Member
 
Registered: Jan 2006
Location: France
Distribution: Debian Wheezy, Webmin + Virtualmin (remote dedi)
Posts: 214

Original Poster
Rep: Reputation: 30
Bleh, kdm.log said :
Code:
X Window System Version 6.9.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 6.9
Build Operating System: Linux 2.6.3-31mdk-i686-up-4GB i686 [ELF] 
Current Operating System: Linux mdv 2.6.12-12mdk #1 Fri Sep 9 18:15:22 CEST 2005 i686
Build Date: 05 June 2006
	Before reporting problems, check http://wiki.X.Org
	to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Jul 15 22:41:44 2006
(==) Using config file: "/etc/X11/xorg.conf"
Using vt 7
(EE) Unable to open /usr/X11R6/lib/modules/extensions/nvidia/libglx.so
(EE) Failed to load module "/usr/X11R6/lib/modules/extensions/nvidia/libglx.so" (open failed, 2)
(EE) NVIDIA(0): Failure to construct a valid mode list: no modes remaining.
(EE) NVIDIA(0):  *** Aborting ***
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
or, before XFdrake :
Code:
(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
(EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
(EE) NVIDIA(0):     you continue to encounter problems, Please try
(EE) NVIDIA(0):     reinstalling the NVIDIA driver.
(EE) NVIDIA(0): Failure to construct a valid mode list: no modes remaining.
(EE) NVIDIA(0):  *** Aborting ***
(EE) Screen(s) found, but none have a usable configuration.
or
Code:
(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
In other words, the nvidia installer didn't find any precompiled kernel module, seemed to compile one but screwed the work, and i'm back to an OS without graphical acceleration.

Sigh

The only solution would be a clean reinstall, but i'd hate formatting /
Guess i'll keep my system as is.
 
Old 07-16-2007, 09:17 AM   #10
flarets
LQ Newbie
 
Registered: Feb 2006
Posts: 2

Rep: Reputation: 0
my previous setup was opensuse and the following commands worked for me. First download the correct package from http://download.nvidia.com
Copy these commands to a text file because once you type the first command in, you're in terminal-land

sudo /sbin/init 3
sudo sh ~/your-NVIDIA-package.run
sax2 -m 0=nvidia

this worked for opensuse, but i'm trying ubuntu now and the first command doesn't seem to do anything, Anyway hope this helped
 
Old 07-16-2007, 11:56 AM   #11
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,085

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
Quote:
i'm trying ubuntu now and the first command doesn't seem to do anything
That's because (k)ubuntu handles run-levels differently (No, I don't know why!)

For (k)ubuntu:
Code:
# Runlevel 0 is halt.
# Runlevel 1 is single-user.
# Runlevels 2-5 are multi-user.
# Runlevel 6 is reboot.
 
  


Reply

Tags
nvidia


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Running my own server impulse() Linux - General 9 05-16-2006 02:53 PM
Are you running a server? fuelinjection Linux - General 14 05-14-2006 05:32 PM
Please help me get X Server running!!! civics123 Linux - Newbie 2 11-08-2004 12:09 PM
Please help me get X Server running!!! civics123 Debian 2 11-08-2004 09:43 AM
so is a web server running Linux without X 4x faster than win2k server? Mr. Mojo Risin General 3 09-02-2003 07:41 PM


All times are GMT -5. The time now is 12:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration