LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-07-2014, 09:49 PM   #16
cyberdome
Member
 
Registered: Mar 2014
Distribution: Fedora 23 - MariaDB 10.1 -
Posts: 130
Blog Entries: 2

Original Poster
Rep: Reputation: 8

Quote:
Originally Posted by michaelk View Post
As unSpawn noticed the server appears to be only listening on ipv6. However according to the documentation it should listen on both since listen_ipv6=YES option is enabled.

However I just checked and with IPV6 enabled I could not connect from a remote PC. So try disabling listen_ipv6 and enable ipv4 i.e. listen=yes.
I did change the
Code:
Listen=NO  to Listen=YES,   also, I uncommented the listen_ipv6=YES.

after making the change I restarted
Code:
systemctl restart vsftpd.service.
for some reason, I am still unable to connect from my windows machine. changing to ipv4 should have worked. But, when I change back to default port 21, it works fine using the LAN IP 192.168.1.2.

Code:
netstat -pnl | grep vsftpd
tcp        0      0 0.0.0.0:1980            0.0.0.0:*               LISTEN      20934/vsftpd

Code:
iptables -L

Chain IN_public_allow (1 references)
target     prot opt source               destination         
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:ftp ctstate NEW
ACCEPT     udp  --  anywhere             224.0.0.251          udp dpt:mdns ctstate NEW
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:http ctstate NEW
ACCEPT     tcp  --  anywhere             anywhere             tcp dpts:rfb:5903 ctstate NEW
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:smtp ctstate NEW
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:https ctstate NEW
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:mysql ctstate NEW
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:urd ctstate NEW
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:p2pq ctstate NEW
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:submission ctstate NEW
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:estamp ctstate NEW
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:pearldoc-xact ctstate NEW

Last edited by cyberdome; 04-07-2014 at 10:01 PM.
 
Old 04-08-2014, 05:06 AM   #17
cyberdome
Member
 
Registered: Mar 2014
Distribution: Fedora 23 - MariaDB 10.1 -
Posts: 130
Blog Entries: 2

Original Poster
Rep: Reputation: 8
I was able to connect on my windows machine using FTP via port 1980 using IP local LAN IP. On the FileZilla Cleint I had to choose ACTIVE mode instead of PASSIVE mode. Choosing ACTIVE mode works perfectly with the LAN IP on port 1980.

But when I try the same above settings using hostname/domain name. for example, mydomainname.com , It does not work.

I get error message,

Quote:
could not retrieve directory listing

illegal port command.

Last edited by cyberdome; 04-08-2014 at 05:08 AM.
 
Old 04-08-2014, 09:54 PM   #18
kirukan
Senior Member
 
Registered: Jun 2008
Location: Eelam
Distribution: Redhat, Solaris, Suse
Posts: 1,274

Rep: Reputation: 148Reputation: 148
Can you resolve the IP for your domainname from your windows PC?
Quote:
nslookup mydomainname.com
check this is return the FTP server LAN IP.
 
Old 04-09-2014, 05:32 AM   #19
cyberdome
Member
 
Registered: Mar 2014
Distribution: Fedora 23 - MariaDB 10.1 -
Posts: 130
Blog Entries: 2

Original Poster
Rep: Reputation: 8
nslookup in my windows machine shows my google DNS and my WAN IP.
 
Old 04-09-2014, 01:57 PM   #20
cyberdome
Member
 
Registered: Mar 2014
Distribution: Fedora 23 - MariaDB 10.1 -
Posts: 130
Blog Entries: 2

Original Poster
Rep: Reputation: 8
Thanks to everyone for posting and for all the help. Apparently, the port I was using was already assigned by IANA. my mistake. Just change the port to a very high number that is uassigned. I have actually using port that was already assigned. Now everything works using LAN IP and WAN IP. thanks for the reply.

http://www.adminsub.net/tcp-udp-port-finder/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
default /etc/vsftpd/vsftpd.conf content rpmacaspac Linux - Newbie 1 09-04-2013 01:29 AM
VSFTPD Multiple FTP sites with default port '21' maddy_elx Linux - Networking 2 05-30-2011 10:19 AM
[pureftpd] problem running from non default ftp port karphead Linux - Networking 2 10-25-2005 10:17 AM
Unable to login as local user with vsftpd running on the server kairamr Linux - Newbie 1 06-09-2004 02:25 PM
vsftpd xinetd bbbbbbbbbbbbbChanging default port jakcap Linux - Newbie 2 07-26-2003 06:30 PM


All times are GMT -5. The time now is 04:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration