LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-06-2014, 02:42 PM   #1
cyberdome
Member
 
Registered: Mar 2014
Distribution: Fedora 23 - MariaDB 10.1 -
Posts: 130
Blog Entries: 2

Rep: Reputation: 8
running vsftpd on a different port other than default 21? unable to get it working?


Hello all,

I am trying to change the default port on my vsftpd configuration.

I tried changing the port but it does not seem to connect to my server. For some reason it is not working. I have added the port in my IPtables. and port forwarded on my ROUTER. Everthing is done correctly. Still, my server is unable to connect using different port,

here is my vsftpd.conf file, I am not sure where to change the port?

Code:
# Example config file /etc/vsftpd/vsftpd.conf
#
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
#
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=NO
#
# Uncomment this to allow local users to log in.
# When SELinux is enforcing check for SE bool ftp_home_dir
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES
#
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
# When SELinux is enforcing check for SE bool allow_ftpd_anon_write, allow_ftpd_full_access
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# You may override where the log file goes if you like. The default is shown
# below.
#xferlog_file=/var/log/xferlog
#
# If you want, you can have your log file in standard ftpd xferlog format.
# Note that the default log file location is /var/log/xferlog in this case.
xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that on some FTP servers, ASCII support allows a denial of service
# attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
# predicted this attack and has always been safe, reporting the size of the
# raw file.
# ASCII mangling is a horrible feature of the protocol.
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
ftpd_banner=Welcome to the CYBERDOME FTP service. AUTHORIZED USERS ONLY!!!!!!
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd/banned_emails
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
# (Warning! chroot'ing can be very dangerous. If using chroot, make sure that
# the user does not have write access to the top level directory within the
# chroot)
#chroot_local_user=YES
#chroot_list_enable=YES
# (default follows)
#chroot_list_file=/etc/vsftpd/chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#ls_recurse_enable=YES
#
# When "listen" directive is enabled, vsftpd runs in standalone mode and
# listens on IPv4 sockets. This directive cannot be used in conjunction
# with the listen_ipv6 directive.
listen=NO
#
# This directive enables listening on IPv6 sockets. By default, listening
# on the IPv6 "any" address (::) will accept connections from both IPv6
# and IPv4 clients. It is not necessary to listen on *both* IPv4 and IPv6
# sockets. If you want that (perhaps because you want to listen on specific
# addresses) then you must run two copies of vsftpd with two configuration
# files.
# Make sure, that one of the listen options is commented !!
listen_ipv6=YES

pam_service_name=vsftpd
userlist_enable=YES
tcp_wrappers=YES

Any help is greatly appreciated.

Last edited by cyberdome; 04-06-2014 at 02:50 PM.
 
Old 04-07-2014, 12:07 AM   #2
kirukan
Senior Member
 
Registered: Jun 2008
Location: Eelam
Distribution: Redhat, Solaris, Suse
Posts: 1,272

Rep: Reputation: 148Reputation: 148
How did you change listening port for vsftpd?
can't figure-out the following line in your configuration.
Quote:
listen_port=""
 
Old 04-07-2014, 12:57 AM   #3
cyberdome
Member
 
Registered: Mar 2014
Distribution: Fedora 23 - MariaDB 10.1 -
Posts: 130
Blog Entries: 2

Original Poster
Rep: Reputation: 8
Quote:
Originally Posted by kirukan View Post
How did you change listening port for vsftpd?
can't figure-out the following line in your configuration.
there is no line in the config file by default when I installed it. I had to manually type in the line

# port configure

listen_port=port-number


but still when I type in the different port number and try to connect via FTP program. I get error message.
 
Old 04-07-2014, 01:41 AM   #4
kirukan
Senior Member
 
Registered: Jun 2008
Location: Eelam
Distribution: Redhat, Solaris, Suse
Posts: 1,272

Rep: Reputation: 148Reputation: 148
Ok. Can you post the error here? and check vsftpd listening on which port?
Quote:
netstat -pnl | grep vsftpd
 
Old 04-07-2014, 03:55 PM   #5
cyberdome
Member
 
Registered: Mar 2014
Distribution: Fedora 23 - MariaDB 10.1 -
Posts: 130
Blog Entries: 2

Original Poster
Rep: Reputation: 8
Quote:
Originally Posted by kirukan View Post
Ok. Can you post the error here? and check vsftpd listening on which port?

when I run the default port 21, everything works perfectly fine.


output of the command,

Code:
 netstat -pnl | grep vsftpd
tcp6       0      0 :::1980                 :::*                    LISTEN      17909/vsftpd
that is the port I am using, but when I open my WINSCP FTP client software on my windows machine. I get a error message saying,

Code:
timout detected,
could not retrieve directory listing,
error listing directory /home/user.
I am using the windows machine for testing. I have port 1980 added on my linux firewall and port forwarded on my ROUTER.
Attached Thumbnails
Click image for larger version

Name:	Untitled.jpg
Views:	10
Size:	86.3 KB
ID:	15184  

Last edited by cyberdome; 04-07-2014 at 04:00 PM.
 
Old 04-07-2014, 04:17 PM   #6
cyberdome
Member
 
Registered: Mar 2014
Distribution: Fedora 23 - MariaDB 10.1 -
Posts: 130
Blog Entries: 2

Original Poster
Rep: Reputation: 8
Quote:
Originally Posted by kirukan View Post
Ok. Can you post the error here? and check vsftpd listening on which port?
I was reading online that FTP uses 2 ports. So, I don't know if that is what causing the issue?
 
Old 04-07-2014, 06:50 PM   #7
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,961

Rep: Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530
I assume that you restarted the server once you added the listen_port=1980 in the configuration file.

Can you connect on the server itself?
ftp localhost port_number

If that does not work is selinux active? You can add the port via the command
semanage port -a -t ftp_port_t -p tcp 1980

If you can connect on the PC itself then are you trying to connect using your WAN IP address or the LAN IP address of your server? If using the WAN then try the LAN. If that does not work then you could still have a firewall problem.
 
Old 04-07-2014, 07:20 PM   #8
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,331
Blog Entries: 55

Rep: Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531
Quote:
Originally Posted by cyberdome View Post
Code:
 netstat -pnl | grep vsftpd
tcp6       0      0 :::1980                 :::*                    LISTEN      17909/vsftpd
Huh? "tcp6"? As in IPv6 only?..
 
Old 04-07-2014, 07:23 PM   #9
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,961

Rep: Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530
Ouch... I completely missed that..
 
Old 04-07-2014, 08:27 PM   #10
cyberdome
Member
 
Registered: Mar 2014
Distribution: Fedora 23 - MariaDB 10.1 -
Posts: 130
Blog Entries: 2

Original Poster
Rep: Reputation: 8
Quote:
Originally Posted by unSpawn View Post
Huh? "tcp6"? As in IPv6 only?..
I did notice the tcp6. could this be a issue. I am only using IPv4 on my server.

how can I run vsftpd as IPv4?

Last edited by cyberdome; 04-07-2014 at 09:25 PM.
 
Old 04-07-2014, 08:36 PM   #11
cyberdome
Member
 
Registered: Mar 2014
Distribution: Fedora 23 - MariaDB 10.1 -
Posts: 130
Blog Entries: 2

Original Poster
Rep: Reputation: 8
Quote:
Originally Posted by michaelk View Post
I assume that you restarted the server once you added the listen_port=1980 in the configuration file.

Can you connect on the server itself?
ftp localhost port_number

If that does not work is selinux active? You can add the port via the command
semanage port -a -t ftp_port_t -p tcp 1980

If you can connect on the PC itself then are you trying to connect using your WAN IP address or the LAN IP address of your server? If using the WAN then try the LAN. If that does not work then you could still have a firewall problem.

Yes, I restarted the server. and I have SELinux disabled. I tried using command ftp localhost port number , it tells me command not found.

On my windows machine, I am typing in the WINSCP client the LAN IP. 192.168.1.2 --> port 1980 , then I get the error. I have not tried the WAN IP or domain name yet.

Last edited by cyberdome; 04-07-2014 at 09:20 PM.
 
Old 04-07-2014, 08:59 PM   #12
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,961

Rep: Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530
Ftp client is not installed by default. I would install it to make sure you can connect on the computer itself.
 
Old 04-07-2014, 09:27 PM   #13
cyberdome
Member
 
Registered: Mar 2014
Distribution: Fedora 23 - MariaDB 10.1 -
Posts: 130
Blog Entries: 2

Original Poster
Rep: Reputation: 8
Quote:
Originally Posted by michaelk View Post

Can you connect on the server itself?
ftp localhost port_number
Quote:
Originally Posted by michaelk View Post
Ftp client is not installed by default. I would install it to make sure you can connect on the computer itself.

yes, I was able to install ftp client on my server. I ran the command,

ftp localhost 1980

works perefectly locally on my server machine. Only when I am trying to connect from my windows machine. I am getting error message.

Last edited by cyberdome; 04-07-2014 at 09:30 PM.
 
Old 04-07-2014, 09:58 PM   #14
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,961

Rep: Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530
As unSpawn noticed the server appears to be only listening on ipv6. However according to the documentation it should listen on both since listen_ipv6=YES option is enabled.

However I just checked and with IPV6 enabled I could not connect from a remote PC. So try disabling listen_ipv6 and enable ipv4 i.e. listen=yes.
 
Old 04-07-2014, 10:28 PM   #15
kirukan
Senior Member
 
Registered: Jun 2008
Location: Eelam
Distribution: Redhat, Solaris, Suse
Posts: 1,272

Rep: Reputation: 148Reputation: 148
If you enable IPv6, there should be two configuration files one for IPv4 and other one for IPv6.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
default /etc/vsftpd/vsftpd.conf content rpmacaspac Linux - Newbie 1 09-04-2013 02:29 AM
VSFTPD Multiple FTP sites with default port '21' maddy_elx Linux - Networking 2 05-30-2011 11:19 AM
[pureftpd] problem running from non default ftp port karphead Linux - Networking 2 10-25-2005 11:17 AM
Unable to login as local user with vsftpd running on the server kairamr Linux - Newbie 1 06-09-2004 03:25 PM
vsftpd xinetd bbbbbbbbbbbbbChanging default port jakcap Linux - Newbie 2 07-26-2003 07:30 PM


All times are GMT -5. The time now is 12:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration