LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Running Fedora 4 on primary master and cant acsess my xp files on primary slave (http://www.linuxquestions.org/questions/linux-newbie-8/running-fedora-4-on-primary-master-and-cant-acsess-my-xp-files-on-primary-slave-409233/)

roxberry1 01-29-2006 05:05 AM

Running Fedora 4 on primary master and cant acsess my xp files on primary slave
 
I just installed Fedora Core 4 on a new drive that is master but i cant acsess my xp files on slave.

Nylex 01-29-2006 05:11 AM

Please, give more info about your problem. It's pointless to pretty much just repeat your thread title.

What are you doing to try to get access to your Windows files? Have you mounted your XP partition under Linux? If you tried this and are getting error messages or anything, please tell us what the exact problem is. It would probably also help to know what filesystem your XP partition is using.

roxberry1 01-29-2006 05:44 AM

Hi Nylex

Sorry completely in the dark with linux running NTSE i can see in the hardware browser that it is hdb1 and i try to put that in to file browser but it says that this is not a folder, and that is about all i know. Dont know how to mount my xp drive!!

Nylex 01-29-2006 06:12 AM

What's NTSE? Do you mean NTFS?

You need to mount your partiton before being able to access the files on it. Perhaps Fedora has done this for you, so it's wise to check first. Open up a terminal window (if you don't know how, then look in the menus for entries like "Terminal" or "Konsole") and type "mount" (without quotes). If your partition is mounted already, you'll see (amongst others) a line like the following:

/dev/hda1 on /mnt/windows type ntfs (ro).

This is what mine looks like and yours may be different (obviously, yours should have "/dev/hdb1" at the start, for example). If there is a similar line there, you need to change to the directory that your partition is mounted on (here, /mnt/windows) so put that info in your file browser, or from the terminal,

$ cd /mnt/windows

If you get permission denied errors, then you need to become root first (do this with the "su" command and then enter your password. The prompt will change from a $ to a #.

If your partition hasn't been mounted, then mount it with

# mount -t vfat /dev/hdb1 /mnt/windows

if your partition is formatted FAT and

# mount -t ntfs /dev/hdb1 /mnt/windows

if it's formatted NTFS. The last bit of those lines tell you where the partition is being mounted to, so you don't need to use /mnt/windows if you don't want to. Just be sure that the directory you're using exists! Again, the # signifies that you must be root to mount partitions (you don't need to type the #).

If you get "unknown filesystem type 'ntfs'" errors, then you'll need to enable support for NTFS in the kernel, but I think there's a module for Fedora you can download for this (search this forum, it's probably been asked before).

There's a lot to read, but hopefully it helps.

roxberry1 01-29-2006 09:28 AM

Thks

i am geting this "unknown filesystem type 'ntfs'" but have found the module

roxberry1 01-29-2006 11:37 AM

All working


All times are GMT -5. The time now is 11:07 AM.