LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-22-2014, 07:47 AM   #16
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156

# 15 .
Quote:
autoconf: not found
Well, then better install / reinstall the ns2 prerequisites :
$ sudo apt-get install g++ autoconf automake make libtool patch libxmu-dev xgraph


Quote:
sudo dpkg -i gcc41-compat-4.1.2-ubuntu1210_i386.deb g++41-compat-4.1.2_i386.deb
... And please remember to reboot the OS.

-
 
Old 02-22-2014, 07:54 AM   #17
r0w225
Member
 
Registered: Jul 2012
Location: South Africa
Distribution: Ubuntu precise pangolin 12.04LTS
Posts: 48

Original Poster
Rep: Reputation: Disabled
hi knudfl
i solved the problem as i indicated down the post #15
Quote:
====================
My bad have to do sudo dpkg -i gcc41-compat-4.1.2-ubuntu1210_i386.deb g++41-compat-4.1.2_i386.deb
, and yes i did reboot the machine, everything is installed fine but still have the same problem of the rumor module exiting unexpectedly during the run. as in post #12. showing 11 nodes instead of 30 nodes and yet no real data transmission. maybe a memory leak or something like that, just clueless
 
Old 02-22-2014, 09:32 AM   #18
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156
#17, and ref. #12 .

Please attach 'energy_sum_add.awk' as : "energy_sum_add.awk.txt".


Quote:
I mean I have 30 nodes
.
.
total left energy of 11 nodes
Well, the nam display shows 30 nodes. But no visible activity.
Attached Thumbnails
Click image for larger version

Name:	screen15317.jpg
Views:	8
Size:	21.4 KB
ID:	14800  
 
Old 02-22-2014, 09:41 AM   #19
r0w225
Member
 
Registered: Jul 2012
Location: South Africa
Distribution: Ubuntu precise pangolin 12.04LTS
Posts: 48

Original Poster
Rep: Reputation: Disabled
this is exactely what i have been experiencing, but in the tcl script if you change the routing protocol with aodv or dsdv or else it works okay. please find attached the awk
couldnot attached it actually:
====================
BEGIN {
totalenergy=0;
for(i=0;i<=120;i++){
energysum[i]=1.000;
}
largeid=0;
}
{
nodeid = $9;
nodeenergy = $17;
if (energysum[nodeid]>nodeenergy){
energysum[nodeid]=nodeenergy;

}
if (nodeid > largeid) largeid = nodeid;
}
END {
for(i=0;i<=largeid;i++){
totalenergy = totalenergy+energysum[i];
printf ("node (%d) have %f energy\n",i,energysum[i]);
}
printf ( "total left energy of %d nodes network is %f\n",largeid,totalenergy);
}
=====================================
 
Old 02-22-2014, 09:59 AM   #20
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156
# 19 : Thanks, the above copy of the awk script will do.


Repeat : Text etc. attachments must have suffix .txt → → "energy_sum_add.awk.txt".
Example : file.bz2 becommes file.bz2.txt .
Images can have suffix's .jpg .jpeg etc.
Attached Thumbnails
Click image for larger version

Name:	screen24835.jpg
Views:	9
Size:	22.1 KB
ID:	14801  
 
Old 03-02-2014, 03:28 AM   #21
r0w225
Member
 
Registered: Jul 2012
Location: South Africa
Distribution: Ubuntu precise pangolin 12.04LTS
Posts: 48

Original Poster
Rep: Reputation: Disabled
Hi all, any success with the debugging of the issue encountered ?
 
  


Reply

Tags
lcsrumor, ns2, rumor


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
APTEEN routing protocol for ns2.34 under CYGWIN reem10 Linux - Software 0 01-15-2014 10:44 PM
NS2: MFR and LAR routing protocol anisabutsi Linux - Software 1 06-04-2013 01:20 PM
GPSR routing protocol on ns2.34 farfattou Programming 4 02-22-2013 03:58 AM
spin routing protocol simulation in ns2 piyar Linux - Software 0 08-19-2011 02:17 AM
i am using ubuntu as os. for NS2 to implement a routing protocol in ns2. sujovasu Programming 1 07-27-2010 02:44 AM


All times are GMT -5. The time now is 06:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration