LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-02-2015, 09:28 AM   #1
loadedmind
Member
 
Registered: Sep 2003
Location: Texas
Distribution: Red Hat/CentOS
Posts: 290
Blog Entries: 1

Rep: Reputation: Disabled
Ruby upgrade 1.8.7 on CentOS 5.10


We're unable to upgrade our environment beyond CentOS 5.10. This is a webserver that has certain reliances to the specific version of the OS, long story short.

I was asked to install a plugin for Redmine that requires at least ruby 1.8.7 so I cloned our VM as a new machine to test functional checkout. The problem is, the existing installation of Ruby was also installed ad hoc (not from any repo or yum methods) and it's currently at 1.8.5. The 1.8.7 version I tried to install gives me the following:
Quote:
# rpm -Uvf ruby-1.8.7.374-2.el6.x86_64.rpm warning: ruby-1.8.7.374-2.el6.x86_64.rpm: Header V3 RSA/SHA1 signature: NOKEY, key ID c105b9de error: Failed dependencies: rpmlib(FileDigests) <= 4.6.0-1 is needed by ruby-1.8.7.374-2.el6.x86_64 ruby-libs = 1.8.7.374-2.el6 is needed by ruby-1.8.7.374-2.el6.x86_64 rpmlib(PayloadIsXz) <= 5.2-1 is needed by ruby-1.8.7.374-2.el6.x86_64 ruby = 1.8.5-31.el5_9 is needed by (installed) ruby-irb-1.8.5-31.el5_9.x86_64 ruby = 1.8.5-31.el5_9 is needed by (installed) ruby-rdoc-1.8.5-31.el5_9.x86_64 ruby = 1.8.5-31.el5_9 is needed by (installed) ruby-ri-1.8.5-31.el5_9.x86_64
It appears as though this particular version was intended for CentOS 6 and, as I've known from previous experience, dependency hell is upon me. So, the question becomes, has anyone successfully upgraded ruby without tinkering with the OS version upgrade and, if so, might you have a HOWTO that prevents dependency hell? This, short of installing from source, is headed in the wrong direction real quick so I'm trying to stick with the RPM method. But, obviously, I'll listen to anything at this point.
 
Old 02-02-2015, 10:17 AM   #2
a4z
Senior Member
 
Registered: Feb 2009
Posts: 1,248

Rep: Reputation: 533Reputation: 533Reputation: 533Reputation: 533Reputation: 533Reputation: 533
you can not simply update 1 rpm with the ruby version,
if you use rpm you have to update/install also all dependencies

similar to pythons virtual env you can install different ruby versions,
read through
https://rvm.io/
and or
https://github.com/sstephenson/rbenv
and decide which fits best for you.
 
Old 02-03-2015, 10:02 AM   #3
loadedmind
Member
 
Registered: Sep 2003
Location: Texas
Distribution: Red Hat/CentOS
Posts: 290
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Thanks a4z.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ruby upgrade 1.8.7 on CentOS 5.10 loadedmind CentOS 1 02-05-2015 07:20 AM
LXer: How to install Ruby and Ruby on Rails on CentOS LXer Syndicated Linux News 0 09-15-2014 08:30 PM
Upgrade to Wheezy - Redmine / Ruby issues tomehb Debian 2 11-29-2012 05:20 AM
Trouble installing Ruby mongrel/mysql/passenger on CentOS samarudge Linux - Server 6 01-19-2011 02:56 PM
Ruby on Rails on CentOS 5.3 nandanm1 Programming 6 10-15-2009 01:10 PM


All times are GMT -5. The time now is 09:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration