LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-22-2012, 11:57 AM   #1
pboll1958
LQ Newbie
 
Registered: Dec 2012
Location: The Netherlands
Distribution: Linux Mint Rebecca Cinnamon
Posts: 3

Rep: Reputation: Disabled
Unhappy Rubbish characters on top and in menus


I just installes OpenSuse 12.2 with gnome.
I have installed all updates.

I have have rubbish characters in the top and in all menus.
Can't read them.
Applications have black and white screens but readable.
It seems to me that the monitor drivers are not OK.
I have a 17inch iiyama PLE430.
I cant change resolution because that gives an Oeps error?

Using OpenSuse 11.2 everything is OK, where the monitor usage is given as unknown !

Would changing from Gnome to KDE help?
Can I change the type of monitor somewhere?
 
Old 12-22-2012, 12:29 PM   #2
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
Hello pboll1958, welcome to LQ,

I don't understand the problem. Is it a problem of "wrong Characters" or "wrong displayed graphics"?

Could you please tell us where you live?
Open a terminal and execute
Code:
echo $LANG
and please execute in a terminal
Code:
lspci -k | grep -iA3 vga
and if this gives no output please
Code:
lspci -k | grep -iA3 graph
the lspci command with option -k will show for each device which kernelmodule is in use, I want to see which graphics-adapter your computer has and which kernelmodule is in use for this device.

Markus
 
Old 12-22-2012, 12:36 PM   #3
pboll1958
LQ Newbie
 
Registered: Dec 2012
Location: The Netherlands
Distribution: Linux Mint Rebecca Cinnamon
Posts: 3

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by markush View Post
Hello pboll1958, welcome to LQ,

I don't understand the problem. Is it a problem of "wrong Characters" or "wrong displayed graphics"?

Could you please tell us where you live?
Open a terminal and execute
Code:
echo $LANG
and please execute in a terminal
Code:
lspci -k | grep -iA3 vga
and if this gives no output please
Code:
lspci -k | grep -iA3 graph
the lspci command with option -k will show for each device which kernelmodule is in use, I want to see which graphics-adapter your computer has and which kernelmodule is in use for this device.

Markus
Hello Markus,
Thanks for your questions.
I live in the Netherlands: nl_NL.UTF-8
Both commands do not give any output??
when i run lspci -k it says:
Absolute path to 'lspci' is '/sbin/lspci', so running it may require superuser privileges (eg. root).
?
I do not have a graphics problem but a characterdisplay problem.

I found out how to run this as root.
Then I see only on the first command the following result:
linux-makw:~ # lspci -k | grep -iA3 vga
01:00.0 VGA compatible controller: NVIDIA Corporation NV34 [GeForce FX 5200] (rev a1)
Subsystem: XFX Pine Group Inc. GeForce FX 5200
Kernel driver in use: nouveau
02:00.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)

Already during startup when all those luinux-messages are logged, I can see that not all characters are displayed on the left...

Last edited by pboll1958; 12-22-2012 at 12:48 PM. Reason: Additional information
 
Old 12-22-2012, 12:41 PM   #4
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
Indeed you could use
Code:
/sbin/lspci -k | grep -iA3 vga
or
Code:
/sbin/lspci | grep -k | grep -iA3 graph
or execute only
Code:
/sbin/lspci -k
and find the lines with infos about your graphics adapter.

Markus
 
Old 12-22-2012, 02:44 PM   #5
TroN-0074
Senior Member
 
Registered: Dec 2011
Location: Michigan USA
Distribution: OpenSUSE 13.2 64bit-Gnome on ASUS U52F
Posts: 1,444

Rep: Reputation: 340Reputation: 340Reputation: 340Reputation: 340
The problem you have is because your Graphic card is not configurated correcly. You can find the exact driver for your card at the NVIDIAs web site http://www.geforce.com/drivers/results/52241.

In the mean time you can run GNOME the fall back mode and that should display good enough.

Once you have found the exact driver for your card ask on the opensuse forum how to install it on your system.

Here is a quick how to. http://forums.opensuse.org/content/3...-hard-way.html

Good luck to you.
 
Old 12-23-2012, 08:52 AM   #6
pboll1958
LQ Newbie
 
Registered: Dec 2012
Location: The Netherlands
Distribution: Linux Mint Rebecca Cinnamon
Posts: 3

Original Poster
Rep: Reputation: Disabled
Wink

Quote:
Originally Posted by TroN-0074 View Post
The problem you have is because your Graphic card is not configurated correcly. You can find the exact driver for your card at the NVIDIAs web site http://www.geforce.com/drivers/results/52241.

In the mean time you can run GNOME the fall back mode and that should display good enough.

Once you have found the exact driver for your card ask on the opensuse forum how to install it on your system.

Here is a quick how to. http://forums.opensuse.org/content/3...-hard-way.html

Good luck to you.
All this was to difficult for me and did not work.
Could not even get into run level 3 also not after editing /etc/inittab
So I decided to reinstall everything from scratch.
Also that seemed not OK first.
Got a black screen.
After running in recovery mode where all works fine. Don't know why here the screen is OK?
Then I installed all the patches with yast.
Then still the screen in normal mode is not OK but now I have no strange characters anymore ! Only the problem that the mouse leaves the screen on the left and right.
Putting the resolution on 1024 instead of 1268 helps.
However the procedure to install better drivers is to hard for me (yet).
Thanks anyway.
 
Old 12-23-2012, 02:57 PM   #7
TroN-0074
Senior Member
 
Registered: Dec 2011
Location: Michigan USA
Distribution: OpenSUSE 13.2 64bit-Gnome on ASUS U52F
Posts: 1,444

Rep: Reputation: 340Reputation: 340Reputation: 340Reputation: 340
That is unfortunate. I hope you can solve that problem. Perhaps you can try the OpenSuse forums it might be more help there for that issue.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] puts(rubbish)... jay73 Programming 9 07-21-2010 09:27 PM
Smudged text, missing menus and characters tom_sawyer70 Linux - Laptop and Netbook 3 09-02-2009 09:28 AM
can't use third characters on the top keys ( { [ | ` @...) of my keyboard on RHEL5 mars33 Linux - Server 1 11-03-2007 06:08 PM
flash media on top of menus crazibri Linux - Software 1 02-25-2006 10:22 AM
FTP is rubbish uveraser General 8 06-12-2004 10:44 PM


All times are GMT -5. The time now is 04:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration