LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-10-2009, 10:59 AM   #1
maxy7710
Member
 
Registered: Jan 2008
Location: Mumbai, india
Distribution: REDHAT, FEDORA,SUSE, UBUNTU, ORACLE ENTERPRISE LINUX & SOLARIS 10
Posts: 130

Rep: Reputation: 17
Unhappy rsh Setup


HI

i want to setup a rsh between 2 servers for my SAP Setup.
i know ssh is better compared to rsh , but SAP specifically wants rsh.
i havent used rsh till now, so need steps to setup rsh.

Thanking in advance
 
Old 02-15-2009, 12:12 AM   #2
JulianTosh
Member
 
Registered: Sep 2007
Location: Las Vegas, NV
Distribution: Fedora / CentOS
Posts: 674
Blog Entries: 3

Rep: Reputation: 90
Give this a try...

http://puretechie.blogspot.com/2007/...-on-linux.html

If that gives you any troubles, let us know what flavor/distro of linux you're using.

Last edited by JulianTosh; 02-15-2009 at 12:13 AM.
 
Old 03-31-2009, 02:15 AM   #3
maxy7710
Member
 
Registered: Jan 2008
Location: Mumbai, india
Distribution: REDHAT, FEDORA,SUSE, UBUNTU, ORACLE ENTERPRISE LINUX & SOLARIS 10
Posts: 130

Original Poster
Rep: Reputation: 17
CPCAPP108 & CPCAPP110 are 2 servers who need rsh to & fro

==================|
CPCAPP108 config:-|
==================|

vim /etc/hosts.equiv
CPCAPP110

vim /root/.rhosts
CPCAPP110

Set the permissions on the file to 600.

chmod 600 /root/.rhosts

vim /etc/securetty
rsh
rlogin

vim /etc/xinetd.d/rsh
disable = no

vim /etc/xinetd.d/rlogin
disable = no

3 files /usr/bin/rsh /usr/bin/rcp /usr/bin/rlogin should have SUID bit set on it

i.e chmod u+s /usr/bin/rsh /usr/bin/rcp /usr/bin/rlogin

/etc/init.d/xinetd restart

then do rsh CPCAPP108 from CPCAPP110 server.

==================|
CPCAPP110 config:-|
==================|

vim /etc/hosts.equiv
CPCAPP108

vim /root/.rhosts
CPCAPP108

Set the permissions on the file to 600.

chmod 600 /root/.rhosts

vim /etc/securetty
rsh
rlogin

vim /etc/xinetd.d/rsh
disable = no

vim /etc/xinetd.d/rlogin
disable = no

3 files /usr/bin/rsh /usr/bin/rcp /usr/bin/rlogin should have SUID bit set on it

i.e chmod u+s /usr/bin/rsh /usr/bin/rcp /usr/bin/rlogin

/etc/init.d/xinetd restart

then do rsh CPCAPP110 from CPCAPP108 server.
 
Old 03-31-2009, 02:16 AM   #4
maxy7710
Member
 
Registered: Jan 2008
Location: Mumbai, india
Distribution: REDHAT, FEDORA,SUSE, UBUNTU, ORACLE ENTERPRISE LINUX & SOLARIS 10
Posts: 130

Original Poster
Rep: Reputation: 17
Issue resolved
see above notes
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
rsh error: protocol failure in circuit setup Andrea Linux - Networking 5 09-17-2009 02:15 PM
'rsh' - setup RedOctober45 Linux - Software 1 01-11-2008 07:07 PM
how to setup rsh or configure ssh properly cheeku Linux - Software 5 03-30-2006 08:47 AM
setup of IP addy, localhost, and rsh d4harvey Linux - Networking 2 09-07-2004 09:20 PM
rsh : poll: protocol failure in circuit setup haoscar Linux - Software 0 07-20-2004 09:49 PM


All times are GMT -5. The time now is 11:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration