LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-16-2004, 10:37 AM   #1
rightsidedown
LQ Newbie
 
Registered: Jul 2004
Posts: 14

Rep: Reputation: 0
rsh


Hi All,
I am new to Linux. I installed Red Hat 9. I am trying to get rsh to work. When I try to rsh to this system it comes back with permission denied. I have created a .rhosts with the hostnames. I checked the rsh file and set disable to no. I did a /etc/init.d/xinetd restart but it still didn't work. Am I missing something? Thanks for all of your help.
 
Old 07-16-2004, 01:24 PM   #2
osvaldomarques
Member
 
Registered: Jul 2004
Location: Rio de Janeiro - Brazil
Distribution: Conectiva 10 - Conectiva 8 - Slackware 9 - starting with LFS
Posts: 519

Rep: Reputation: 34
There are some more steps to get rsh working. Remember "rsh" is the client side of a remote command. You need to have the server side installed and enabled. First check if "rshd" is installed. After you need to enable it. I think Red Hat use xinetd super server to start rshd. So, you have to edit the file "/etc/xinetd.d/rsh"
Code:
service shell
{
        disable     = no
        flags       = REUSE
        socket_type = stream
        protocol    = tcp
        wait        = no
        user        = root
        server      = /usr/sbin/in.rshd
}
This configuration file comes with "disable = yes". Change it to no and restart xinetd to enable it. After it is enabled, you need /root/.rhosts and /etc/hosts.equiv to have the hosts configured. Both files have to have the same content. It is important the permifissions for both be "0644" (read/write for root and readable by all) otherwise rshd will ignore it.
Last but not least, it's very probable your installation use the "pam package" to control login. So, you have to configure pam.. You need a file named "/etc/pam.d/rsh" with this content:
Code:
#%PAM-1.0
auth       required     /lib/security/pam_rhosts_auth.so
auth       required     /lib/security/pam_nologin.so
account    required     /lib/security/pam_unix.so
session    required     /lib/security/pam_unix.so
~
Good luck!
 
Old 07-16-2004, 03:21 PM   #3
rightsidedown
LQ Newbie
 
Registered: Jul 2004
Posts: 14

Original Poster
Rep: Reputation: 0
Thanks for your help Osvaldomarques. From looking at your recommendations I found out that rsh was supposed to be listed in etc/securetty. Once I added that it worked fine. Thanks again.
 
Old 07-16-2004, 04:08 PM   #4
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
You probably ought to be using ssh instead, unless you have some compelling reason to use rsh. The r protocols (rlogin, rsh, etc.) aren't considered secure because everything (including passwords) is transmitted over the network in plain text.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
RSH: remuser too long error when rsh is executed from IIS dev33445 Programming 0 08-29-2005 10:34 AM
rsh drisay Slackware 2 11-11-2004 02:24 PM
rsh ziox Linux - Networking 1 10-27-2004 07:11 PM
how to use rsh?? nqduy Linux - Networking 2 08-21-2003 03:00 AM
please help with rsh slice4e Linux - General 5 08-19-2003 01:49 PM


All times are GMT -5. The time now is 09:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration