LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-18-2015, 01:47 AM   #1
omniok
LQ Newbie
 
Registered: May 2014
Posts: 15

Rep: Reputation: Disabled
rpm not working


Hi All,

I am having RHEL 5.4 64-bit OS. When I run the command "rpm --help" I get the following error. Please help:

rpm: /usr/lib64/libpopt.so.0: no version information available (required by rpm)
rpm: /usr/lib64/libpopt.so.0: no version information available (required by /usr/lib64/librpmbuild.so.1)
rpm: /usr/lib64/libpopt.so.0: no version information available (required by /usr/lib64/librpm.so.1)
rpm: /usr/lib64/libpopt.so.0: no version information available (required by /usr/lib64/librpmio.so.1)
rpm: /lib64/libc.so.6: version `GLIBC_2.7' not found (required by /usr/lib64/liblua-5.1.so)
rpm: /lib64/libc.so.6: version `GLIBC_2.11' not found (required by /usr/lib64/liblua-5.1.so)

Thanks in advance.
 
Old 02-18-2015, 01:53 AM   #2
veerain
Senior Member
 
Registered: Mar 2005
Location: Earth bound to Helios
Distribution: Custom
Posts: 2,524

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
You are missing 64bit version of popt as well as glibc packages. Install them.

Also try run:

Code:
ldconfig /lib64
Check if it helps.

Edited.

Last edited by veerain; 02-18-2015 at 07:41 AM.
 
Old 02-18-2015, 02:10 AM   #3
omniok
LQ Newbie
 
Registered: May 2014
Posts: 15

Original Poster
Rep: Reputation: Disabled
Thanks veerain, the correct command is "ldconfig" and not "ldocnfig"

The output of this command is as mentioned below. However, "rpm --help" gives the same error as mentioned earlier.

[root@bkpdrill ~]# ldconfig /lib64
ldconfig: /usr/lib64/liblzma.so.0 is not a symbolic link

[root@bkpdrill ~]#
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
rpm not working from root login but working from user login amar.sree Linux - Newbie 2 08-09-2012 09:53 PM
rpm for ntfs support for rhel 5.0 not working looking for specific ntfs rpm shekhar.ieit@gmail.com Linux - Kernel 1 12-03-2009 05:02 AM
rpm -e not working? FLOODS Linux - Software 5 08-13-2003 05:28 PM
rpm not working obli Linux - General 4 02-12-2003 02:54 PM
RPM not working tristan_vdv Linux - General 2 07-23-2002 05:46 AM


All times are GMT -5. The time now is 06:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration