LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-30-2011, 12:42 AM   #1
pradiptart
Member
 
Registered: Sep 2007
Posts: 102

Rep: Reputation: 12
rpm (not able to install)


Sir ,
I am trying to install a .rpm in my redhat 5.4 (in vbox) but it is not installing .
kindly tell me some answer..

#rpm -ivh --nodeps libssh-devel-0.5.2-1.mga2.i586.rpm
warning: libssh-devel-0.5.2-1.mga2.i586.rpm: Header V3 RSA/SHA1 signature: NOKEY, key ID 80420f66
error: failed to stat 8777/wshare: No such file or directory
Preparing... ########################################### [100%]
1:libssh-devel ########################################### [100%]
error: unpacking of archive failed: cpio: Bad magic

I have one folder name 8777/wshare ..and with in that this file is present .. what happening i am not able to find out the error.
Thank you
Pradipta
 
Old 11-30-2011, 01:12 AM   #2
tajamari
Member
 
Registered: Jul 2007
Distribution: Red Hat CentOS Ubuntu FreeBSD OpenSuSe
Posts: 252

Rep: Reputation: 32
The RPM may be outdated. Try to find a newer one.
 
Old 11-30-2011, 02:41 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,630

Rep: Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267
The package libssh-devel-0.5.2-1.mga2.i586.rpm is for a contemporary Linux.
And cannot be installed into the old RHEL 5.4.

There is no package libssh-devel (Or openssh-devel) in the Redhat EL 5 repos.
The EPEL repo has these :
libssh2.i386, libssh2-devel.i386 : Version 0.18

EPEL https://fedoraproject.org/wiki/EPEL
> http://download.fedoraproject.org/pu...5-4.noarch.rpm
http://download.fedora.redhat.com/pu...i386/repoview/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot install vlc using rpm -ivh <rpm> redhat5 Linux - Newbie 2 07-26-2009 04:38 AM
Which path to use to query rpm to determine which RPM to install? elitt2 Red Hat 4 10-08-2007 01:18 PM
How do I force an older rpm to install over a newer rpm of wine onyx Linux - Software 4 02-20-2004 12:44 AM
RPM 'failed dependencies': Why can I not install any rpm packages? leontini Linux - Newbie 7 09-16-2003 12:44 AM
Help : rpm dependency error when install video driver rpm ymdwxm Linux - Software 1 04-04-2003 04:55 PM


All times are GMT -5. The time now is 05:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration