LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-31-2010, 08:41 AM   #1
nagavinodh
Member
 
Registered: Aug 2009
Posts: 118

Rep: Reputation: 15
rpm installation error


hi,

Tried to install rpm packafed in red hat 5.

got the following errors.How to resolve that.

[root@perf co]# rpm -ivh glibc-2.5-24.i386.rpm
warning: glibc-2.5-24.i386.rpm: Header V3 DSA signature: NOKEY, key ID 652e84dc
error: Failed dependencies:
glibc-common = 2.5-24 is needed by glibc-2.5-24.i386
[root@perf co]# rpm -ivh libgomp-4.1.2-33.i386.rpm
warning: libgomp-4.1.2-33.i386.rpm: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
Preparing... ########################################### [100%]
file /usr/lib/libgomp.so.1.0.0 from install of libgomp-4.1.2-33 conflicts with file from package libgomp-4.1.1-52.el5
[root@perf co]# rpm -ivh glibc-2.5-24.i386.rpm
warning: glibc-2.5-24.i386.rpm: Header V3 DSA signature: NOKEY, key ID 652e84dc
error: Failed dependencies:
glibc-common = 2.5-24 is needed by glibc-2.5-24.i386
[root@perf co]# rpm -ivh libstdc++-4.1.2-12.i386.rpm
warning: libstdc++-4.1.2-12.i386.rpm: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
Preparing... ########################################### [100%]
file /usr/lib/libstdc++.so.6.0.8 from install of libstdc++-4.1.2-12 conflicts with file from package libstdc++-4.1.1-52.el5

Last edited by nagavinodh; 03-31-2010 at 08:45 AM.
 
Old 03-31-2010, 09:04 AM   #2
xxx_anuj_xxx
Member
 
Registered: Jun 2004
Location: Bharat
Distribution: RedHat, Debian, FreeBSD, Fedora, Centos
Posts: 114

Rep: Reputation: 16
Do you have your server registered with redhat?

Do man rpm.
Install/update glibc-common
Update libgomp & libstdc++-4.1.2-12
 
Old 03-31-2010, 09:04 AM   #3
crts
Senior Member
 
Registered: Jan 2010
Posts: 1,606

Rep: Reputation: 448Reputation: 448Reputation: 448Reputation: 448Reputation: 448
Quote:
error: Failed dependencies:
glibc-common = 2.5-24 is needed by glibc-2.5-24.i386
Well, have you tried to install glibc-common version 2.5-24? It says that it needs it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installation error of RPM Package soni_silver17 Linux - Software 1 10-28-2009 06:39 AM
kernel rpm installation error trebek Linux - Software 1 06-10-2006 05:51 PM
RPM installation error Rollie Peck Linux - Software 5 02-16-2005 05:45 PM
Error trying to run Opera after RPM installation timsch75 Linux - Newbie 5 03-04-2004 09:45 AM
RPM Installation error message umakar2000 Linux - Newbie 2 08-19-2002 09:21 AM


All times are GMT -5. The time now is 02:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration