LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-06-2004, 10:13 AM   #1
tuxdain
LQ Newbie
 
Registered: Jan 2004
Posts: 3

Rep: Reputation: 0
RPM install- what do I do about conflicts


I am installing an rpm package on RedHat and I get :

error: failed dependencies:
dev < 3.2-7 conflicts with kernel-2.4.20-28.7
iptables < 1.2.5-3 conflicts with kernel-2.4.20-28.7
bcm5820 < 1.81 conflicts with kernel-2.4.20-28.7

In general, what do I need to do to resolve conflicts like this?
 
Old 01-06-2004, 10:49 AM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 470Reputation: 470Reputation: 470Reputation: 470Reputation: 470
Which package are you trying to install?
 
Old 01-06-2004, 10:55 AM   #3
tuxdain
LQ Newbie
 
Registered: Jan 2004
Posts: 3

Original Poster
Rep: Reputation: 0
I am upgrading the kernel per a Red Hat erratta (version info below):

I have one conflict remaining and I am perplexed. If you read below, you will see that the new kernel apparently conflicts with a version of bcm5820 that is not even on this system.

medlinux:/tmp/redhatfix> rpm -Fvh *.rpm
error: failed dependencies:
bcm5820 < 1.81 conflicts with kernel-2.4.20-28.7
medlinux:/tmp/redhatfix> rpm -qa bcm5820
bcm5820-1.17-6

What would you do next?
 
Old 01-06-2004, 11:04 AM   #4
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 470Reputation: 470Reputation: 470Reputation: 470Reputation: 470
I would search to see if I can upgrade bcm5820. It looks like your version is too low for your upgrade.
 
Old 01-06-2004, 12:17 PM   #5
tuxdain
LQ Newbie
 
Registered: Jan 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks Xavier.

After searching I came up empty handed on a newer version so I removed the bcm5820 package.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-rpm, SuSE 8.2 upgrade, and package conflicts bigrigdriver Linux - Software 2 05-28-2005 04:23 PM
rpm conflicts sottesen Linux - Software 2 07-07-2004 02:21 PM
2.6.0 and RPM conflicts??? JimDog Linux - Software 5 12-27-2003 09:06 PM
vte-0.11.10-1.i386.rpm conflicts its older version and gnome-terminal sybatter Linux - Software 0 12-06-2003 08:47 PM
Apt rpm conflicts??? thcmwz Linux - Software 6 09-10-2003 07:00 AM


All times are GMT -5. The time now is 10:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration