LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-11-2003, 02:56 PM   #1
Killah
Member
 
Registered: Sep 2003
Location: Belgium, Alosta²
Distribution: Linux Mandrake 9.2
Posts: 66

Rep: Reputation: 15
RPM install problem


Hi, I have some problems with RPM instals

when I'm in root and want to start an rpm install, my pc don't do anything

-->

[Root@Local host killah] rpm -ivh filename.rpm
(enter)
and there he stops

I'm using redhat linux 9.0
need help !!
thx Pieter
 
Old 09-11-2003, 03:04 PM   #2
daveo
Member
 
Registered: Sep 2003
Location: Holland
Distribution: Gentoo 1.4, Slackware
Posts: 196

Rep: Reputation: 30
Re: RPM install problem

Quote:
Originally posted by Killah
Hi, I have some problems with RPM instals

when I'm in root and want to start an rpm install, my pc don't do anything

-->

[Root@Local host killah] rpm -ivh filename.rpm
(enter)
and there he stops

I'm using redhat linux 9.0
need help !!
thx Pieter
Try rpm -i filename.rpm

Hope it helps, but you've already try that huh ?
 
Old 09-11-2003, 03:06 PM   #3
Killah
Member
 
Registered: Sep 2003
Location: Belgium, Alosta²
Distribution: Linux Mandrake 9.2
Posts: 66

Original Poster
Rep: Reputation: 15
Yes I Do , is there nothing else i can do ??

thx for reply
 
Old 09-11-2003, 03:11 PM   #4
daveo
Member
 
Registered: Sep 2003
Location: Holland
Distribution: Gentoo 1.4, Slackware
Posts: 196

Rep: Reputation: 30
Re: Re: RPM install problem

Quote:
Originally posted by daveo
Try rpm -i filename.rpm

Hope it helps, but you've already try that huh ?
Hmm it's strange, if you already post this in the redhat mailgroups?
Maybe the redhat package manager is corrupt ? or do other rpm file work properly ?
 
Old 09-11-2003, 03:19 PM   #5
Killah
Member
 
Registered: Sep 2003
Location: Belgium, Alosta²
Distribution: Linux Mandrake 9.2
Posts: 66

Original Poster
Rep: Reputation: 15
No, I can't execute all Rpm files ..
Dammmmm
 
Old 09-11-2003, 03:26 PM   #6
daveo
Member
 
Registered: Sep 2003
Location: Holland
Distribution: Gentoo 1.4, Slackware
Posts: 196

Rep: Reputation: 30
Quote:
Originally posted by Killah
No, I can't execute all Rpm files ..
Dammmmm
You've also checked with df -h to make sure that the disk isn't full ?
 
Old 09-11-2003, 03:30 PM   #7
Killah
Member
 
Registered: Sep 2003
Location: Belgium, Alosta²
Distribution: Linux Mandrake 9.2
Posts: 66

Original Poster
Rep: Reputation: 15
No that isnt the problem
 
Old 09-11-2003, 03:44 PM   #8
daveo
Member
 
Registered: Sep 2003
Location: Holland
Distribution: Gentoo 1.4, Slackware
Posts: 196

Rep: Reputation: 30
Quote:
Originally posted by Killah
No that isnt the problem
Hmm is the rpm database ok?

Database maintenance:
rpm -i [--initdb]
rpm -i [--rebuilddb]

already check that ?
What version of rpm are you using ?
 
Old 09-11-2003, 04:03 PM   #9
Killah
Member
 
Registered: Sep 2003
Location: Belgium, Alosta²
Distribution: Linux Mandrake 9.2
Posts: 66

Original Poster
Rep: Reputation: 15
I dunno i'm a very newbie
how do you see that?
 
Old 09-11-2003, 04:05 PM   #10
Killah
Member
 
Registered: Sep 2003
Location: Belgium, Alosta²
Distribution: Linux Mandrake 9.2
Posts: 66

Original Poster
Rep: Reputation: 15
[killah@localhost killah]$ su
Password:
[root@localhost killah]# rpm -i [initdb]
error: File not found by glob: [initdb]
[root@localhost killah]# rpm -i [rebuilddb]
error: File not found by glob: [rebuilddb]
[root@localhost killah]#
 
Old 09-11-2003, 04:07 PM   #11
daveo
Member
 
Registered: Sep 2003
Location: Holland
Distribution: Gentoo 1.4, Slackware
Posts: 196

Rep: Reputation: 30
Quote:
Originally posted by Killah
[killah@localhost killah]$ su
Password:
[root@localhost killah]# rpm -i [initdb]
error: File not found by glob: [initdb]
[root@localhost killah]# rpm -i [rebuilddb]
error: File not found by glob: [rebuilddb]
[root@localhost killah]#
Please do man rpm ...

I'll get back to you, I need to update some pages ....
 
Old 09-11-2003, 04:11 PM   #12
Killah
Member
 
Registered: Sep 2003
Location: Belgium, Alosta²
Distribution: Linux Mandrake 9.2
Posts: 66

Original Poster
Rep: Reputation: 15
ok thx in advance
 
Old 09-12-2003, 01:12 AM   #13
daveo
Member
 
Registered: Sep 2003
Location: Holland
Distribution: Gentoo 1.4, Slackware
Posts: 196

Rep: Reputation: 30
Quote:
Originally posted by Killah
ok thx in advance
Ok I'm done, well try this the generate a new package database:

rpm --initdb

Hope this helps ...
 
Old 09-12-2003, 06:35 AM   #14
Killah
Member
 
Registered: Sep 2003
Location: Belgium, Alosta²
Distribution: Linux Mandrake 9.2
Posts: 66

Original Poster
Rep: Reputation: 15
[root@localhost root]# rpm --initdb
[root@localhost root]# rpm -initdb
[root@localhost root]#
[root@localhost root]#


don't do anything i guess
 
Old 09-12-2003, 06:39 AM   #15
Killah
Member
 
Registered: Sep 2003
Location: Belgium, Alosta²
Distribution: Linux Mandrake 9.2
Posts: 66

Original Poster
Rep: Reputation: 15
[root@localhost root]# cd /home/killah
[root@localhost killah]# ls
getting.started.rpm School winedefault.reg
msn wgi-1.13-src.tgz
rp8_linux20_libc6_i386_cs2.bin wgi.rev
[root@localhost killah]# rpm -ivh getting.started.rpm
warning: getting.started.rpm: V3 DSA signature: NOKEY, key ID db42a60e
Preparing... ########################################### [100%]
1:rhl-gsg-en ########################################### [100%]

ok this is what i get when i install an rpm right now

where is it installed noww???

sorry i'm a very very very noob
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem install rpm neonico Linux - Software 2 09-28-2004 08:25 AM
Install rpm problem ust Linux - Software 2 06-24-2004 09:20 PM
rpm install problem pasalacqua128 Linux - Software 2 06-03-2004 04:31 PM
RPM install problem RHGilman Linux - Newbie 4 05-02-2004 06:49 AM
rpm install problem wedgeworth Linux - Software 5 09-12-2003 02:30 PM


All times are GMT -5. The time now is 02:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration