LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-29-2003, 05:58 PM   #1
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
RPM giving incorect dependency info ?


Hi, im trying to install a program (rpm)
but if fails on a dependency,
but rpm -q says the dependency is present....

this is confusing.
here is the output which i think makes no snece, am i missing somthing ?

[root@localhost downloads]# rpm -ivh gtkam-20011114-fr1.i386.rpm
error: Failed dependencies:
gphoto >= 2.0beta3 is needed by gtkam-20011114-fr1

[root@localhost downloads]# rpm -qa | grep gphoto
gphoto2-2.1.0-7

as you can see, i have gphoto 2.1... which is greater than the needed 2.0 beta is it not ?
 
Old 10-29-2003, 06:01 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Yep.

It's greater.

But not equal.

And that's one of the beauties of RPM ;)

And you're right. It makes no sense.

Cheers,
Tink
 
Old 10-29-2003, 06:04 PM   #3
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Original Poster
Rep: Reputation: 47
But this symbol means Greater OR equal to doesnt it ?

every other program ive installed has allowed this type of version difference.

so i need to go back a few versions then, that sucks
 
Old 10-29-2003, 06:06 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
I've had issues with ssl versions in rpm.

However, in your case the problem might
be that you need gphoto, not gphoto2 ;)

Cheers,
Tink
 
Old 10-31-2003, 09:22 AM   #5
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Original Poster
Rep: Reputation: 47
i thought that, but the rpm description on rpmfind.net says it is a gui for gphoto2.

plus thying to install ghphoto gave a million and one conflictions.
 
Old 10-31-2003, 09:45 AM   #6
musrum
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 112

Rep: Reputation: 15
Well, you can spin the prayer wheel try:

rpm -ivh --nodeps gtkam-20011114-fr1.i386.rpm
 
Old 10-31-2003, 05:57 PM   #7
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
That version of gtkam is very old, you need one that depends on gphoto2
 
Old 11-01-2003, 10:05 PM   #8
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Original Poster
Rep: Reputation: 47
the one i have does dep on gphoto 2.
 
Old 11-01-2003, 10:06 PM   #9
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Original Poster
Rep: Reputation: 47
well, i got the thing working anyway, just went back the the older version (that came with redhat 9)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
RPM dependency UltraSoul Linux - Software 9 07-09-2005 02:14 PM
rpm dependency questions giovannym Linux - Newbie 1 07-08-2005 06:24 PM
looking for rpm dependency files varunnarang Linux - Software 1 12-22-2004 12:09 AM
RPM dependency help (apt 4 rpm) Cubsy Linux - Software 4 10-08-2004 05:15 PM
Help : rpm dependency error when install video driver rpm ymdwxm Linux - Software 1 04-04-2003 05:55 PM


All times are GMT -5. The time now is 09:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration