LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-20-2012, 08:20 AM   #1
dann_radkov
Member
 
Registered: Sep 2011
Posts: 52

Rep: Reputation: Disabled
RPM conflicts during installation


Hello Guys ,
Based on the following below I understand that :
1)ipa-python requires a package that is not present on my REPO1 (libipa_hbac-python)

2)ipa-client has a dependency problem since sssd needs to be updated.


--> Running transaction check
---> Package dhcp-common.x86_64 12:4.1.1-25.P1.el6_2.1 will be installed
---> Package ipa-client.x86_64 0:2.1.3-9.el6 will be an update
--> Processing Dependency: sssd >= 1.5.1-60 for package: ipa-client-2.1.3-9.el6.x86_64
---> Package ipa-python.x86_64 0:2.1.3-9.el6 will be an update
--> Processing Dependency: libipa_hbac-python for package: ipa-python-2.1.3-9.el6.x86_64
--> Finished Dependency Resolution
Error: Package: ipa-python-2.1.3-9.el6.x86_64 (REPO1)
Requires: libipa_hbac-python
Error: Package: ipa-client-2.1.3-9.el6.x86_64 (REPO1)
Requires: sssd >= 1.5.1-60
Installed: sssd-1.5.1-34.el6_1.3.x86_64 (@anaconda-RedHatEnterpriseLinux-201105101844.x86_64/6.1)
sssd = 1.5.1-34.el6_1.3
You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
RHEL6SERVER2011.x86_64 is a duplicate with RHEL6SERVER-2011security.x86_64
Installation completed
No updates were applied to this system.


The following kits were retrieved but not installed:

bind-9.7.3-2.el6_1.P3.3.x86_64.rpm
bind-chroot-9.7.3-2.el6_1.P3.3.x86_64.rpm
bind-devel-9.7.3-2.el6_1.P3.3.i686.rpm
bind-devel-9.7.3-2.el6_1.P3.3.x86_64.rpm
bind-libs-9.7.3-2.el6_1.P3.3.i686.rpm
bind-libs-9.7.3-2.el6_1.P3.3.x86_64.rpm
bind-sdb-9.7.3-2.el6_1.P3.3.x86_64.rpm
bind-utils-9.7.3-2.el6_1.P3.3.x86_64.rpm
cups-1.4.2-44.el6.x86_64.rpm
cups-devel-1.4.2-44.el6.i686.rpm
cups-devel-1.4.2-44.el6.x86_64.rpm

and so on and so on....

DO I understand right ?
So I have to 1)blacklist because there is no libipa_hbac-python available
2)blacklist ipa-client or get a newer version of sssd
 
Old 04-20-2012, 09:46 AM   #2
amani
Senior Member
 
Registered: Jul 2006
Location: Kolkata, India
Distribution: Debian 64-bit GNU/Linux, Kubuntu64, Fedora QA, Slackware,
Posts: 2,766

Rep: Reputation: Disabled
0. yum clean all
1. remove the files /var/lib/rpm/_*.*
2. rpm --rebuilddb -vv
3. yum update
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rpm conflicts alaios SUSE / openSUSE 7 02-24-2006 12:50 AM
rpm + conflicts varun_saa Mandriva 1 12-18-2005 04:11 AM
rpm conflicts sottesen Linux - Software 2 07-07-2004 01:21 PM
2.6.0 and RPM conflicts??? JimDog Linux - Software 5 12-27-2003 08:06 PM
Apt rpm conflicts??? thcmwz Linux - Software 6 09-10-2003 06:00 AM


All times are GMT -5. The time now is 01:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration