LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   RPM Conflicting Package Error (http://www.linuxquestions.org/questions/linux-newbie-8/rpm-conflicting-package-error-225431/)

kougar 09-01-2004 06:55 PM

RPM Conflicting Package Error
 
When attempting to install things using RPMs, I occasionally run into errors saying that a package I'm installing conflicts with an existing one, and it aborts. When this happens, is there anything I can do to bypass, or do I need to remove the conflicting package?

jailbait 09-01-2004 08:21 PM

"When attempting to install things using RPMs, I occasionally run into errors saying that a package I'm installing conflicts with an existing one, and it aborts. When this happens, is there anything I can do to bypass, or do I need to remove the conflicting package?"

What this error message usually means is that the two packages have one or more files in common. You can list the files in the installed package with:

rpm -ql ipackagename | less

You can list the files in the second package that you are trying to install with:

rpm -qpl /pathname/spackagename | less

Check the two lists for duplicate file names. If there are duplicate file names you can replace the existing files with the new files with:

rpm --force -i /pathname/spackagename

Whether the new files will work OK with the rest of the old package is anybody's guess.

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites


All times are GMT -5. The time now is 10:35 PM.